summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-07-15 05:20:28 +0200
committerCarsten Teibes2014-07-15 05:20:28 +0200
commit17a760ac1bfe608e84b6d370e56101ac42d4ffd0 (patch)
treee12f9c5fca12a923c49106cec5fb64b44837246d
downloadaur-openbor-git.tar.gz
[add] openbor-git
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD55
-rw-r--r--openbor.desktop8
-rw-r--r--openbor.install13
-rw-r--r--openbor.sh7
5 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..651449ab2f8c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = openbor-git
+ pkgdesc = An open source, moddable fighting game engine (aka Beats of Rage), rofl0r's optimized fork
+ pkgver = r473.afa9362
+ pkgrel = 1
+ url = https://github.com/rofl0r/openbor
+ install = openbor.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = yasm
+ makedepends = imagemagick
+ makedepends = glu
+ depends = bash
+ depends = sdl_gfx
+ depends = libvorbis
+ depends = libpng
+ optdepends = libgl: OpenGL video mode
+ conflicts = openbor-svn
+ source = openbor::git+https://github.com/rofl0r/openbor.git
+ source = openbor.desktop
+ source = openbor.sh
+ sha256sums = SKIP
+ sha256sums = 92c2c8fa5727ddf76421bdb54589d898679b12f4201931f2861b7fa1b613097b
+ sha256sums = fc584ea761ba1307e4568c2ffb78731b848d27ed231bdc2149ece96304a55d81
+
+pkgname = openbor-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a98cd34bd988
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+
+pkgname=openbor-git
+pkgver=r473.afa9362
+pkgrel=1
+pkgdesc="An open source, moddable fighting game engine (aka Beats of Rage), rofl0r's optimized fork"
+arch=('i686' 'x86_64')
+url="https://github.com/rofl0r/openbor"
+license=('BSD')
+depends=('bash' 'sdl_gfx' 'libvorbis' 'libpng')
+makedepends=('git' 'yasm' 'imagemagick' 'glu')
+optdepends=('libgl: OpenGL video mode')
+conflicts=('openbor-svn')
+install=openbor.install
+source=(openbor::'git+https://github.com/rofl0r/openbor.git'
+ 'openbor.desktop'
+ 'openbor.sh')
+sha256sums=('SKIP'
+ '92c2c8fa5727ddf76421bdb54589d898679b12f4201931f2861b7fa1b613097b'
+ 'fc584ea761ba1307e4568c2ffb78731b848d27ed231bdc2149ece96304a55d81')
+
+pkgver() {
+ cd openbor
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ # convert icon
+ convert -resize 48x48 openbor/resources/OpenBOR_Icon_128x128.png openbor.png
+}
+
+build() {
+ cd openbor
+ make
+
+ # build tools
+ cd tools/borpak
+ ./build-linux.sh
+}
+
+package() {
+ cd openbor
+
+ # launcher + binaries
+ install -Dm755 ../openbor.sh "$pkgdir"/usr/bin/openbor
+ install -Dm755 OpenBOR "$pkgdir"/usr/bin/OpenBOR.real
+ install -Dm755 tools/borpak/borpak "$pkgdir"/usr/bin/borpak
+ # doc
+ install -Dm644 README "$pkgdir"/usr/share/doc/$pkgname/README
+ # .desktop entry
+ install -Dm644 ../openbor.desktop "$pkgdir"/usr/share/applications/openbor.desktop
+ install -Dm644 ../openbor.png "$pkgdir"/usr/share/pixmaps/openbor.png
+ # license
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/openbor.desktop b/openbor.desktop
new file mode 100644
index 000000000000..f590df927af7
--- /dev/null
+++ b/openbor.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=OpenBOR
+Comment=Open Beats of Rage
+Icon=openbor
+Exec=openbor
+Terminal=false
+Categories=Game;
diff --git a/openbor.install b/openbor.install
new file mode 100644
index 000000000000..e617e6ffc09d
--- /dev/null
+++ b/openbor.install
@@ -0,0 +1,13 @@
+
+post_install() {
+ echo "This package contains a launcher script that will setup OpenBOR to use the"
+ echo "folder ~/.OpenBOR for all data files. Put your PAK files and configs there."
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ echo "Remember to clean up your ~/.OpenBOR folder."
+}
diff --git a/openbor.sh b/openbor.sh
new file mode 100644
index 000000000000..d99583cee6ec
--- /dev/null
+++ b/openbor.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+# simple launcher by carstene1ns, 2014
+
+mkdir -p "$HOME"/.OpenBOR
+
+cd "$HOME"/.OpenBOR && exec /usr/bin/OpenBOR.real