aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrmat2016-12-01 04:27:14 +0100
committergrmat2016-12-01 04:27:40 +0100
commit0fb52b2d67daf10ab8d513de5515d3b370d42448 (patch)
tree203c8ec5cde133c0f53049c7b6196dd0f9eb2393
downloadaur-0fb52b2d67daf10ab8d513de5515d3b370d42448.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD52
-rw-r--r--README.md20
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..151b564463c7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = amdgpocl
+ pkgdesc = OpenCL userspace driver as provided in the amdgpu-pro driver stack. This package is intended to work along with the free amdgpu stack.
+ pkgver = 16.40.348864
+ pkgrel = 1
+ url = http://www.amd.com
+ arch = x86_64
+ license = custom:AMD
+ makedepends = wget
+ source = https://www2.ati.com/drivers/linux/ubuntu/amdgpu-pro-16.40-348864.tar.xz
+ sha256sums = 59d6b1d975164ff45f6e6be5af6bcc061bf9ef6378ac5757bdb4e67840a706b0
+
+pkgname = amdgpocl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b88914a4c418
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: grmat <grmat@sub.red>
+
+pkgname=amdgpocl
+pkgdesc="OpenCL userspace driver as provided in the amdgpu-pro driver stack. This package is intended to work along with the free amdgpu stack."
+pkgver=16.40.348864
+pkgrel=1
+arch=('x86_64')
+url='http://www.amd.com'
+license=('custom:AMD')
+makedepends=('wget')
+
+DLAGENTS='https::/usr/bin/wget --referer http://support.amd.com/en-us/kb-articles/Pages/AMD-Radeon-GPU-PRO-Linux-Beta-Driver%E2%80%93Release-Notes.aspx -N %u'
+
+prefix='amdgpu-pro-'
+major='16.40'
+minor='348864'
+shared="opt/amdgpu-pro/lib/x86_64-linux-gnu"
+
+source=("https://www2.ati.com/drivers/linux/ubuntu/${prefix}${major}-${minor}.tar.xz")
+sha256sums=('59d6b1d975164ff45f6e6be5af6bcc061bf9ef6378ac5757bdb4e67840a706b0')
+
+pkgver() {
+ echo "${major}.${minor}"
+}
+
+build() {
+ mkdir "${srcdir}/opencl"
+ cd "${srcdir}/opencl"
+ ar x "${srcdir}/${prefix}${major}-${minor}/opencl-amdgpu-pro-icd_${major}-${minor}_amd64.deb"
+ tar xJf data.tar.xz
+ cd ${shared}
+ sed -i "s|libdrm_amdgpu|libdrm_amdgpo|g" libamdocl64.so
+
+ mkdir "${srcdir}/libdrm"
+ cd "${srcdir}/libdrm"
+ ar x "${srcdir}/${prefix}${major}-${minor}/libdrm-amdgpu-pro-amdgpu1_2.4.66-${minor}_amd64.deb"
+ tar xJf data.tar.xz
+ cd ${shared}
+ rm "libdrm_amdgpu.so.1"
+ mv "libdrm_amdgpu.so.1.0.0" "libdrm_amdgpo.so.1.0.0"
+ ln -s "libdrm_amdgpo.so.1.0.0" "libdrm_amdgpo.so.1"
+}
+
+package() {
+ mv "${srcdir}/opencl/etc" "${pkgdir}/"
+ mkdir -p ${pkgdir}/usr/lib
+ mv "${srcdir}/opencl/${shared}/libamdocl64.so" "${pkgdir}/usr/lib/"
+ mv "${srcdir}/opencl/${shared}/libamdocl12cl64.so" "${pkgdir}/usr/lib/"
+ mv "${srcdir}/libdrm/${shared}/libdrm_amdgpo.so.1.0.0" "${pkgdir}/usr/lib/"
+ mv "${srcdir}/libdrm/${shared}/libdrm_amdgpo.so.1" "${pkgdir}/usr/lib/"
+}
+
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..9258d947f9d2
--- /dev/null
+++ b/README.md
@@ -0,0 +1,20 @@
+# amdgpocl
+OpenCL on amdgpu for Arch
+
+This package allows the usage of AMD's proprietary user-space OpenCL driver along with the free amdgpu stack. It should work with upstream amdgpu and Mesa. Inspired by [this blog post](http://www.gearsongallium.com/?p=2960).
+
+## Hardware support
+
+This *should* work with all amdgpu-enabled GCN GPUs. However, I have no hardware to actually test it.
+
+If you are using CIK (Sea Islands GPU), you'll need a custom kernel. Check the [aur](https://aur.archlinux.org/packages/linux-cik/) or compile your own.
+
+Currently tested with Kernel 4.8.6 and Hawaii. Blender Cycles and Luxmark seem to work without any problems.
+
+## What this is not
+
+You are not getting Vulkan support, faster 3D rendering or unicorns.
+
+If you are looking for the full amdgpu-pro stack, including proprietary OpenGL and Vulkan implementations, move over to the [aur](https://aur.archlinux.org/pkgbase/amdgpu-pro-installer/).
+
+Expect maintainance of this package to be dropped when there is free OpenCL support on top of the [ROC](https://radeonopencompute.github.io/) stack.