summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormrdotx2023-01-26 11:27:07 +0100
committermrdotx2023-01-26 11:27:07 +0100
commitdd0558b5553d79b825964fdbdf8af3e53787bad1 (patch)
treefae6a8a924a320c0e8e837ddd2f02f0eafd86389
parent6ffd13fcee769c1f318a6abb9f71bf7c5aa34eec (diff)
downloadaur-opendoas-sudo.tar.gz
Add a larger comment for clarification
-rw-r--r--PKGBUILD19
1 files changed, 15 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5bd80b480af3..7b56149686a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: samsapti <sam at sapti dot me>
+# Maintainer: mrdotx <klassiker@gmx.de>
+# Contributor: samsapti <sam at sapti dot me>
# Contributor: Ultracoolguy <dummyd241 at gmaildotcom>
# Quick thanks to deuill, creator of rofi-dmenu
pkgname=opendoas-sudo
@@ -9,10 +10,20 @@ arch=('any')
url="https://github.com/Duncaen/OpenDoas"
license=('MIT')
depends=('opendoas')
-provides=('sudo') # makes sudo appear as a satisfied dependency for other packages
+provides=('sudo')
conflicts=('sudo')
package() {
- install -d "$pkgdir"/usr/bin
- ln -s $(which doas) "$pkgdir"/usr/bin/sudo
+ #################################################################
+ # #
+ # This package is not just a symlink. It provides/conflicts #
+ # sudo, which means it replaces/uninstalls sudo. This cannot #
+ # be done with a simple symlink, as many packages have #
+ # sudo as dependency. Please do not delete this package again. #
+ # Thanks! #
+ # #
+ #################################################################
+
+ install -d "$pkgdir"/usr/bin
+ ln -s $(which doas) "$pkgdir"/usr/bin/sudo
}