summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Edwards2024-01-13 12:02:47 -0800
committerWilliam Edwards2024-01-13 12:02:47 -0800
commit8dc6a728678b6f9fb1aaf1ebdbf7aedaa7af2d08 (patch)
treec36ede6f0ba91a27b593e53c878ff228242dcf9f
parent7ef3d0b07a1db6c2391397d9489330024fab3088 (diff)
downloadaur-8dc6a728678b6f9fb1aaf1ebdbf7aedaa7af2d08.tar.gz
Update to v0.29.1 and include Dockerfile to test build in Docker
-rw-r--r--.SRCINFO10
-rw-r--r--Dockerfile13
-rw-r--r--Makefile17
-rw-r--r--PKGBUILD10
4 files changed, 40 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6ea5a3cb006..38c19d6b9966 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = opengamepadui-bin
pkgdesc = Open source game launcher
- pkgver = v0.28.0
- pkgrel = 3
+ pkgver = v0.29.1
+ pkgrel = 1
url = https://github.com/ShadowBlip/OpenGamepadUI
arch = x86_64
license = GPL
@@ -14,7 +14,6 @@ pkgbase = opengamepadui-bin
depends = libxau
depends = libxdmcp
depends = gamescope
- depends = ryzenadj
depends = vulkan-tools
depends = mesa-utils
optdepends = firejail
@@ -23,10 +22,11 @@ pkgbase = opengamepadui-bin
optdepends = networkmanager
optdepends = bluez
optdepends = dbus
+ optdepends = powerstation
provides = opengamepadui
conflicts = opengamepadui-git
- source = opengamepadui-v0.28.0.tar.gz::https://github.com/ShadowBlip/OpenGamepadUI/releases/download/v0.28.0/opengamepadui.tar.gz
- sha256sums = 6f9b36790eac6d8a5b263352ce43e605a8d2ede73366d210f4cfa9b030c26408
+ source = opengamepadui-v0.29.1.tar.gz::https://github.com/ShadowBlip/OpenGamepadUI/releases/download/v0.29.1/opengamepadui.tar.gz
+ sha256sums = 9706da61d1a3de477564e9e6c3a456ec08d00d4aadccf8014c3a8032b3ec6000
pkgname = opengamepadui-bin
options = !strip
diff --git a/Dockerfile b/Dockerfile
new file mode 100644
index 000000000000..2e5a2ef5425d
--- /dev/null
+++ b/Dockerfile
@@ -0,0 +1,13 @@
+FROM archlinux:latest
+
+RUN pacman --noconfirm -Sy fakeroot binutils make
+RUN pacman --noconfirm -S \
+ libx11 \
+ libxres \
+ libxcb \
+ libxext \
+ libxau \
+ libxdmcp \
+ gamescope \
+ vulkan-tools \
+ mesa-utils
diff --git a/Makefile b/Makefile
index 7d2f3c0fee1b..3a1f7f788a45 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,23 @@
+IMAGE_NAME ?= makepkg.local
+IMAGE_TAG ?= latest
+UID = $(shell id -u)
+GID = $(shell id -g)
+
+.PHONY: build
build: clean
makepkg
makepkg --printsrcinfo > .SRCINFO
+.PHONY: clean
clean:
rm -rf *.tar.* *.pkg.* src pkg
+
+.PHONY: in-docker
+in-docker: clean
+ docker build -t $(IMAGE_NAME):$(IMAGE_TAG) .
+ docker run -it --rm \
+ --volume $(PWD):/src \
+ --workdir /src \
+ --user $(UID):$(GID) \
+ $(IMAGE_NAME):$(IMAGE_TAG) \
+ make build
diff --git a/PKGBUILD b/PKGBUILD
index 965e8ac887c4..494e93e892a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: Derek J. Clark <derekjohn.clark@gmail.com>
pkgname=opengamepadui-bin
_pkgbase=opengamepadui
-pkgver=v0.28.0
-pkgrel=3
+pkgver=v0.29.1
+pkgrel=1
pkgdesc="Open source game launcher"
arch=('x86_64')
url="https://github.com/ShadowBlip/OpenGamepadUI"
license=('GPL')
depends=('glibc' 'gcc-libs' 'libx11' 'libxres' 'libxcb' 'libxext' 'libxau'
- 'libxdmcp' 'gamescope' 'ryzenadj' 'vulkan-tools'
+ 'libxdmcp' 'gamescope' 'vulkan-tools'
'mesa-utils'
)
-optdepends=('firejail' 'bubblewrap' 'wireplumber' 'networkmanager' 'bluez' 'dbus')
+optdepends=('firejail' 'bubblewrap' 'wireplumber' 'networkmanager' 'bluez' 'dbus' 'powerstation')
provides=('opengamepadui')
conflicts=('opengamepadui-git')
source=(opengamepadui-$pkgver.tar.gz::https://github.com/ShadowBlip/OpenGamepadUI/releases/download/$pkgver/opengamepadui.tar.gz)
-sha256sums=('6f9b36790eac6d8a5b263352ce43e605a8d2ede73366d210f4cfa9b030c26408')
+sha256sums=('9706da61d1a3de477564e9e6c3a456ec08d00d4aadccf8014c3a8032b3ec6000')
prepare() {
cd "$srcdir/${_pkgbase}"