summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Hanna2015-11-30 14:49:15 +0100
committerSimon Hanna2015-11-30 14:49:15 +0100
commit0e9a0dff624b3ee048b3381ce14867b8d62a5c14 (patch)
tree7ec761a14dc37af6357a3213fe15629cd31a04f4
parenta8c611cb254d46820b62a72e66d48d88d7375b16 (diff)
downloadaur-0e9a0dff624b3ee048b3381ce14867b8d62a5c14.tar.gz
upgpkg: openlp 2.2.1-1
upstream release
-rw-r--r--.SRCINFO43
-rw-r--r--PKGBUILD32
2 files changed, 29 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb1c7d438c5b..b3f6dee9a8cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,41 +1,26 @@
-# Generated by makepkg 4.2.0
-# Mon Feb 16 23:51:05 UTC 2015
pkgbase = openlp
pkgdesc = Church presentation software.
- pkgver = 2.0.5
- pkgrel = 4
+ pkgver = 2.2.1
+ pkgrel = 1
url = http://openlp.org/
install = openlp.install
arch = any
license = GPLv2
makedepends = qt5-tools
- depends = qt4
- depends = python2
- depends = python2-pyqt4
- depends = python2-setuptools
- depends = phonon-qt4
- depends = python2-chardet
- depends = python2-lxml
- depends = python2-beautifulsoup4
- depends = python2-pyicu
- depends = python2-sqlalchemy
- depends = python2-sip
- depends = python2-pysqlite-legacy
- depends = python2-pyenchant
- depends = python2-mako
- depends = python2-alembic
- depends = python2-xdg
- depends = python2-beautifulsoup3
- depends = python2-migrate
- optdepends = libreoffice-impress: display impress presentations
+ depends = python
+ depends = python-pyqt4
+ depends = phonon
+ depends = python-chardet
+ depends = python-lxml
+ depends = python-beautifulsoup4
+ depends = python-pyenchant
+ depends = python-alembic
+ optdepends = libreoffice-fresh: display impress presentations
optdepends = vlc: play multimedia
- conflicts = openlp-bzr
- conflicts = openlp-dev
- source = http://downloads.sourceforge.net/project/openlp/openlp/2.0.5/OpenLP-2.0.5.tar.gz
+ optdepends = mupdf: display pdfs
+ source = https://get.openlp.org/2.2.1/OpenLP-2.2.1.tar.gz
source = openlp.sh
- md5sums = 539626eb8da337814d64e82329e22e78
- md5sums = 56908c5e7807fe2a384aa55de3735f32
- sha1sums = 59dff57fff62ce406b180585dc5dcbd47d0e1c72
+ sha1sums = 5d15ebdba8f149e7453cf8a71ca7beef913d9b3a
sha1sums = d40794631c19688eb1971eadeb108c5a2cc69506
pkgname = openlp
diff --git a/PKGBUILD b/PKGBUILD
index 2e6218b6a4e7..99105006ff8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,31 @@
# Maintainer: Garrett <floft.net/contact>
pkgname=openlp
-pkgver=2.0.5
-pkgrel=4
+pkgver=2.2.1
+pkgrel=1
pkgdesc="Church presentation software."
arch=('any')
-conflicts=('openlp-bzr' 'openlp-dev')
url='http://openlp.org/'
license=('GPLv2')
makedepends=('qt5-tools')
-depends=('qt4' 'python2' 'python2-pyqt4' 'python2-setuptools' 'phonon-qt4'
- 'python2-chardet' 'python2-lxml' 'python2-beautifulsoup4' 'python2-pyicu'
- 'python2-sqlalchemy' 'python2-sip' 'python2-pysqlite-legacy'
- 'python2-pyenchant' 'python2-mako' 'python2-alembic'
- 'python2-xdg' 'python2-beautifulsoup3' 'python2-migrate')
-optdepends=('libreoffice-impress: display impress presentations'
- 'vlc: play multimedia')
+depends=('python' 'python-pyqt4' 'phonon'
+ 'python-chardet' 'python-lxml'
+ 'python-beautifulsoup4' 'python-pyenchant'
+ 'python-alembic'
+ )
+optdepends=('libreoffice-fresh: display impress presentations'
+ 'vlc: play multimedia'
+ 'mupdf: display pdfs')
install=openlp.install
-source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/OpenLP-$pkgver.tar.gz openlp.sh)
-md5sums=('539626eb8da337814d64e82329e22e78'
- '56908c5e7807fe2a384aa55de3735f32')
-sha1sums=('59dff57fff62ce406b180585dc5dcbd47d0e1c72'
+source=(https://get.openlp.org/$pkgver/OpenLP-$pkgver.tar.gz openlp.sh)
+sha1sums=('5d15ebdba8f149e7453cf8a71ca7beef913d9b3a'
'd40794631c19688eb1971eadeb108c5a2cc69506')
package() {
cd "$srcdir/OpenLP-$pkgver"
- python2 setup.py install --root="$pkgdir/" --optimize=1
- mv "$pkgdir/usr/bin/openlp"{.pyw,}
+ python setup.py install --root="$pkgdir/" --optimize=1
+ mv "$pkgdir/usr/bin/openlp"{.py,}
- echo "$pkgver" > "$pkgdir/usr/lib/python2.7/site-packages/openlp/.version"
+ echo "$pkgver" > "$pkgdir/usr/lib/python3.5/site-packages/openlp/.version"
install -Dm0755 "$srcdir/openlp.sh" "$pkgdir/etc/profile.d/openlp.sh"
install -Dm0644 "resources/openlp.desktop" "$pkgdir/usr/share/applications/openlp.desktop"