summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark C2024-03-17 08:16:23 -0400
committerMark C2024-03-17 08:16:23 -0400
commit2d5db7a274172a54692e94f2e710ce7c430d9c20 (patch)
tree0103f6c8392c320fe0c9b1a626a86cee4f6e1fe3
parent3faa921b29b07b764a5a85f1355e2f5143b5ac21 (diff)
downloadaur-2d5db7a274172a54692e94f2e710ce7c430d9c20.tar.gz
Upstream upgrade to 3.1.0
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD65
2 files changed, 51 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96e7070d469b..279356d1b77e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openlp
pkgdesc = Church presentation software.
- pkgver = 3.0.2
- pkgrel = 2
+ pkgver = 3.1.0
+ pkgrel = 1
url = http://openlp.org/
install = openlp.install
arch = any
@@ -15,25 +15,31 @@ pkgbase = openlp
depends = phonon-qt5
depends = python-chardet
depends = python-lxml
- depends = python-qrcode
depends = python-beautifulsoup4
depends = python-pyenchant
- depends = python-qtawesome
- depends = python-alembic
+ depends = python-mako
+ depends = python-appdirs
+ depends = python-sqlalchemy
+ depends = python-pyodbc
+ depends = python-pyqt5-webengine
depends = qt5-multimedia
- depends = qt5-webkit
- depends = python-pyicu
- depends = python-waitress
+ depends = python-pyqt5-webengine
+ depends = python-alembic
+ depends = python-qtawesome
depends = python-websockets
- depends = python-pillow<10.0
- depends = python-pymupdf
+ depends = python-flask
+ depends = python-flask-cors
+ depends = python-webob
+ depends = python-waitress
+ depends = python-qrcode
+ depends = python-pymediainfo
optdepends = libreoffice-fresh: Display impress presentations
optdepends = python-vlc: Multimedia playback
optdepends = python-mysql-connector: Use a mysql/mariadb database
optdepends = python-psycopg2: Use a postgresql database
- source = https://get.openlp.org/3.0.2/OpenLP-3.0.2.tar.gz
+ source = https://gitlab.com/openlp/openlp/-/archive/3.1.0/openlp-3.1.0.tar.gz
source = openlp.sh
- sha256sums = edf03061e9e1c494835657bd4924c07d862aea1997832d2c9e56e3286fce1d2b
+ sha256sums = d40baf9698d84fbcaf1cc3624aca3c157de6e25dbf8b09f54037cd98632ec939
sha256sums = 19c2f3c622585bf308efc259013fb5518feaf8cf14b51613e1e71778fcc2e8cf
pkgname = openlp
diff --git a/PKGBUILD b/PKGBUILD
index b7804fb4ff92..1d4f7aa5a642 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,51 +3,52 @@
# Contributor: Macxcool <macx coool at coolnet dot xyz>
pkgname=openlp
-pkgver=3.0.2
-pkgrel=2
+pkgver=3.1.0
+pkgrel=1
pkgdesc="Church presentation software."
arch=('any')
url='http://openlp.org/'
license=('GPLv2')
makedepends=('qt5-tools' 'python-pip' 'python-setuptools')
depends=('python>=3.10' 'python<3.12' 'python-pyqt5' 'phonon-qt5'
- 'python-chardet' 'python-lxml' 'python-qrcode'
- 'python-beautifulsoup4' 'python-pyenchant' 'python-qtawesome'
- 'python-alembic' 'qt5-multimedia' 'qt5-webkit' 'python-pyicu'
- 'python-waitress' 'python-websockets' 'python-pillow<10.0'
- 'python-pymupdf')
+ 'python-chardet' 'python-lxml' 'python-beautifulsoup4' 'python-pyenchant'
+ 'python-mako' 'python-appdirs' 'python-sqlalchemy' 'python-pyodbc'
+ 'python-pyqt5-webengine' 'qt5-multimedia' 'python-pyqt5-webengine' 'python-alembic'
+ 'python-qtawesome' 'python-websockets' 'python-flask' 'python-flask-cors'
+ 'python-webob' 'python-waitress' 'python-qrcode' 'python-pymediainfo')
optdepends=('libreoffice-fresh: Display impress presentations'
'python-vlc: Multimedia playback'
'python-mysql-connector: Use a mysql/mariadb database'
'python-psycopg2: Use a postgresql database')
install=openlp.install
-source=("https://get.openlp.org/${pkgver}/OpenLP-${pkgver}.tar.gz" "openlp.sh")
-sha256sums=('edf03061e9e1c494835657bd4924c07d862aea1997832d2c9e56e3286fce1d2b'
+source=("https://gitlab.com/openlp/openlp/-/archive/${pkgver}/openlp-${pkgver}.tar.gz" "openlp.sh")
+
+sha256sums=('d40baf9698d84fbcaf1cc3624aca3c157de6e25dbf8b09f54037cd98632ec939'
'19c2f3c622585bf308efc259013fb5518feaf8cf14b51613e1e71778fcc2e8cf')
package() {
- cd "${srcdir}"
- python setup.py install --root="${pkgdir}/" --optimize=1
-
- #remove tests
- pyVer=$(python --version | cut -d ' ' -f 2 | grep -Eo '[0-9]\.[0-9]+')
- rm -rf "${pkgdir}/usr/lib/python${pyVer}/site-packages/tests"
-
- echo "${pkgver}" > "${pkgdir}/usr/lib/python${pyVer}/site-packages/openlp/.version"
-
- install -Dm0755 "${srcdir}/openlp.sh" "${pkgdir}/etc/profile.d/openlp.sh"
- install -Dm0644 "resources/openlp.desktop" "${pkgdir}/usr/share/applications/openlp.desktop"
- install -Dm0644 "resources/images/openlp-logo.svg" "${pkgdir}/usr/share/pixmaps/openlp.svg"
- install -Dm0644 "resources/images/openlp-logo-48x48.png" "${pkgdir}/usr/share/pixmaps/openlp.png"
-
- #translations
- tsrcdir="${srcdir}/resources/i18n"
- tdestdir="${pkgdir}/usr/share/$pkgname/i18n"
- mkdir -p "${tdestdir}"
- cd "${tsrcdir}"
-
- for file in *.ts; do
- lconvert -i "${file}" -o "${tdestdir}/${file%%ts}qm"
- done
+ cd "${srcdir}/openlp-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+
+ #remove tests
+ pyVer=$(python --version | cut -d ' ' -f 2 | grep -Eo '[0-9]\.[0-9]+')
+ rm -rf "${pkgdir}/usr/lib/python${pyVer}/site-packages/tests"
+
+ echo "${pkgver}" > "${pkgdir}/usr/lib/python${pyVer}/site-packages/openlp/.version"
+
+ install -Dm0755 "${srcdir}/openlp.sh" "${pkgdir}/etc/profile.d/openlp.sh"
+ install -Dm0644 "resources/openlp.desktop" "${pkgdir}/usr/share/applications/openlp.desktop"
+ install -Dm0644 "resources/images/openlp-logo.svg" "${pkgdir}/usr/share/pixmaps/openlp.svg"
+ install -Dm0644 "resources/images/openlp-logo-48x48.png" "${pkgdir}/usr/share/pixmaps/openlp.png"
+
+ #translations
+ tsrcdir="${srcdir}/openlp-${pkgver}/resources/i18n"
+ tdestdir="${pkgdir}/usr/share/$pkgname/i18n"
+ mkdir -p "${tdestdir}"
+ cd "${tsrcdir}"
+
+ for file in *.ts; do
+ lconvert -i "${file}" -o "${tdestdir}/${file%%ts}qm"
+ done
}