summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGarrett Wilson2015-08-10 19:27:32 -0500
committerGarrett Wilson2015-08-10 19:27:32 -0500
commita8c611cb254d46820b62a72e66d48d88d7375b16 (patch)
tree72a8ae66430fb3c619cb0b131cc5d66e91449f35
downloadaur-a8c611cb254d46820b62a72e66d48d88d7375b16.tar.gz
Initial
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD46
-rw-r--r--openlp.install11
-rw-r--r--openlp.sh4
4 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bb1c7d438c5b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+# Generated by makepkg 4.2.0
+# Mon Feb 16 23:51:05 UTC 2015
+pkgbase = openlp
+ pkgdesc = Church presentation software.
+ pkgver = 2.0.5
+ pkgrel = 4
+ url = http://openlp.org/
+ install = openlp.install
+ arch = any
+ license = GPLv2
+ makedepends = qt5-tools
+ depends = qt4
+ depends = python2
+ depends = python2-pyqt4
+ depends = python2-setuptools
+ depends = phonon-qt4
+ depends = python2-chardet
+ depends = python2-lxml
+ depends = python2-beautifulsoup4
+ depends = python2-pyicu
+ depends = python2-sqlalchemy
+ depends = python2-sip
+ depends = python2-pysqlite-legacy
+ depends = python2-pyenchant
+ depends = python2-mako
+ depends = python2-alembic
+ depends = python2-xdg
+ depends = python2-beautifulsoup3
+ depends = python2-migrate
+ optdepends = libreoffice-impress: display impress presentations
+ optdepends = vlc: play multimedia
+ conflicts = openlp-bzr
+ conflicts = openlp-dev
+ source = http://downloads.sourceforge.net/project/openlp/openlp/2.0.5/OpenLP-2.0.5.tar.gz
+ source = openlp.sh
+ md5sums = 539626eb8da337814d64e82329e22e78
+ md5sums = 56908c5e7807fe2a384aa55de3735f32
+ sha1sums = 59dff57fff62ce406b180585dc5dcbd47d0e1c72
+ sha1sums = d40794631c19688eb1971eadeb108c5a2cc69506
+
+pkgname = openlp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e6218b6a4e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Garrett <floft.net/contact>
+pkgname=openlp
+pkgver=2.0.5
+pkgrel=4
+pkgdesc="Church presentation software."
+arch=('any')
+conflicts=('openlp-bzr' 'openlp-dev')
+url='http://openlp.org/'
+license=('GPLv2')
+makedepends=('qt5-tools')
+depends=('qt4' 'python2' 'python2-pyqt4' 'python2-setuptools' 'phonon-qt4'
+ 'python2-chardet' 'python2-lxml' 'python2-beautifulsoup4' 'python2-pyicu'
+ 'python2-sqlalchemy' 'python2-sip' 'python2-pysqlite-legacy'
+ 'python2-pyenchant' 'python2-mako' 'python2-alembic'
+ 'python2-xdg' 'python2-beautifulsoup3' 'python2-migrate')
+optdepends=('libreoffice-impress: display impress presentations'
+ 'vlc: play multimedia')
+install=openlp.install
+source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/OpenLP-$pkgver.tar.gz openlp.sh)
+md5sums=('539626eb8da337814d64e82329e22e78'
+ '56908c5e7807fe2a384aa55de3735f32')
+sha1sums=('59dff57fff62ce406b180585dc5dcbd47d0e1c72'
+ 'd40794631c19688eb1971eadeb108c5a2cc69506')
+
+package() {
+ cd "$srcdir/OpenLP-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ mv "$pkgdir/usr/bin/openlp"{.pyw,}
+
+ echo "$pkgver" > "$pkgdir/usr/lib/python2.7/site-packages/openlp/.version"
+
+ install -Dm0755 "$srcdir/openlp.sh" "$pkgdir/etc/profile.d/openlp.sh"
+ install -Dm0644 "resources/openlp.desktop" "$pkgdir/usr/share/applications/openlp.desktop"
+ install -Dm0644 "resources/images/openlp-logo.svg" "$pkgdir/usr/share/pixmaps/openlp.svg"
+ install -Dm0644 "resources/images/openlp-logo-48x48.png" "$pkgdir/usr/share/pixmaps/openlp.png"
+
+ #translations
+ tsrcdir="$srcdir/OpenLP-$pkgver/resources/i18n"
+ tdestdir="$pkgdir/usr/share/$pkgname/i18n"
+ mkdir -p "$tdestdir"
+ cd "$tsrcdir"
+
+ for file in *.ts; do
+ lconvert -i "$file" -o "$tdestdir/${file%%ts}qm"
+ done
+}
diff --git a/openlp.install b/openlp.install
new file mode 100644
index 000000000000..f6b57714e145
--- /dev/null
+++ b/openlp.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo "Please logout and back in or source /etc/profile.d/openlp.sh"
+ echo "if you're going to be using impress presentations in openlp."
+ update-desktop-database -q
+}
+post_upgrade() {
+ post_install
+}
+post_remove() {
+ update-desktop-database -q
+}
diff --git a/openlp.sh b/openlp.sh
new file mode 100644
index 000000000000..cd43490e9571
--- /dev/null
+++ b/openlp.sh
@@ -0,0 +1,4 @@
+if [ -e "/usr/lib/libreoffice/program/uno.py" ]; then
+ export PYTHONPATH="$PYTHONPATH:/usr/lib/libreoffice/program/"
+ export URE_BOOTSTRAP="file:///usr/lib/libreoffice/program/fundamentalrc"
+fi