summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2023-04-29 14:17:43 +0200
committerLone_Wolf2023-04-29 14:17:43 +0200
commit099ea0afbc3d411f045aa6154ad43ba99b72032f (patch)
treeeec6362dd8f292e22d9dd257298411f0bea19679
parenta5cf9604ce4ae60119119fb5a8c5014fd2d90f66 (diff)
downloadaur-099ea0afbc3d411f045aa6154ad43ba99b72032f.tar.gz
adjusted pkgver()
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a335404cf47..b5603e5f4eb9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = openmw-git
pkgdesc = An open-source engine reimplementation for the role-playing game Morrowind.
- pkgver = 0.47.0.r4538.ga41cbfb349
+ pkgver = 0.48.0.rc9.r1887.g9f653b2a79
pkgrel = 1
url = http://www.openmw.org
arch = i686
arch = x86_64
+ arch = aarch64
license = GPL3
license = MIT
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index ee076d656909..ed196ec81817 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer : bwrsandman
# Co-Maintainer: Lone_Wolf <lone_wolf@klaas-de-kat.nl>
+# thanks to txtsd <aur.archlinux@ihavea.quest> for contributing some parts of the PKGBUILD code
pkgname=openmw-git
-pkgver=0.47.0.r4538.ga41cbfb349
+pkgver=0.48.0.rc9.r1887.g9f653b2a79
pkgrel=1
pkgdesc="An open-source engine reimplementation for the role-playing game Morrowind."
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'aarch64')
url="http://www.openmw.org"
license=('GPL3' 'MIT' 'custom')
depends=('openal' 'openscenegraph' 'mygui' 'bullet-dp' 'qt5-base' 'ffmpeg' 'sdl2' 'unshield' 'libxt' 'boost-libs' 'luajit' 'recastnavigation-openmw' 'yaml-cpp')
@@ -18,8 +19,13 @@ sha1sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname%-git}"
- _tag="$(git describe --tags --match 'openmw-[01]*' --abbrev=0 $(git rev-list --tags) | uniq | sed 's/openmw-//' | sort | tail -n1)"
- _numcommits="$(git rev-list openmw-$_tag..HEAD --count)"
+ _pattern='^([0-9]{2})-rc([0-9]{1,2}$)'
+ _tag="$(git describe --tags $(git rev-list --tags --max-count=1) | sed 's/openmw-//')"
+ if [[ $_tag =~ $_pattern ]] ;
+ then
+ _tag=$(echo $_tag | sed -E 's/^([0-9]{2})-rc([0-9]{1,2}$)/0.\1.0.rc\2/')
+ fi
+ _numcommits="$(git rev-list $(git rev-list --tags --no-walk --max-count=1)..HEAD --count)"
_hash="$(git rev-parse --short HEAD)"
printf "%s.r%s.g%s" "$_tag" "$_numcommits" "$_hash"
}