summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSandy Carter2022-01-30 19:58:17 -0500
committerSandy Carter2022-01-30 19:58:17 -0500
commit59331f9fdc8bcbdf3789422cd47b8121c5fea4d9 (patch)
tree594b641ca9349e37c9a33444a7be99e38fd3a955
parent5702a8aed4dbcb29164fa53a73164de57f2fc7b2 (diff)
downloadaur-59331f9fdc8bcbdf3789422cd47b8121c5fea4d9.tar.gz
Use recastnavigation for openmw
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b51fa54d0f6..d0ff34f12e0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openmw-git
pkgdesc = An open-source engine reimplementation for the role-playing game Morrowind.
pkgver = 0.47.0.r1788.g2bd99867f
- pkgrel = 1
+ pkgrel = 2
url = http://www.openmw.org
arch = i686
arch = x86_64
@@ -22,6 +22,7 @@ pkgbase = openmw-git
depends = libxt
depends = boost-libs
depends = luajit
+ depends = recastnavigation-openmw
optdepends = openscenegraph-openmw-git: experimental performance enhancements for OpenMW that are too controversial to be included in the general purpose OSG project
provides = openmw
conflicts = openmw
diff --git a/PKGBUILD b/PKGBUILD
index 4c77dfe21648..5b1d2171a89e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
pkgname=openmw-git
pkgver=0.47.0.r1788.g2bd99867f
-pkgrel=1
+pkgrel=2
pkgdesc="An open-source engine reimplementation for the role-playing game Morrowind."
arch=('i686' 'x86_64')
url="http://www.openmw.org"
license=('GPL3' 'MIT' 'custom')
-depends=('openal' 'openscenegraph' 'mygui' 'bullet-multithreaded' 'qt5-base' 'ffmpeg' 'sdl2' 'unshield' 'libxt' 'boost-libs' 'luajit')
+depends=('openal' 'openscenegraph' 'mygui' 'bullet-multithreaded' 'qt5-base' 'ffmpeg' 'sdl2' 'unshield' 'libxt' 'boost-libs' 'luajit' 'recastnavigation-openmw')
optdepends=('openscenegraph-openmw-git: experimental performance enhancements for OpenMW that are too controversial to be included in the general purpose OSG project')
makedepends=('git' 'cmake' 'boost')
conflicts=("${pkgname%-git}")
@@ -25,7 +25,8 @@ build() {
cd "${srcdir}/${pkgname%-git}"
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DDESIRED_QT_VERSION=5
+ -DDESIRED_QT_VERSION=5 \
+ -DOPENMW_USE_SYSTEM_RECASTNAVIGATION=ON
make
}