summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2022-06-16 13:54:53 +0200
committerLone_Wolf2022-06-16 13:54:53 +0200
commita3beb8eb21617ad2b2a40ac08b03976bad264621 (patch)
treeaead61c6432bcc3e2978ab6a912995ad2bfe96f7
parent41187d1fb79a3e1ca096f8621b72a69817d3fb21 (diff)
downloadaur-a3beb8eb21617ad2b2a40ac08b03976bad264621.tar.gz
switch back to latest ffmpeg from repos
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 2 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0d2a2ea1773..34986c469d6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,7 +16,7 @@ pkgbase = openmw-git
depends = mygui
depends = bullet-multithreaded
depends = qt5-base
- depends = ffmpeg4.4
+ depends = ffmpeg
depends = sdl2
depends = unshield
depends = libxt
diff --git a/PKGBUILD b/PKGBUILD
index ba4321135f1d..000573276e4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ arch=('i686' 'x86_64')
url="http://www.openmw.org"
license=('GPL3' 'MIT' 'custom')
# Workaround ffmpeg4.4 https://gitlab.com/OpenMW/openmw/-/issues/6631#note_848732223
-depends=('openal' 'openscenegraph' 'mygui' 'bullet-multithreaded' 'qt5-base' 'ffmpeg4.4' 'sdl2' 'unshield' 'libxt' 'boost-libs' 'luajit' 'recastnavigation-openmw' 'yaml-cpp')
+depends=('openal' 'openscenegraph' 'mygui' 'bullet-multithreaded' 'qt5-base' 'ffmpeg' 'sdl2' 'unshield' 'libxt' 'boost-libs' 'luajit' 'recastnavigation-openmw' 'yaml-cpp')
optdepends=('openscenegraph-openmw-git: experimental performance enhancements for OpenMW that are too controversial to be included in the general purpose OSG project')
makedepends=('git' 'cmake' 'boost')
conflicts=("${pkgname%-git}")
@@ -27,9 +27,6 @@ pkgver() {
build() {
cd "${srcdir}/${pkgname%-git}"
- # Workardoung ffmpeg4.4 https://gitlab.com/OpenMW/openmw/-/issues/6631#note_848732223
- export PKG_CONFIG_LIBDIR='/usr/lib/ffmpeg4.4/pkgconfig/'
-
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DDESIRED_QT_VERSION=5 \