summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSandy Carter2023-02-09 12:45:48 -0500
committerSandy Carter2023-02-09 12:48:52 -0500
commita5cf9604ce4ae60119119fb5a8c5014fd2d90f66 (patch)
treeebac3259dc9912628ae813717facb36f4e33c52f
parent2ade5d87c4ee3733fc69d35813900a751058a31f (diff)
downloadaur-a5cf9604ce4ae60119119fb5a8c5014fd2d90f66.tar.gz
Better filter tags
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43516c498104..3a335404cf47 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openmw-git
pkgdesc = An open-source engine reimplementation for the role-playing game Morrowind.
- pkgver = 0.47.0.r3589.gbedfbfd594
+ pkgver = 0.47.0.r4538.ga41cbfb349
pkgrel = 1
url = http://www.openmw.org
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index d60a1e6391f8..ee076d656909 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-Maintainer: Lone_Wolf <lone_wolf@klaas-de-kat.nl>
pkgname=openmw-git
-pkgver=0.47.0.r3589.gbedfbfd594
+pkgver=0.47.0.r4538.ga41cbfb349
pkgrel=1
pkgdesc="An open-source engine reimplementation for the role-playing game Morrowind."
arch=('i686' 'x86_64')
@@ -18,8 +18,8 @@ sha1sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname%-git}"
- _tag="$(git describe --tags --match 'openmw*' --abbrev=0 $(git rev-list --tags) | head -n 1 | sed 's/openmw-//')"
- _numcommits="$(git rev-list `git rev-list --tags --no-walk --max-count=1`..HEAD --count)"
+ _tag="$(git describe --tags --match 'openmw-[01]*' --abbrev=0 $(git rev-list --tags) | uniq | sed 's/openmw-//' | sort | tail -n1)"
+ _numcommits="$(git rev-list openmw-$_tag..HEAD --count)"
_hash="$(git rev-parse --short HEAD)"
printf "%s.r%s.g%s" "$_tag" "$_numcommits" "$_hash"
}