summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSandy2012-11-05 08:57:26 -0500
committerSandy2012-11-05 08:57:26 -0500
commite7f9598ae899aa78ebd9551e24a20964c8b8b4a9 (patch)
treef89d06b8b10ecfa5b08082bc4a515ce538d1160e
parentb896bf29952750386f06924aa86d9c5b80054e96 (diff)
downloadaur-e7f9598ae899aa78ebd9551e24a20964c8b8b4a9.tar.gz
Added licences, optimizations
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD25
2 files changed, 22 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ed09b136ab8..bd783182f37e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,15 @@
pkgbase = openmw-git
pkgdesc = An open-source engine reimplementation for the role-playing game Morrowind.
- pkgver = 20121104
+ pkgver = 20121105
pkgrel = 1
url = http://www.openmw.org
arch = i686
arch = x86_64
license = GPL3
+ license = custom:Bitstream Vera
+ license = custom:Daedric Font
+ license = custom:OFL
+ license = custom:shiny
makedepends = git
makedepends = cmake
makedepends = boost>=1.5.0
@@ -16,6 +20,7 @@ pkgbase = openmw-git
depends = mpg123
depends = libsndfile
depends = qt
+ provides = openmw
conflicts = openmw
pkgname = openmw-git
diff --git a/PKGBUILD b/PKGBUILD
index 72975c9adb16..3ca2785a8373 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,18 @@
# PKGBUILD source: https://github.com/bwrsandman/pkgbuild/tree/master/openmw-git
pkgname=openmw-git
-pkgver=20121104
+pkgver=20121105
pkgrel=1
pkgdesc="An open-source engine reimplementation for the role-playing game Morrowind."
arch=('i686' 'x86_64')
url="http://www.openmw.org"
-license=('GPL3')
+license=('GPL3' 'custom:Bitstream Vera' 'custom:Daedric Font' 'custom:OFL' 'custom:shiny')
depends=('openal' 'ogre=1.8.1' 'mygui>=3.2.0-2' 'bullet>=2.8.0' 'mpg123' 'libsndfile' 'qt')
makedepends=('git' 'cmake' 'boost>=1.5.0')
conflicts=('openmw')
+provides=('openmw')
_gitroot="git://github.com/zinnschlag/openmw.git"
_gitname="openmw"
@@ -20,26 +21,26 @@ _gitname="openmw"
build() {
msg "Connecting to GIT server...."
+ cd "$srcdir"
if [ -d "$_gitname" ] ; then
cd "$_gitname" && git pull origin
git submodule update
msg "The local files are updated."
else
- cd "$srcdir"
- git clone "$_gitroot" "$_gitname"
+ git clone --depth=1 "$_gitroot" "$_gitname"
cd "$_gitname"
git submodule update --init
fi
-
msg "GIT checkout done or server timeout"
- msg "Starting make..."
+ msg "Starting make..."
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=RelWithDebInfo
make -j`getconf _NPROCESSORS_ONLN`
+}
- # Install
- # There is currently no make install so we do this manually
+package() {
+ cd "$srcdir/$_gitname"
# Binaries
install -d -m755 "$pkgdir"/usr/bin
@@ -67,5 +68,11 @@ build() {
install -d -m755 "$pkgdir"/usr/share/games/openmw
cp -r resources "$pkgdir"/usr/share/games/openmw/ || exit 1
install -m644 launcher.qss "$pkgdir"/usr/share/games/openmw/resources
-}
+ # Custom Licences
+ install -d -m755 "$pkgdir"/usr/share/licenses/openmw
+ install -D -m644 "Bitstream Vera License.txt" "$pkgdir/usr/share/licenses/openmw/"
+ install -D -m644 "Daedric Font License.txt" "$pkgdir/usr/share/licenses/openmw/"
+ install -D -m644 "OFL.txt" "$pkgdir/usr/share/licenses/openmw/"
+ install -D -m644 "extern/shiny/License.txt" "$pkgdir/usr/share/licenses/openmw/Shiny License.txt"
+} \ No newline at end of file