summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSledge Sulaweyo2020-01-12 14:20:32 +0100
committerSledge Sulaweyo2020-01-12 14:20:32 +0100
commit00f87d7a876d7aa717b5390b627ea09ac7791b88 (patch)
tree5e93378e5e11c615083cd1f1d910c16a695da92d
parent5bea58ae24494679b8ad4f4b083b6e876599cadb (diff)
downloadaur-00f87d7a876d7aa717b5390b627ea09ac7791b88.tar.gz
use bundler to install required gems as script does not include all
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--opennebula.install8
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bfaa7cc380a9..2ecba549bbed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = opennebula
pkgdesc = Virtual management infrastructure as a service (IaaS) toolkit for cloud computing (NOTE: Read the PKGBUILD!)
pkgver = 5.10.1
- pkgrel = 1
+ pkgrel = 2
url = https://opennebula.org/
install = opennebula.install
changelog = ChangeLog
@@ -111,7 +111,7 @@ pkgbase = opennebula
md5sums = 2f1c73538c52324c224684072ea7877b
md5sums = e00db582c46c97d96115eef252f37b40
md5sums = 680931b4555ea25a17ea8c20b382d175
- md5sums = 6db815e867c77e4bee908381798cb79b
+ md5sums = 2f16894c5461b00498f077c596647116
pkgname = opennebula
diff --git a/PKGBUILD b/PKGBUILD
index a1abc0708c5c..6d3f41caee67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=opennebula
_unstable_pkg=opennebula-unstable
pkgver=5.10.1
-pkgrel=1
+pkgrel=2
pkgdesc="Virtual management infrastructure as a service (IaaS) toolkit for cloud computing (NOTE: Read the PKGBUILD!)"
arch=('i686' 'x86_64')
url='https://opennebula.org/'
@@ -118,7 +118,7 @@ md5sums=('3168d199782c10af07012991c2447b1a' # package
'2f1c73538c52324c224684072ea7877b' # opennebula.logrotate
'e00db582c46c97d96115eef252f37b40' # install.sh.patch
'680931b4555ea25a17ea8c20b382d175' # fix_kvm_emulator.patch
- '6db815e867c77e4bee908381798cb79b') # opennebula.install
+ '2f16894c5461b00498f077c596647116') # opennebula.install
prepare() {
cd "one-release-${pkgver}"
diff --git a/opennebula.install b/opennebula.install
index 32aecbeaa4c7..771fe8a9641d 100644
--- a/opennebula.install
+++ b/opennebula.install
@@ -13,15 +13,15 @@ post_install() {
echo ">> You must edit the password in /var/lib/one/.one/one_auth"
fi
chown oneadmin:cloud -R /var/log/one /var/lib/one /run/one /run/lock/one
- echo ">> To install required gems run as root:"
- echo ">> '/usr/share/one/install_gems --showallgems | xargs -l gem install --no-user-install --no-document'"
+ echo ">> To install required gems run as a local user:"
+ echo ">> bundler install --gemfile /usr/share/one/Gemfile"
}
post_upgrade(){
chown oneadmin:cloud -R /var/lib/one/sunstone
printf "NOTE: This is may be an major upgrade! If you are not installing from scratch, check the compatibility guide at:\n\n\thttp://docs.opennebula.org/5.10/intro_release_notes/release_notes/compatibility.html\n\thttp://docs.opennebula.org/5.10/intro_release_notes/upgrades/index.html\n"
- echo ">> Check if all required gems are installed! /usr/share/one/install_gems --showallgems"
-}
+ echo ">> To install required gems run as a local user:"
+ echo ">> bundler install --gemfile /usr/share/one/Gemfile"
pre_remove() {
userdel oneadmin && echo ">> User 'oneadmin' has been removed."