summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSledge Sulaweyo2019-10-06 12:30:39 +0200
committerSledge Sulaweyo2019-10-06 12:30:39 +0200
commit8c6c806208050443766d87104f1c440f71b13ad7 (patch)
tree0f44d40f26714b7b820d4a54669b47df5d2699bf
parentc1a92127a6ee96592b0963d973d79a4c4f32a14e (diff)
downloadaur-8c6c806208050443766d87104f1c440f71b13ad7.tar.gz
Update to 5.8.5
-rw-r--r--.SRCINFO11
-rw-r--r--ChangeLog6
-rw-r--r--PKGBUILD18
-rw-r--r--scons_python3.patch157
4 files changed, 184 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 882ca780f03c..93d6eb3c071a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = opennebula
pkgdesc = Virtual management infrastructure as a service (IaaS) toolkit for cloud computing (NOTE: Read the PKGBUILD!)
- pkgver = 5.8.2
+ pkgver = 5.8.5
pkgrel = 1
url = https://opennebula.org/
install = opennebula.install
@@ -13,6 +13,7 @@ pkgbase = opennebula
makedepends = scons
makedepends = mariadb
makedepends = libmariadbclient
+ makedepends = libvncserver
makedepends = npm
makedepends = grunt-cli
makedepends = bower
@@ -84,7 +85,7 @@ pkgbase = opennebula
backup = etc/one/sunstone-views/user.yaml
backup = etc/one/sched.conf
backup = etc/one/ec2_driver.default
- source = https://github.com/OpenNebula/one/archive/release-5.8.2.tar.gz
+ source = https://github.com/OpenNebula/one/archive/release-5.8.5.tar.gz
source = opennebula.service
source = opennebula-scheduler.service
source = opennebula-sunstone.service
@@ -98,7 +99,8 @@ pkgbase = opennebula
source = set_locations.patch
source = fix_kvm_emulator.patch
source = opennebula.install
- md5sums = 680c606a7b3256ae2042f7177b14ef85
+ source = scons_python3.patch
+ md5sums = 8c277bcb2f851621a189c28891c51be1
md5sums = 69c4374554ae689c44b0ef8c0a31b911
md5sums = 74bc0a908441063a44cb134449564db1
md5sums = f207636bd04a621f20b14a37c6ad49b7
@@ -111,7 +113,8 @@ pkgbase = opennebula
md5sums = cd272404aba91a27cf89ce22364e51b4
md5sums = bab6415dd2437c6dfdadad90efedeff3
md5sums = 680931b4555ea25a17ea8c20b382d175
- md5sums = 073b8bce1b12201658b9745ba7ad2e66
+ md5sums = d6fd565c86ea40001c618689f18a222d
+ md5sums = 8fd54ddb28ae34a75425cff104fdca64
pkgname = opennebula
diff --git a/ChangeLog b/ChangeLog
index d6f934eb2906..42230b3b5ae9 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,9 @@
+2019-10-06 Sledge Sulaweyo <sledge.sulaweyo#gmail.com>
+
+ * 5.8.5-1:
+ New upstream release (5.8.5)
+ Some fixes to build that versions
+
2019-02-28 Sledge Sulaweyo <sledge.sulaweyo#gmail.com>
* 5.8.2-1:
diff --git a/PKGBUILD b/PKGBUILD
index 12042a57020e..a5cbfb9c367d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=opennebula
_unstable_pkg=opennebula-unstable
-pkgver=5.8.2
+pkgver=5.8.5
pkgrel=1
pkgdesc="Virtual management infrastructure as a service (IaaS) toolkit for cloud computing (NOTE: Read the PKGBUILD!)"
arch=('i686' 'x86_64')
@@ -34,6 +34,7 @@ makedepends=('xmlrpc-c'
'scons'
'mariadb'
'libmariadbclient'
+ 'libvncserver' # needed to build sunstone
'npm' # needed to build sunstone
'grunt-cli' # needed to build sunstone
'bower') # needed to build sunstone
@@ -104,8 +105,9 @@ source=("https://github.com/OpenNebula/one/archive/release-${pkgver}.tar.gz"
'chown_fix.patch'
'set_locations.patch'
'fix_kvm_emulator.patch'
- 'opennebula.install')
-md5sums=('680c606a7b3256ae2042f7177b14ef85'
+ 'opennebula.install'
+ 'scons_python3.patch')
+md5sums=('8c277bcb2f851621a189c28891c51be1'
'69c4374554ae689c44b0ef8c0a31b911'
'74bc0a908441063a44cb134449564db1'
'f207636bd04a621f20b14a37c6ad49b7'
@@ -118,7 +120,8 @@ md5sums=('680c606a7b3256ae2042f7177b14ef85'
'cd272404aba91a27cf89ce22364e51b4'
'bab6415dd2437c6dfdadad90efedeff3'
'680931b4555ea25a17ea8c20b382d175'
- 'd6fd565c86ea40001c618689f18a222d')
+ 'd6fd565c86ea40001c618689f18a222d'
+ '8fd54ddb28ae34a75425cff104fdca64')
prepare() {
cd "one-release-${pkgver}"
@@ -129,6 +132,13 @@ prepare() {
patch < "${srcdir}/chown_fix.patch"
patch < "${srcdir}/set_locations.patch"
patch -p0 < "${srcdir}/fix_kvm_emulator.patch"
+ # Fix for scons with python3 https://github.com/OpenNebula/one/issues/3584
+ patch -p1 < "${srcdir}/scons_python3.patch"
+ # Patch npm package versions to support node 12
+ # grunt-sass version
+ sed -i 's/1.2.1/2.1.0/' "${srcdir}/one-release-${pkgver}/src/sunstone/public/package.json"
+ # node-sass
+ sed -i 's/3.10.1/4.12.0/' "${srcdir}/one-release-${pkgver}/src/sunstone/public/package.json"
# As we install from the github release sources we need to build sunstone as well.
# To do that we need the npm environment set up
# https://docs.opennebula.org/5.4/integration/references/sunstone_dev.html#sunstone-dev
diff --git a/scons_python3.patch b/scons_python3.patch
new file mode 100644
index 000000000000..f6fdd7a594ae
--- /dev/null
+++ b/scons_python3.patch
@@ -0,0 +1,157 @@
+From e4ca0a4f07304e110f63bcb3c74361ff9c93498a Mon Sep 17 00:00:00 2001
+From: Jan Orel <jorel@opennebula.systems>
+Date: Wed, 4 Sep 2019 10:07:26 +0200
+Subject: [PATCH] B #3584: Make scons python3 compatible
+
+---
+ SConstruct | 66 +++++++++++++++++-----------------
+ share/rubygems/SConstruct | 4 +--
+ src/docker_machine/SConstruct | 4 +--
+ src/sunstone/public/SConstruct | 4 +--
+ 4 files changed, 39 insertions(+), 39 deletions(-)
+
+diff --git a/SConstruct b/SConstruct
+index e758fc2dd0..f531cb461b 100755
+--- a/SConstruct
++++ b/SConstruct
+@@ -40,15 +40,15 @@ main_env['CXXFLAGS'] = " -DGITVERSION=\'\"" + git_version + "\"\'"
+
+ # snippet borrowed from http://dev.gentoo.org/~vapier/scons-blows.txt
+ # makes scons aware of build related environment variables
+-if os.environ.has_key('CC'):
++if 'CC' in os.environ:
+ main_env['CC'] = os.environ['CC']
+-if os.environ.has_key('CFLAGS'):
++if 'CFLAGS' in os.environ:
+ main_env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CFLAGS'])
+-if os.environ.has_key('CXX'):
++if 'CXX' in os.environ:
+ main_env['CXX'] = os.environ['CXX']
+-if os.environ.has_key('CXXFLAGS'):
++if 'CXXFLAGS' in os.environ:
+ main_env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CXXFLAGS'])
+-if os.environ.has_key('LDFLAGS'):
++if 'LDFLAGS' in os.environ:
+ main_env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
+ else:
+ os.environ['LDFLAGS'] = ""
+@@ -186,15 +186,15 @@ if not main_env.GetOption('clean'):
+ try:
+ if mysql == 'yes':
+ main_env.ParseConfig('mysql_config --cflags --libs')
+- except Exception, e:
+- print ""
+- print "mysql_config was not found in the path"
+- print ""
+- print "Check that mysql development package is installed and"
+- print "mysql_config is in the path. If your mysql config tool"
+- print "is called mysql5_config make a symlink as mysql_config"
+- print "to a directory in the path."
+- print ""
++ except Exception as e:
++ print ("")
++ print ("mysql_config was not found in the path")
++ print ("")
++ print ("Check that mysql development package is installed and")
++ print ("mysql_config is in the path. If your mysql config tool")
++ print ("is called mysql5_config make a symlink as mysql_config")
++ print ("to a directory in the path.")
++ print ("")
+ exit(-1)
+
+ try:
+@@ -203,24 +203,24 @@ if not main_env.GetOption('clean'):
+ main_env.ParseConfig(("LDFLAGS='%s' share/scons/get_xmlrpc_config" +
+ " client") % (os.environ['LDFLAGS'],))
+
+- except Exception, e:
+- print ""
+- print "Error searching for xmlrpc-c libraries. Please check this" +\
+- " things:"
+- print ""
+- print " * You have installed development libraries for xmlrpc-c. One" +\
+- " way to check"
+- print " this is calling xmlrpc-c-config that is provided with the" +\
+- " development"
+- print " package."
+- print " * Check that the version of xmlrpc-c is at least 1.06. You" +\
+- " can do this also"
+- print " calling:"
+- print " $ xmlrpc-c-config --version"
+- print " * If all this requirements are already met please send log" +\
+- " files located in"
+- print " .xmlrpc_test to the mailing list."
+- print ""
++ except Exception as e:
++ print ("")
++ print ("Error searching for xmlrpc-c libraries. Please check this") +\
++ (" things:")
++ print ("")
++ print (" * You have installed development libraries for xmlrpc-c. One") +\
++ (" way to check")
++ print (" this is calling xmlrpc-c-config that is provided with the") +\
++ (" development")
++ print (" package.")
++ print (" * Check that the version of xmlrpc-c is at least 1.06. You") +\
++ (" can do this also")
++ print (" calling:")
++ print (" $ xmlrpc-c-config --version")
++ print (" * If all this requirements are already met please send log") +\
++ (" files located in")
++ print (" .xmlrpc_test to the mailing list.")
++ print ("")
+ exit(-1)
+ else:
+ main_env.Replace(mysql='yes')
+diff --git a/share/rubygems/SConstruct b/share/rubygems/SConstruct
+index b3e3d8e148..60add7927b 100644
+--- a/share/rubygems/SConstruct
++++ b/share/rubygems/SConstruct
+@@ -21,10 +21,10 @@ import os
+ Import('env')
+
+ if env['rubygems']=='yes':
+- print "Generating rubygems packages\n"
++ print ("Generating rubygems packages\n")
+ exit_code=os.system("./generate")
+
+ if exit_code != 0:
+- print "Error generating rubygem packages\n"
++ print ("Error generating rubygem packages\n")
+ exit(-1)
+
+diff --git a/src/docker_machine/SConstruct b/src/docker_machine/SConstruct
+index 6027a5cc3c..bff5870b78 100644
+--- a/src/docker_machine/SConstruct
++++ b/src/docker_machine/SConstruct
+@@ -21,9 +21,9 @@ import os
+ Import('env')
+
+ if env['docker_machine']=='yes':
+- print "Generating docker-machine-driver-opennebula\n"
++ print ("Generating docker-machine-driver-opennebula\n")
+ exit_code=os.system("make -C src/docker_machine build")
+
+ if exit_code != 0:
+- print "Error generating docker-machine-driver-opennebula\n"
++ print ("Error generating docker-machine-driver-opennebula\n")
+ exit(-1)
+diff --git a/src/sunstone/public/SConstruct b/src/sunstone/public/SConstruct
+index bf5e588d6e..c418231ece 100644
+--- a/src/sunstone/public/SConstruct
++++ b/src/sunstone/public/SConstruct
+@@ -22,11 +22,11 @@ Import('env')
+
+
+ if env['sunstone']=='yes':
+- print "Generating Sunstone minified files\n"
++ print ("Generating Sunstone minified files\n")
+
+ exit_code=os.system("./build.sh")
+
+ if exit_code != 0:
+- print "Error generating minifying Sunstone files\n"
++ print ("Error generating minifying Sunstone files\n")
+ exit(-1)
+
+