summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFerdinand Bachmann2023-12-13 17:03:28 +0100
committerFerdinand Bachmann2023-12-13 17:03:28 +0100
commitf6c3f0b73f65c166eb965b7d5040f260a962bbd4 (patch)
tree0519e0af4262de6895eeaec82630726127b58bd1
parentf37cdcd4dd61a9ada322aa47cb1813d1b4486b3b (diff)
downloadaur-openocd-raspberrypi-git.tar.gz
update pkgver to VCS package guidelines, use more up-to-date branch
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3c8f806f452..861d7427ade4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = openocd-raspberrypi-git
pkgdesc = Debugging, in-system programming and boundary-scan testing for embedded target devices (git version, raspberrypi fork)
- pkgver = r8907.610f137d2
+ pkgver = v0.12.0.r24.g4d87f6d
pkgrel = 1
- url = http://openocd.org
+ url = https://github.com/raspberrypi/openocd
arch = i686
arch = x86_64
arch = arm
@@ -18,11 +18,11 @@ pkgbase = openocd-raspberrypi-git
depends = hidapi
depends = libudev.so
depends = capstone
- provides = openocd
+ provides = openocd=${pkgver}
conflicts = openocd
conflicts = openocd-git
options = !strip
- source = openocd-raspberrypi-git::git+https://github.com/raspberrypi/openocd.git
+ source = openocd-raspberrypi-git::git+https://github.com/raspberrypi/openocd.git#branch=rp2040-v0.12.0
source = git+https://github.com/msteveb/jimtcl.git
source = git+https://gitlab.zapb.de/libjaylink/libjaylink.git
source = git+https://git.savannah.nongnu.org/git/git2cl.git
diff --git a/PKGBUILD b/PKGBUILD
index 04df6c202025..8cf0a685f90f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,20 +10,20 @@
_pkgbase=openocd
pkgname=openocd-raspberrypi-git
-pkgver=r8907.610f137d2
+pkgver=v0.12.0.r24.g4d87f6d
pkgrel=1
pkgdesc="Debugging, in-system programming and boundary-scan testing for embedded target devices (git version, raspberrypi fork)"
arch=('i686' 'x86_64' 'arm' 'aarch64')
-url="http://openocd.org"
+url="https://github.com/raspberrypi/openocd"
license=('GPL')
depends=('libftdi-compat' 'libusb-compat' 'hidapi' 'libudev.so' 'capstone')
makedepends=('git' 'automake>=1.11' 'autoconf' 'libtool' 'tcl')
options=(!strip)
-provides=('openocd')
+provides=('openocd=${pkgver}')
conflicts=('openocd' 'openocd-git')
source=(
- "${pkgname}::git+https://github.com/raspberrypi/openocd.git"
+ "${pkgname}::git+https://github.com/raspberrypi/openocd.git#branch=rp2040-v0.12.0"
"git+https://github.com/msteveb/jimtcl.git"
"git+https://gitlab.zapb.de/libjaylink/libjaylink.git"
"git+https://git.savannah.nongnu.org/git/git2cl.git"
@@ -81,7 +81,7 @@ _features=(
pkgver() {
cd "${srcdir}/${pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags --abbrev=7 | sed 's/^rp2040-v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {