summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeff Keyte2017-01-15 19:36:52 -0600
committerJeff Keyte2017-01-15 19:36:52 -0600
commit7f6025a14390110bc7779bfaf417adbb3e71e6fd (patch)
treeec75c7aa6d9f5864f822c377af9af705181b262e
parent6d7b7e80f54793976f9561456bd4423e1771e210 (diff)
downloadaur-7f6025a14390110bc7779bfaf417adbb3e71e6fd.tar.gz
Revised plexhometheater.sh with new paths from upstreatm
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--plexhometheater.sh4
3 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15d902d22810..bdcdc4ff7290 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openpht
pkgdesc = OpenPHT is a community driven fork of Plex Home Theater
pkgver = 1.7.1.137
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/RasPlex/OpenPHT/
arch = i686
arch = x86_64
@@ -74,7 +74,7 @@ pkgbase = openpht
source = fribidi.patch
source = plexhometheater.desktop
sha256sums = e1b324a5ebb42d3a6f011592ff3dad0c4f08b3e937ff77977d3aa2ac51f8d415
- sha256sums = dc6bd394c07a2ececbb2f8c53cb54afd5d78f7c00a0b34acab3e71217da085fb
+ sha256sums = 8a2d9ac55bc4e05520a9dc5893bb19c5e0e28991dbcdd9b4af5feaec20fc4f2d
sha256sums = 966edfa84fa09cf9c54281dff2adfd6fad41309b17893511e7cf01dc85def1ea
sha256sums = 354429ce7dcafaa8b619b000000f4f4f8fc0a1545b9656f6beb9f85ebb8f4e41
diff --git a/PKGBUILD b/PKGBUILD
index 921ef1c10640..02179f13a731 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=openpht
pkgver=1.7.1.137
_pkghash=b604995c
-pkgrel=2
+pkgrel=3
pkgdesc='OpenPHT is a community driven fork of Plex Home Theater '
arch=('i686' 'x86_64')
url='https://github.com/RasPlex/OpenPHT/'
@@ -28,7 +28,7 @@ source=("https://github.com/RasPlex/OpenPHT/archive/v${pkgver}-${_pkghash}.tar.g
'fribidi.patch'
'plexhometheater.desktop')
sha256sums=('e1b324a5ebb42d3a6f011592ff3dad0c4f08b3e937ff77977d3aa2ac51f8d415'
- 'dc6bd394c07a2ececbb2f8c53cb54afd5d78f7c00a0b34acab3e71217da085fb'
+ '8a2d9ac55bc4e05520a9dc5893bb19c5e0e28991dbcdd9b4af5feaec20fc4f2d'
'966edfa84fa09cf9c54281dff2adfd6fad41309b17893511e7cf01dc85def1ea'
'354429ce7dcafaa8b619b000000f4f4f8fc0a1545b9656f6beb9f85ebb8f4e41')
prepare() {
@@ -46,7 +46,8 @@ build() {
cmake .. \
-DCMAKE_INSTALL_PREFIX='/usr' \
- -DUSE_INTERNAL_FFMPEG='OFF'
+ -DUSE_INTERNAL_FFMPEG='ON'
+
make
}
diff --git a/plexhometheater.sh b/plexhometheater.sh
index 53276ffedc76..4d71aaaedb2d 100644
--- a/plexhometheater.sh
+++ b/plexhometheater.sh
@@ -1,5 +1,5 @@
#!/bin/sh
-export XBMC_BIN_HOME='/usr/lib/plexhometheater'
+export XBMC_BIN_HOME='/usr/lib/openpht'
export XBMC_HOME='/usr/share/plexhometheater'
-exec plexhometheater
+exec /usr/lib/openpht/plexhometheater