summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeff Keyte2016-05-24 21:03:44 -0500
committerJeff Keyte2016-05-24 21:03:44 -0500
commita60af5095bbe53df5b160fa7ab7b51f03ec4c900 (patch)
tree65f786a08e79b66663acabbc9f35997ccccc5b5b
parent198d049a81fa85b633e2f334aa23dc85cba1f52c (diff)
downloadaur-a60af5095bbe53df5b160fa7ab7b51f03ec4c900.tar.gz
update dependencies due to gcc incompatibility, add fribidi patch
-rw-r--r--PKGBUILD17
-rw-r--r--fribidi.patch50
2 files changed, 59 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 316d3ce55f7c..1f28c9ccaced 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,31 +5,32 @@
pkgname=openpht
pkgver=1.5.2.514
_pkghash=310d4f7e
-pkgrel=3
+pkgrel=4
pkgdesc='OpenPHT is a community driven fork of Plex Home Theater '
arch=('i686' 'x86_64')
url='https://github.com/RasPlex/OpenPHT/'
license=('GPL2')
conflicts=("plex-home-theater")
depends=('alsa-lib' 'avahi' 'boost-libs' 'curl' 'expat' 'freetype2' 'fribidi'
- 'gcc-libs' 'glew' 'glibc' 'glu' 'libcdio' 'libgl' 'libjpeg' 'libmad'
- 'libmicrohttpd' 'libmpeg2' 'libpng' 'libpulse' 'libsamplerate'
+ 'gcc-libs<=5.3.0' 'glew' 'glibc<=2.23-1' 'glu' 'libcdio' 'libgl' 'libjpeg' 'libmad'
+ 'libmicrohttpd' 'libmpeg2' 'libpng' 'libpulse' 'libsamplerate' 'llvm-libs<=3.7.1'
'libssh' 'libtiff' 'libusb-compat' 'libva' 'libvdpau' 'libx11'
'libxext' 'libxrandr' 'lzo' 'pcre' 'python2' 'sdl' 'sdl_image'
'sdl_mixer' 'sqlite' 'smbclient' 'taglib' 'tinyxml' 'yajl' 'zlib')
makedepends=('boost' 'cmake' 'doxygen' 'ffmpeg-compat' 'git' 'java-environment'
- 'libcec' 'libplist' 'nasm' 'swig' 'unzip' 'zip' 'shairplay')
+ 'libcec' 'libplist' 'nasm' 'swig' 'unzip' 'zip')
optdepends=('libplist: AirPlay support'
- 'shairplay: AirPlay support'
'libcec: Pulse-Eight USB-CEC adapter support'
'pulseaudio: PulseAudio support')
source=("https://github.com/RasPlex/OpenPHT/archive/v${pkgver}-${_pkghash}.tar.gz"
- 'plexhometheater.sh')
+ 'plexhometheater.sh'
+ 'fribidi.patch')
sha256sums=('137da57bf9a0ad9f2b464cae327c85f2842a04d00f2adfa12616c3f22cbcf19f'
- 'dc6bd394c07a2ececbb2f8c53cb54afd5d78f7c00a0b34acab3e71217da085fb')
-
+ 'dc6bd394c07a2ececbb2f8c53cb54afd5d78f7c00a0b34acab3e71217da085fb'
+ '966edfa84fa09cf9c54281dff2adfd6fad41309b17893511e7cf01dc85def1ea')
prepare() {
cd OpenPHT-${pkgver}-${_pkghash}
+ patch -Np1 <../fribidi.patch
}
build() {
diff --git a/fribidi.patch b/fribidi.patch
new file mode 100644
index 000000000000..8c939df94a88
--- /dev/null
+++ b/fribidi.patch
@@ -0,0 +1,50 @@
+diff --git a/plex/CMakeModules/FindFriBiDi.cmake b/plex/CMakeModules/FindFriBiDi.cmake
+--- a/plex/CMakeModules/FindFriBiDi.cmake
++++ b/plex/CMakeModules/FindFriBiDi.cmake
+@@ -9,44 +9,8 @@
+ # also defined, but not for general use are
+ # FRIBIDI_LIBRARY, where to find the FriBiDi library.
+
+-include(CheckSymbolExists)
+-
+-SET(FRIBIDI_FOUND "NO")
+-
+-# Set variable in temp var, otherwise FIND_PATH might fail
+-# unset isn't present in the required version of cmake.
+-FIND_PATH(xFRIBIDI_INCLUDE_DIR fribidi.h
+- PATHS /usr/local/include
+- /usr/include
+- PATH_SUFFIXES fribidi
+- )
+-set(FRIBIDI_INCLUDE_DIR ${xFRIBIDI_INCLUDE_DIR})
+-
+-SET(FRIBIDI_NAMES ${FRIBIDI_NAMES} fribidi libfribidi)
+-FIND_LIBRARY(FRIBIDI_LIBRARY
+- NAMES ${FRIBIDI_NAMES}
+- PATHS /usr/lib /usr/local/lib
+- )
+-
+-IF (FRIBIDI_LIBRARY AND FRIBIDI_INCLUDE_DIR)
+- SET(CMAKE_REQUIRED_INCLUDES ${FRIBIDI_INCLUDE_DIR})
+- SET(CMAKE_REQUIRED_LIBRARIES ${FRIBIDI_LIBRARY})
+- CHECK_SYMBOL_EXISTS(fribidi_utf8_to_unicode fribidi.h FOUND_fribidi_utf8_to_unicode)
+- CHECK_SYMBOL_EXISTS(fribidi_charset_to_unicode fribidi.h FOUND_fribidi_charset_to_unicode)
+- if(FOUND_fribidi_charset_to_unicode)
+- SET(FRIBIDI_LIBRARIES ${FRIBIDI_LIBRARY})
+- SET(FRIBIDI_FOUND "YES")
+- elseif(FOUND_fribidi_utf8_to_unicode)
+- SET(FRIBIDI_LIBRARIES ${FRIBIDI_LIBRARY})
+- SET(FRIBIDI_FOUND "YES")
+- add_definitions(-DOLD_FRIBIDI)
+- MESSAGE(STATUS "Legacy FriBiDi: ${FRIBIDI_LIBRARY}")
+- else()
+- SET(FRIBIDI_LIBRARIES "NOTFOUND")
+- SET(FRIBIDI_INCLUDE_DIR "NOTFOUND")
+- SET(FRIBIDI_FOUND "NO")
+- endif()
+-ENDIF (FRIBIDI_LIBRARY AND FRIBIDI_INCLUDE_DIR)
++include(FindPkgConfig)
++pkg_check_modules(FRIBIDI fribidi)
+
+ IF (FRIBIDI_FOUND)
+