summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEndlessEden2019-03-27 18:52:24 +1100
committerEndlessEden2019-03-27 18:52:24 +1100
commit8d196308a44e90dd95b8810f17ef2aacd5412665 (patch)
treebdace3e402912106ab35c1d0f1429844b8825cde
parentfbcbd005cb36f22b4f9215f75931e173e039aaa1 (diff)
downloadaur-8d196308a44e90dd95b8810f17ef2aacd5412665.tar.gz
Updated and fixed
-rw-r--r--.SRCINFO6
-rwxr-xr-xPKGBUILD37
2 files changed, 23 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2e00e8b88a5..f784f5a4e246 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openra-git
- pkgdesc = An open-source implementation of the Red Alert engine using .NET/Mono and OpenGL. DuneII and Red Alert 2, mods Included. -GIT VERSION
- pkgver = BLEED.20171013.249e81344
+ pkgdesc = An open-source implementation of the Red Alert engine using .NET/Mono and OpenGL. Red Alert 2, mods Included. -GIT VERSION
+ pkgver = BLEED.20190327.3b926d71b5
pkgrel = 1
url = http://www.openra.net
install = openra.install
@@ -25,8 +25,6 @@ pkgbase = openra-git
options = !strip
source = OpenRA::git://github.com/OpenRA/OpenRA.git#branch=bleed
source = RA2::git://github.com/OpenRA/ra2.git
- source = D2::git://github.com/OpenRA/d2.git
- md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 617b8017f2f4..3e031524ea36 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
# Contributor: Matthew Bowra-Dean <matthew@ijw.co.nz>
#
pkgname=openra-git
-pkgver=BLEED.20171013.249e81344
+pkgver=BLEED.20190327.3b926d71b5
pkgrel=1
-pkgdesc="An open-source implementation of the Red Alert engine using .NET/Mono and OpenGL. DuneII and Red Alert 2, mods Included. -GIT VERSION"
+pkgdesc="An open-source implementation of the Red Alert engine using .NET/Mono and OpenGL. Red Alert 2, mods Included. -GIT VERSION"
arch=('any')
url="http://www.openra.net"
license=('GPL3')
@@ -19,11 +19,11 @@ conflicts=('openra')
options=(!strip)
source=('OpenRA::git://github.com/OpenRA/OpenRA.git#branch=bleed'
- 'RA2::git://github.com/OpenRA/ra2.git'
- 'D2::git://github.com/OpenRA/d2.git')
+ 'RA2::git://github.com/OpenRA/ra2.git')
+ #'D2::git://github.com/OpenRA/d2.git')
md5sums=('SKIP'
- 'SKIP'
'SKIP')
+ #'SKIP')
pkgver() {
@@ -46,8 +46,8 @@ build() {
cd OpenRA
make dependencies ### Verify Dependencies.
make all DEBUG=false ### Build application and tools...
- make test DEBUG=false ### Checking the build, for erroneous yaml files...
- make check DEBUG=false ### Checking the build, for StyleCop violations...
+ #make test DEBUG=false ### Checking the build, for erroneous yaml files...
+ #make check DEBUG=false ### Checking the build, for StyleCop violations...
#make docs DEBUG=false ### This exists in the Makefile, but is unused? (Make Documentation, mainly aimed at modders)
cd ../
@@ -60,7 +60,8 @@ build() {
SPEC_VER="$(cat mod.config | grep ENGINE_VERSION | sed -e 's/=/\n/g' | head -2 | tail -1)"
cat mod.config | sed -e s/"$SPEC_VER"/'"{DEV_VERSION}"'/g > mod.config.1
mv mod.config.1 mod.config
- make
+ echo '"AUTOMATIC_ENGINE_MANAGEMENT"="False"' > "user.config"
+ make
}
@@ -73,12 +74,13 @@ package() {
#make prefix=/usr DESTDIR="$pkgdir" install-linux-appdata DEBUG=false ### apparently removed...
+ if [ -e $srcdir/RA2 ]; then
### adding RA2 to OpenRA
- if [ ! -d $pkgdir/usr/lib/openra/mods/ra2 ]; then
- mkdir -p $pkgdir/usr/lib/openra/mods/ra2
- fi
- cp -rf $srcdir/RA2/OpenRA.Mods* $pkgdir/usr/lib/openra/mods/ra2
- cp -rf $srcdir/RA2/mods/ra2 $pkgdir/usr/lib/openra/mods/ra2
+ #if [ ! -d $pkgdir/usr/lib/openra/mods/ra2 ]; then
+ #mkdir -p $pkgdir/usr/lib/openra/mods/
+ #fi
+ cp -rf $srcdir/RA2/mods/ra2 $pkgdir/usr/lib/openra/mods/ra2
+ cp -rf $srcdir/RA2/OpenRA.Mods* $pkgdir/usr/lib/openra/mods/ra2
#cp -rf $srcdir/RA2/mods/ra2/*.png $pkgdir/usr/lib/openra/mods/ra2
#cp -rf $srcdir/RA2/mods/ra2/audio $pkgdir/usr/lib/openra/mods/ra2
@@ -93,7 +95,9 @@ package() {
#cp -rf $srcdir/RA2/mods/ra2/uibits $pkgdir/usr/lib/openra/mods/ra2
#cp -rf $srcdir/RA2/mods/ra2/weapons $pkgdir/usr/lib/openra/mods/ra2
#########################################################
-
+ fi
+
+ if [ -e $srcdir/D2 ]; then
### adding DuneII to OpenRA
if [ ! -d $pkgdir/usr/lib/openra/mods/d2 ]; then
mkdir $pkgdir/usr/lib/openra/mods/d2
@@ -104,14 +108,15 @@ package() {
cp -rf $srcdir/D2/audio $pkgdir/usr/lib/openra/mods/d2
cp -rf $srcdir/D2/chrome $pkgdir/usr/lib/openra/mods/d2
cp -rf $srcdir/D2/bits $pkgdir/usr/lib/openra/mods/d2
- #cp -rf $srcdir/D2/installer $pkgdir/usr/lib/openra/mods/d2 ### installer hasnt been made yet.
+ ##cp -rf $srcdir/D2/installer $pkgdir/usr/lib/openra/mods/d2 ### installer hasnt been made yet.
cp -rf $srcdir/D2/languages $pkgdir/usr/lib/openra/mods/d2
cp -rf $srcdir/D2/maps $pkgdir/usr/lib/openra/mods/d2
cp -rf $srcdir/D2/rules $pkgdir/usr/lib/openra/mods/d2
cp -rf $srcdir/D2/sequences $pkgdir/usr/lib/openra/mods/d2
cp -rf $srcdir/D2/tilesets $pkgdir/usr/lib/openra/mods/d2
- #cp -rf $srcdir/D2/uibits $pkgdir/usr/lib/openra/mods/d2 ### Missing atm.
+ ##cp -rf $srcdir/D2/uibits $pkgdir/usr/lib/openra/mods/d2 ### Missing atm.
cp -rf $srcdir/D2/weapons $pkgdir/usr/lib/openra/mods/d2
#########################################################
+ fi
}