summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrenton Horne2019-06-02 13:51:07 +1000
committerBrenton Horne2019-06-02 13:51:07 +1000
commit49dcaf1fa6bdba759a3d6b032181e15f5e539042 (patch)
tree4dd113fd69da1ce3f93c7934f161ef5a900f5942
parent310abed597de04999a6b141c3d11a97c7bf7f8a9 (diff)
downloadaur-49dcaf1fa6bdba759a3d6b032181e15f5e539042.tar.gz
:arrow_up: 203.git.aa4ed5a
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rwxr-xr-xPKGBUILD12
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d55264a9a76f..55e01e99b1ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = openra-yr-git
pkgdesc = A Command & Conquer: Yuri's Revenge-inspired mod of OpenRA
- pkgver = 199.git.5b8b952
+ pkgver = 203.git.aa4ed5a
pkgrel = 1
- url = https://github.com/cookgreen/yr
+ url = https://github.com/cookgreen/Yuris-Revenge
install = openra-yr.install
arch = any
license = GPL3
@@ -23,7 +23,7 @@ pkgbase = openra-yr-git
depends = zenity
provides = openra-yr
options = !strip
- source = git+https://github.com/cookgreen/yr.git
+ source = git+https://github.com/cookgreen/Yuris-Revenge.git
source = openra-yr
source = openra-yr.appdata.xml
source = openra-yr.desktop
diff --git a/.gitignore b/.gitignore
index 34145982ebb1..e356ef332c8c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.xz
+Yuris-Revenge
yr
pkg
src
diff --git a/PKGBUILD b/PKGBUILD
index 32ce6d34e290..dc2765846ff4 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
pkgname=openra-yr-git
_pkgname=openra-yr
-pkgver=199.git.5b8b952
+pkgver=203.git.aa4ed5a
pkgrel=1
pkgdesc="A Command & Conquer: Yuri's Revenge-inspired mod of OpenRA"
arch=('any')
-url="https://github.com/cookgreen/yr"
+url="https://github.com/cookgreen/Yuris-Revenge"
license=('GPL3')
install=openra-yr.install
depends=('mono' 'ttf-dejavu' 'openal' 'libgl' 'freetype2' 'sdl2' 'lua51' 'hicolor-icon-theme' 'gtk-update-icon-cache'
@@ -22,25 +22,25 @@ md5sums=('SKIP'
'3be388e2b2fb8b8c33b2e5f3232e9cda')
pkgver() {
- cd $srcdir/yr
+ cd $srcdir/Yuris-Revenge
no=$(git rev-list --count HEAD)
hash=$(git log | head -n 1 | cut -d ' ' -f 2 | head -c 7)
printf "${no}.git.${hash}"
}
prepare() {
- cd $srcdir/yr
+ cd $srcdir/Yuris-Revenge
dos2unix *.md
}
build() {
- cd $srcdir/yr
+ cd $srcdir/Yuris-Revenge
make version VERSION="${pkgver}"
make
}
package() {
- cd $srcdir/yr
+ cd $srcdir/Yuris-Revenge
mkdir -p $pkgdir/usr/{lib/openra-yr/mods,bin,share/pixmaps,share/doc/packages/openra-yr,share/applications,share/appdata}
install -dm775 $pkgdir/var/games/openra-yr
cp -r engine/{glsl,lua,AUTHORS,COPYING,Eluant.dll*,FuzzyLogicLibrary.dll,GeoLite2-Country.mmdb.gz,'global mix database.dat',ICSharpCode.SharpZipLib.dll,launch-dedicated.sh,launch-game.sh,MaxMind.Db.dll,OpenAL-CS.dll,OpenAL-CS.dll.config,Open.Nat.dll,OpenRA.Game.exe,OpenRA.Platforms.Default.dll,OpenRA.Server.exe,OpenRA.Utility.exe,rix0rrr.BeaconLib.dll,SDL2-CS.dll,SDL2-CS.dll.config,SharpFont.dll,SharpFont.dll.config,VERSION} $pkgdir/usr/lib/openra-yr