summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrenton Horne2019-03-23 22:58:43 +1000
committerBrenton Horne2019-03-23 22:58:43 +1000
commit552e05f253b42fbdd6192fbefcee05ce2de4053d (patch)
treecd405f2ae6dbc50fb4d92ef1782ebe735cd16d35
downloadaur-552e05f253b42fbdd6192fbefcee05ce2de4053d.tar.gz
Initial commit
-rw-r--r--.SRCINFO36
-rw-r--r--.gitignore5
-rwxr-xr-xPKGBUILD55
-rwxr-xr-xopenra-yr19
-rwxr-xr-xopenra-yr.appdata.xml37
-rwxr-xr-xopenra-yr.desktop11
-rwxr-xr-xopenra-yr.install18
7 files changed, 181 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1bcedd4c4a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = openra-yr-git
+ pkgdesc = A Command & Conquer: Yuri's Revenge-inspired mod of OpenRA
+ pkgver = 172
+ pkgrel = 1
+ url = https://www.openra.net
+ install = openra-yr.install
+ arch = any
+ license = GPL3
+ makedepends = dos2unix
+ makedepends = git
+ makedepends = unzip
+ depends = mono
+ depends = ttf-dejavu
+ depends = openal
+ depends = libgl
+ depends = freetype2
+ depends = sdl2
+ depends = lua51
+ depends = hicolor-icon-theme
+ depends = gtk-update-icon-cache
+ depends = desktop-file-utils
+ depends = xdg-utils
+ depends = zenity
+ provides = openra-yr
+ options = !strip
+ source = git+https://github.com/cookgreen/yr.git
+ source = openra-yr
+ source = openra-yr.appdata.xml
+ source = openra-yr.desktop
+ md5sums = SKIP
+ md5sums = 9ddf56b241cd992d455ee3c7b602382b
+ md5sums = 51b3883b5f26625f30256a13cb729ea5
+ md5sums = 3be388e2b2fb8b8c33b2e5f3232e9cda
+
+pkgname = openra-yr-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..34145982ebb1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.xz
+yr
+pkg
+src
+*.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..2adccb29726c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+pkgname=openra-yr-git
+_pkgname=openra-yr
+pkgver=172.git.4bd6919
+pkgrel=1
+pkgdesc="A Command & Conquer: Yuri's Revenge-inspired mod of OpenRA"
+arch=('any')
+url="https://www.openra.net"
+license=('GPL3')
+install=openra-yr.install
+depends=('mono' 'ttf-dejavu' 'openal' 'libgl' 'freetype2' 'sdl2' 'lua51' 'hicolor-icon-theme' 'gtk-update-icon-cache'
+ 'desktop-file-utils' 'xdg-utils' 'zenity')
+makedepends=('dos2unix' 'git' 'unzip')
+provides=('openra-yr')
+options=(!strip)
+source=("git+https://github.com/cookgreen/yr.git"
+"openra-yr"
+"openra-yr.appdata.xml"
+"openra-yr.desktop")
+md5sums=('SKIP'
+ '9ddf56b241cd992d455ee3c7b602382b'
+ '51b3883b5f26625f30256a13cb729ea5'
+ '3be388e2b2fb8b8c33b2e5f3232e9cda')
+
+pkgver() {
+ cd $srcdir/yr
+ no=$(git rev-list --count HEAD)
+ hash=$(git log | head -n 1 | cut -d ' ' -f 2 | head -c 7)
+ printf "${no}.git.${hash}"
+}
+
+prepare() {
+ cd $srcdir/yr
+ dos2unix *.md
+ make version VERSION="Master commit ${pkgver}"
+}
+
+build() {
+ cd $srcdir/yr
+ make
+}
+
+package() {
+ cd $srcdir/yr
+ mkdir -p $pkgdir/usr/{lib/openra-yr/mods,bin,share/pixmaps,share/doc/packages/openra-yr,share/applications,share/appdata}
+ install -dm775 $pkgdir/var/games/openra-yr
+ cp -r engine/{glsl,lua,AUTHORS,COPYING,Eluant.dll*,FuzzyLogicLibrary.dll,GeoLite2-Country.mmdb.gz,'global mix database.dat',ICSharpCode.SharpZipLib.dll,launch-dedicated.sh,launch-game.sh,MaxMind.Db.dll,OpenAL-CS.dll,OpenAL-CS.dll.config,Open.Nat.dll,OpenRA.Game.exe,OpenRA.Platforms.Default.dll,OpenRA.Server.exe,OpenRA.Utility.exe,rix0rrr.BeaconLib.dll,SDL2-CS.dll,SDL2-CS.dll.config,SharpFont.dll,SharpFont.dll.config,VERSION} $pkgdir/usr/lib/openra-yr
+ cp -r mods/yr $pkgdir/usr/lib/openra-yr/mods
+ cp -r engine/mods/{common,modcontent} $pkgdir/usr/lib/openra-yr/mods
+ install -Dm755 $srcdir/openra-yr $pkgdir/usr/bin/openra-yr
+ cp -r $srcdir/openra-yr.appdata.xml $pkgdir/usr/share/appdata/openra-yr.appdata.xml
+ cp -r README.md $pkgdir/usr/share/doc/packages/openra-yr/README.md
+ cp -r mods/yr/logo.png $pkgdir/usr/share/pixmaps/openra-yr.png
+ install -Dm644 $srcdir/openra-yr.desktop $pkgdir/usr/share/applications/openra-yr.desktop
+ rm $pkgdir/usr/lib/openra-yr/*.sh
+}
diff --git a/openra-yr b/openra-yr
new file mode 100755
index 000000000000..6e1b8307f5fe
--- /dev/null
+++ b/openra-yr
@@ -0,0 +1,19 @@
+#!/bin/sh
+cd "/usr/lib/openra-yr"
+
+# Run the game
+mono --debug OpenRA.Game.exe Game.Mod=yr Engine.LaunchPath="/usr/bin/openra-yr" "Engine.ModSearchPaths=/usr/lib/openra-yr/mods" "$@"
+
+# Show a crash dialog if something went wrong
+if [ $? != 0 ] && [ $? != 1 ]; then
+ ERROR_MESSAGE="Yuri's Revenge has encountered a fatal error.\nPlease refer to the crash logs and FAQ for more information.\n\nLog files are located in ~/.openra/Logs\nThe FAQ is available at http://wiki.openra.net/FAQ"
+ if command -v zenity > /dev/null; then
+ zenity --no-wrap --error --title "Yuri's Revenge" --text "${ERROR_MESSAGE}" 2> /dev/null
+ elif command -v kdialog > /dev/null; then
+ kdialog --title "Yuri's Revenge" --error "${ERROR_MESSAGE}"
+ else
+ printf "${ERROR_MESSAGE}\n"
+ fi
+ exit 1
+fi
+
diff --git a/openra-yr.appdata.xml b/openra-yr.appdata.xml
new file mode 100755
index 000000000000..e1cfff00f84f
--- /dev/null
+++ b/openra-yr.appdata.xml
@@ -0,0 +1,37 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<component type="desktop">
+ <id>openra-gen.desktop</id>
+ <metadata_license>CC0-1.0</metadata_license>
+ <project_license>GPL-3.0</project_license>
+ <name>OpenRA - Generals Alpha</name>
+ <summary>An open-source remake of the original Command Command &amp; Conquer: Generals Conquer: Yuri's Revenge game</summary>
+ <description>
+ <p>
+ OpenRA Yuri's Revenge is a project that recreates and modernizes the classic Command Command &amp; Conquer: Generals Conquer: Yuri's Revenge real time strategy game.
+ </p>
+ </description>
+ <url type="homepage">https://github.com/cookgreen/yr</url>
+ <update_contact>mustafaoyunda37@gmail.com</update_contact>
+ <content_rating type="oars-1.0">
+ <content_attribute id="violence-cartoon">none</content_attribute>
+ <content_attribute id="violence-fantasy">none</content_attribute>
+ <content_attribute id="violence-realistic">moderate</content_attribute>
+ <content_attribute id="violence-bloodshed">moderate</content_attribute>
+ <content_attribute id="violence-sexual">none</content_attribute>
+ <content_attribute id="drugs-alcohol">none</content_attribute>
+ <content_attribute id="drugs-narcotics">none</content_attribute>
+ <content_attribute id="drugs-tobacco">none</content_attribute>
+ <content_attribute id="sex-nudity">none</content_attribute>
+ <content_attribute id="sex-themes">none</content_attribute>
+ <content_attribute id="language-profanity">mild</content_attribute>
+ <content_attribute id="language-humor">mild</content_attribute>
+ <content_attribute id="language-discrimination">none</content_attribute>
+ <content_attribute id="social-chat">intense</content_attribute>
+ <content_attribute id="social-info">none</content_attribute>
+ <content_attribute id="social-audio">none</content_attribute>
+ <content_attribute id="social-location">none</content_attribute>
+ <content_attribute id="social-contacts">none</content_attribute>
+ <content_attribute id="money-purchasing">none</content_attribute>
+ <content_attribute id="money-gambling">none</content_attribute>
+ </content_rating>
+</component>
diff --git a/openra-yr.desktop b/openra-yr.desktop
new file mode 100755
index 000000000000..e122f40140f5
--- /dev/null
+++ b/openra-yr.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=OpenRA - Yuri's Revenge
+GenericName=Real Time Strategy Game
+GenericName[de]=Echtzeit-Strategiespiel
+Comment=Reimagining of the Command Yuri's Revenge: The Future of War Conquer: Yuri's Revenge game
+Icon=openra-yr
+Exec=openra-yr
+Terminal=false
+Categories=Game;StrategyGame;X-RTS;X-RealTimeStrategy;X-RealTimeStrategyGame;
diff --git a/openra-yr.install b/openra-yr.install
new file mode 100755
index 000000000000..a00383965830
--- /dev/null
+++ b/openra-yr.install
@@ -0,0 +1,18 @@
+post_upgrade() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_install() {
+ echo "If the game doesn't run, try using the Cg renderer ~/.openra/settings.yaml like so:"
+ echo "Graphics:"
+ echo " Renderer: Cg"
+ echo "Be careful to only use one indenting tab with 8 shift width."
+ post_upgrade
+}
+
+post_remove() {
+ echo "openra downloaded data files to ~/.openra/Content and you might want"
+ echo "to delete those."
+ post_upgrade
+}