summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Dupke2023-03-26 19:47:50 -0400
committerRyan Dupke2023-03-26 19:47:50 -0400
commit546cbf055ace6e8f720c43ee90cca183e5dc110f (patch)
tree679a89f895162355c2fef02fabf4c83fa4dc5069
parentb1c5bf9438e136e482da0e7419d06b205a8a41aa (diff)
downloadaur-546cbf055ace6e8f720c43ee90cca183e5dc110f.tar.gz
Update PKGBUILD
List myself as the active maintainer, and apply Thaodan's patch
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD39
2 files changed, 29 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81f3b4bba299..04c3cfbce002 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openrct2-git
pkgdesc = Open source re-implementation of Roller Coaster Tycoon 2 (requires full copy of the game)
- pkgver = r21143.594b08c91
+ pkgver = 0.4.3.r416.g62b0a5edfe
pkgrel = 1
url = https://openrct2.io
install = openrct2.install
@@ -11,19 +11,21 @@ pkgbase = openrct2-git
license = GPL3
makedepends = git
makedepends = cmake
- makedepends = discord-rpc-api
+ makedepends = nlohmann-json
depends = hicolor-icon-theme
depends = sdl2
depends = curl
- depends = nlohmann-json
depends = speexdsp
depends = fontconfig
depends = libpng
depends = openssl
depends = libzip
depends = icu
- depends = duktape
depends = benchmark
+ depends = libogg
+ depends = libvorbis
+ depends = flac
+ depends = discord-rpc
optdepends = zenity: System dialog box support (GNOME/GTK)
optdepends = kdialog: System dialog box support (KDE)
optdepends = alsa-lib: ALSA audio driver
@@ -34,4 +36,3 @@ pkgbase = openrct2-git
sha256sums = SKIP
pkgname = openrct2-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 4ec7047196a5..20651ff66101 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,17 @@
-# Maintainer: Graham Edgecombe <graham@grahamedgecombe.com>
+# Maintainer: Ryan Dupke <rctdude2 at gmail dot com>
+# Contributor: Graham Edgecombe <graham@grahamedgecombe.com>
pkgname=openrct2-git
-pkgver=r21143.594b08c91
+pkgver=0.4.3.r416.g62b0a5edfe
pkgrel=1
pkgdesc='Open source re-implementation of Roller Coaster Tycoon 2 (requires full
copy of the game)'
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url='https://openrct2.io'
license=('GPL3')
-depends=('hicolor-icon-theme' 'sdl2' 'curl' 'nlohmann-json' 'speexdsp'
- 'fontconfig' 'libpng' 'openssl' 'libzip' 'icu' 'duktape' 'benchmark')
-makedepends=('git' 'cmake' 'discord-rpc-api')
+depends=('hicolor-icon-theme' 'sdl2' 'curl' 'speexdsp'
+ 'fontconfig' 'libpng' 'openssl' 'libzip' 'icu' 'benchmark'
+ 'libogg' 'libvorbis' 'flac' 'discord-rpc')
+makedepends=('git' 'cmake' 'nlohmann-json')
optdepends=('zenity: System dialog box support (GNOME/GTK)'
'kdialog: System dialog box support (KDE)'
'alsa-lib: ALSA audio driver'
@@ -21,24 +23,29 @@ source=("$pkgname"::'git+https://github.com/OpenRCT2/OpenRCT2.git#branch=develop
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$pkgname"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/$pkgname"
+ # Required options to workaround GCC 12 issues
+ # https://github.com/OpenRCT2/OpenRCT2/issues/17371
+ CXXFLAGS+=" -Wno-error=maybe-uninitialized -Wno-error=restrict -Wno-error=null-dereference"
- mkdir -p build
- cd build
- cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib ..
- make all g2
+ # Needed to be able to build while LTO is enabled
+ # https://github.com/OpenRCT2/OpenRCT2/issues/6200
+ CXXFLAGS+=" -Wno-error=stringop-overflow"
+
+ cmake -B build -S "$pkgname" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DSTATIC=OFF \
+ -Wno-dev
+ cmake --build build -v
}
package() {
- cd "$srcdir/$pkgname/build"
-
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
rm "$pkgdir/usr/lib/libopenrct2.a"
rmdir "$pkgdir/usr/lib"