summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraham Edgecombe2014-05-27 10:45:10 +0100
committerGraham Edgecombe2014-05-27 10:55:16 +0100
commita03446add53cd1c39584be2c484f1c64d247a042 (patch)
tree62fa1de9c17ca2629ec1e00e1055849a03431fe5
downloadaur-a03446add53cd1c39584be2c484f1c64d247a042.tar.gz
Initial commit.
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD44
-rwxr-xr-xopenrct22
-rw-r--r--openrct2.desktop8
-rw-r--r--openrct2.install6
6 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a15992376029
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = openrct2-git
+ pkgdesc = Open source clone of RollerCoaster Tycoon 2
+ pkgver = r630.835835b
+ pkgrel = 1
+ url = https://openrct2.com
+ install = openrct2.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = mingw-w64-gcc
+ depends = wine
+ depends = mingw-w64-sdl2
+ options = !buildflags
+ source = openrct2-git::git://github.com/IntelOrca/OpenRCT2.git
+ source = openrct2
+ source = openrct2.desktop
+ md5sums = SKIP
+ md5sums = 58efc9b12751ae8a4ca62ba7fd48e945
+ md5sums = f3623006456c3c25878371a89873c8db
+
+pkgname = openrct2-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..469799f74b06
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+.*
+*~
+!.git*
+!.mailmap
+/src
+/pkg
+/openrct2-git
+*.tar.xz
+*.tar.xz.sig
+*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e93375f2c9ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Graham Edgecombe <graham@grahamedgecombe.com>
+pkgname=openrct2-git
+pkgver=r630.835835b
+pkgrel=1
+pkgdesc="Open source clone of RollerCoaster Tycoon 2"
+arch=('i686' 'x86_64')
+url="https://openrct2.com"
+license=('GPL3')
+depends=('wine' 'mingw-w64-sdl2')
+makedepends=('git' 'cmake' 'mingw-w64-gcc')
+options=('!buildflags')
+install=openrct2.install
+source=("$pkgname"::'git://github.com/IntelOrca/OpenRCT2.git'
+ 'openrct2'
+ 'openrct2.desktop')
+md5sums=('SKIP'
+ '58efc9b12751ae8a4ca62ba7fd48e945'
+ 'f3623006456c3c25878371a89873c8db')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ cmake -DCMAKE_TOOLCHAIN_FILE=CMakeLists_mingw.txt -DCMAKE_BUILD_TYPE=Debug .
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm644 openrct2.dll "$pkgdir/usr/lib/openrct2/openrct2.dll"
+ install -Dm755 openrct2.exe "$pkgdir/usr/lib/openrct2/openrct2.exe"
+ install -Dm755 "$srcdir/openrct2" "$pkgdir/usr/bin/openrct2"
+ install -Dm644 "$srcdir/openrct2.desktop" "$pkgdir/usr/share/applications/openrct2.desktop"
+
+ # For Wine to find the SDL2.dll file it needs to be in the same
+ # directory as openrct2.exe, so we symlink it in place. We don't use
+ # $CARCH here because on x86_64 OpenRCT2 is compiled with -m32,
+ # therefore we always want to use the i686 DLL. OpenRCT2 relies on
+ # Wine's WoW64 support to actually run on x86_64 machines.
+ ln -s /usr/i686-w64-mingw32/bin/SDL2.dll "$pkgdir/usr/lib/openrct2"
+}
diff --git a/openrct2 b/openrct2
new file mode 100755
index 000000000000..e2a52cc075bd
--- /dev/null
+++ b/openrct2
@@ -0,0 +1,2 @@
+#!/bin/sh -e
+exec wine /usr/lib/openrct2/openrct2.exe
diff --git a/openrct2.desktop b/openrct2.desktop
new file mode 100644
index 000000000000..28f5723abf33
--- /dev/null
+++ b/openrct2.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=OpenRCT2
+Comment=Open-source clone of RollerCoaster Tycoon 2
+Exec=openrct2
+Terminal=false
+Categories=Game;
diff --git a/openrct2.install b/openrct2.install
new file mode 100644
index 000000000000..2d1fb467141a
--- /dev/null
+++ b/openrct2.install
@@ -0,0 +1,6 @@
+post_install() {
+ cat <<EOF
+For OpenRCT2 to run you must install a retail copy of RollerCoaster Tycoon 2
+with Wine.
+EOF
+}