summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlsf2023-05-30 08:56:44 +0200
committerlsf2023-05-30 08:56:44 +0200
commitb645cdf09d042b499a6de615ba0f0b011fbf20f6 (patch)
treec3417eb4c316411d14078bbb2666feb5b3056fc0
parent9bdd5ee13f4af786a7f1d4023cb157da101536c9 (diff)
downloadaur-b645cdf09d042b499a6de615ba0f0b011fbf20f6.tar.gz
now actually including the patch :D
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Build-with-Archlinux.patch23
-rw-r--r--PKGBUILD12
3 files changed, 34 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d27bc9fd405..569a1745b1ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = opensnitch-ebpf-module-git
pkgdesc = eBPF process monitor module for opensnitch
- pkgver = 1.6.0rc5.r75.89dc6ab
- pkgrel = 1
+ pkgver = 1.6.0rc5.r76.102b65e
+ pkgrel = 2
url = https://github.com/evilsocket/opensnitch
arch = i686
arch = x86_64
@@ -24,6 +24,8 @@ pkgbase = opensnitch-ebpf-module-git
conflicts = opensnitch-ebpf-module
options = !strip
source = git+https://github.com/evilsocket/opensnitch.git
+ source = 0001-Build-with-Archlinux.patch
sha256sums = SKIP
+ sha256sums = 446c029de1cbd39308575e346511d80ee160d2dea575d64fddc7835fc3040460
pkgname = opensnitch-ebpf-module-git
diff --git a/0001-Build-with-Archlinux.patch b/0001-Build-with-Archlinux.patch
new file mode 100644
index 000000000000..24c84f6b96b1
--- /dev/null
+++ b/0001-Build-with-Archlinux.patch
@@ -0,0 +1,23 @@
+diff --git a/ebpf_prog/Makefile b/ebpf_prog/Makefile
+index d987814..5f7bc10 100644
+--- a/ebpf_prog/Makefile
++++ b/ebpf_prog/Makefile
+@@ -29,6 +29,7 @@ endif
+
+ BIN := opensnitch.o opensnitch-procs.o opensnitch-dns.o
+ CLANG_FLAGS = -I. \
++ -I$(KERNEL_HEADERS)/arch/$(ARCH)/include/ \
+ -I$(KERNEL_HEADERS)/arch/$(ARCH)/include/generated/ \
+ -I$(KERNEL_HEADERS)/include \
+ -include $(KERNEL_DIR)/include/linux/kconfig.h \
+@@ -45,7 +46,9 @@ CLANG_FLAGS = -I. \
+ $(EXTRA_FLAGS) \
+ -Wno-gnu-variable-sized-type-not-at-end \
+ -Wno-address-of-packed-member -Wno-tautological-compare \
+- -Wno-unknown-warning-option \
++ -Wno-unknown-warning-option \
++ -fcf-protection \
++ -fno-stack-protector \
+ -g -O2 -emit-llvm
+
+ all: $(BIN)
diff --git a/PKGBUILD b/PKGBUILD
index 7f459acbac2d..8c6d14f11d20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=opensnitch-ebpf-module-git
_pkgname=opensnitch
-pkgver=1.6.0rc5.r75.89dc6ab
-pkgrel=1
+pkgver=1.6.0rc5.r76.102b65e
+pkgrel=2
pkgdesc="eBPF process monitor module for opensnitch"
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/evilsocket/opensnitch"
@@ -14,8 +14,10 @@ makedepends=('git' 'clang' 'llvm' 'libelf'
depends=('opensnitch')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://github.com/evilsocket/opensnitch.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/evilsocket/opensnitch.git'
+ '0001-Build-with-Archlinux.patch')
+sha256sums=('SKIP'
+ '446c029de1cbd39308575e346511d80ee160d2dea575d64fddc7835fc3040460')
options=('!strip') # we're stripping with llvm-strip
pkgver() {
@@ -26,7 +28,7 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}/ebpf_prog"
- patch Makefile < "${srcdir}/../0001-Build-with-Archlinux.patch"
+ patch Makefile < "${srcdir}/0001-Build-with-Archlinux.patch"
}
build() {