summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Walladge2019-08-12 18:32:04 +0930
committerSamuel Walladge2019-08-12 18:32:04 +0930
commit10c77d0c5cb73f967c209fdb67ac79d1c560e65c (patch)
tree97438b02f21c48da1906ebd5f87b1e9555453de3
parentb12f92072a4f53465b088cdc1ed29f7062626360 (diff)
downloadaur-10c77d0c5cb73f967c209fdb67ac79d1c560e65c.tar.gz
use upstream's documented build type
This may help resolve the segfaults discussed here: https://github.com/yvt/openspades/issues/845
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62460c8d256b..25462c1a80c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openspades
pkgdesc = A clone of Voxlap Ace of Spades 0.75
pkgver = 0.1.3
- pkgrel = 1
+ pkgrel = 2
url = http://openspades.yvt.jp/
install = openspades.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 61236f08b170..4590698a9233 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=openspades
pkgver=0.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="A clone of Voxlap Ace of Spades 0.75"
arch=('i686' 'x86_64')
url="http://openspades.yvt.jp/"
@@ -17,7 +17,7 @@ sha256sums=('ecd7aaf568f80712d981ecdd7bf9e380221dc2c16e86d2e56a0ddda87432bea3')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- cmake -D CMAKE_INSTALL_PREFIX=/usr -D CMAKE_BUILD_TYPE=Release -D OPENSPADES_RESDIR=/usr/share/openspades/Resources -D OPENSPADES_INSTALL_RESOURCES=share/openspades/Resources -D OPENSPADES_INSTALL_BINARY=bin .
+ cmake -D CMAKE_INSTALL_PREFIX=/usr -D CMAKE_BUILD_TYPE=RelWithDebInfo -D OPENSPADES_RESDIR=/usr/share/openspades/Resources -D OPENSPADES_INSTALL_RESOURCES=share/openspades/Resources -D OPENSPADES_INSTALL_BINARY=bin .
make
}