summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrottweiler2015-08-11 10:32:31 +0200
committerBrottweiler2015-08-11 10:32:31 +0200
commitfd2da71959a54f067336a8e3a9f4c724c85f5488 (patch)
tree3ea684c51c40ce5ac4cd23f8d10ec1e9e907bdcd
downloadaur-fd2da71959a54f067336a8e3a9f4c724c85f5488.tar.gz
Initial import
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD34
-rw-r--r--openspades.install12
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abd61622a376
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = openspades-git
+ pkgdesc = A clone of Voxlap Ace of Spades 0.75 (git version)
+ pkgver = 0.0.12.16.g6ffc0b2
+ pkgrel = 1
+ url = https://sites.google.com/a/yvt.jp/openspades/
+ install = openspades.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ makedepends = imagemagick
+ makedepends = unzip
+ makedepends = wget
+ depends = curl
+ depends = desktop-file-utils
+ depends = glew
+ depends = hicolor-icon-theme
+ depends = mesa
+ depends = openal
+ depends = sdl2
+ depends = sdl2_image
+ provides = openspades
+ conflicts = openspades
+ source = openspades-git::git://github.com/yvt/openspades.git
+ md5sums = SKIP
+
+pkgname = openspades-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f08ecd89d1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Brottweiler <brott@oc.tc>
+# Contributor: kusakata <shohei atmark kusakata period com>
+
+pkgname=openspades-git
+pkgver=0.0.12.16.g6ffc0b2
+pkgrel=1
+pkgdesc="A clone of Voxlap Ace of Spades 0.75 (git version)"
+arch=('i686' 'x86_64')
+url="https://sites.google.com/a/yvt.jp/openspades/"
+license=('GPL3')
+depends=('curl' 'desktop-file-utils' 'glew' 'hicolor-icon-theme' 'mesa' 'openal' 'sdl2' 'sdl2_image')
+makedepends=('cmake' 'git' 'imagemagick' 'unzip' 'wget')
+provides=('openspades')
+conflicts=('openspades')
+install=openspades.install
+source=("$pkgname"::'git://github.com/yvt/openspades.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --tags | sed 's/^v//' | sed 's/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ cmake -D CMAKE_INSTALL_PREFIX=/usr -D CMAKE_BUILD_TYPE=Release -D OPENSPADES_RESDIR=/usr/share/openspades-git/Resources -D OPENSPADES_INSTALL_RESOURCES=share/openspades-git/Resources -D OPENSPADES_INSTALL_BINARY=bin .
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}/usr/share/menu"
+}
diff --git a/openspades.install b/openspades.install
new file mode 100644
index 000000000000..dcc06de40405
--- /dev/null
+++ b/openspades.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}