summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikola Pavlica2021-11-01 22:37:29 +0100
committerNikola Pavlica2021-11-01 22:37:29 +0100
commitf4f8123e83abc8f878869d77a34374ff4172bee5 (patch)
tree8c1d14bce7b94cdfd8d706e0b812714abab7312f
parent2c43775728ea5f285f9dda7141fd26ae69519849 (diff)
downloadaur-openssh-xdg-git.tar.gz
add hacky openssh XDG patch
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70d428e8fae2..93703bde5da8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
-pkgbase = openssh-git
- pkgdesc = Free version of the SSH connectivity tools
+pkgbase = openssh-xdg-git
+ pkgdesc = Free version of the SSH connectivity tools (with XDG support)
pkgver = 7.9.P1.r242.gf5abb05f
pkgrel = 1
url = http://www.openssh.org/portable.html
@@ -7,7 +7,6 @@ pkgbase = openssh-git
arch = x86_64
license = custom:BSD
makedepends = git
- makedepends = linux-headers
depends = krb5
depends = openssl
depends = libedit
@@ -34,5 +33,5 @@ pkgbase = openssh-git
sha256sums = 4effac1186cc62617f44385415103021f72f674f8b8e26447fc1139c670090f6
sha256sums = 64576021515c0a98b0aaf0a0ae02e0f5ebe8ee525b1e647ab68f369f81ecd846
-pkgname = openssh-git
+pkgname = openssh-xdg-git
diff --git a/PKGBUILD b/PKGBUILD
index afb19202ef52..d39c780f2e94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
-# Maintainer: Christian Hesse <mail@eworm.de>
+# Maintainer: Nikola Pavlica <pavlica.nikola@gmail.com>
+# Contributor: Christian Hesse <mail@eworm.de>
# Contributor: Gaetan Bisson <bisson@archlinux.org>
# Contributor: Aaron Griffin <aaron@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
-pkgname=openssh-git
-pkgver=7.9.P1.r242.gf5abb05f
+pkgname=openssh-xdg-git
+pkgver=8.8.P1.r64.g0328a081
pkgrel=1
-pkgdesc='Free version of the SSH connectivity tools'
+pkgdesc='Free version of the SSH connectivity tools (with XDG support)'
url='http://www.openssh.org/portable.html'
license=('custom:BSD')
arch=('i686' 'x86_64')
-makedepends=('git' 'linux-headers')
+makedepends=('git')
depends=('krb5' 'openssl' 'libedit' 'ldns')
optdepends=('xorg-xauth: X11 forwarding'
'x11-ssh-askpass: input passphrase in X')
@@ -49,6 +50,13 @@ pkgver() {
fi
}
+prepare() {
+ cd openssh/
+ echo -n "\"Patching\"..."
+ grep -rl "\.ssh" * | xargs sed -i 's/\.ssh/.config\/ssh/g'
+ echo "done"
+}
+
build() {
cd openssh/