summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian 'gonX' Jensen2022-12-26 23:53:14 +0100
committerSebastian 'gonX' Jensen2022-12-26 23:53:14 +0100
commit512d3d7d6c05f2d47d628ecdb81093b2330af56a (patch)
tree5379d976bbe103c2082beeae45bbfbf364e4cef4
parent41786e67570324a9124cbd64655ebceaf81803b5 (diff)
downloadaur-512d3d7d6c05f2d47d628ecdb81093b2330af56a.tar.gz
Force-disable stripping
This causes issues with the current dotnet toolchain after the recent changes to the build script which forcefully embed debug symbols with no way to disable it. This commit will likely be reverted once stripping support is back in
-rw-r--r--PKGBUILD5
1 files changed, 1 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 54e9f6121580..bd0bd32dcd60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,6 +24,7 @@ source=('git+https://github.com/OpenTabletDriver/OpenTabletDriver'
"$_pkgname.desktop"
"notes.install"
)
+options=(!strip) # sorry, seems like dotnet bug
sha256sums=('SKIP'
'a3e5a2e4b8e7b17776bfa3fc33cb33f13bc26d6756ba5ada8200ca708f33e293'
@@ -57,10 +58,6 @@ build() {
PREFIX=$(git describe --long --tags | sed 's/-.*//;s/v//')
fi
- if check_option "strip" y; then
- EXTRA_OPTIONS="/p:DebugType=None /p:DebugSymbols=false"
- fi
-
./build.sh linux-x64 \
/p:VersionPrefix="$PREFIX" \
$EXTRA_OPTIONS