summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Höher2020-08-12 00:04:21 +0200
committerMartin Höher2020-08-12 00:04:21 +0200
commitb505c76c76927d0d1c602b859c8ab55caba58274 (patch)
tree65ecea06fab36f6daa105a8a5a02943bed209923
downloadaur-b505c76c76927d0d1c602b859c8ab55caba58274.tar.gz
OpenTodoList v3.25.0
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD58
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..91d3321eb7c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = opentodolist
+ pkgdesc = Maintain todo lists, notes and images in libraries, which can be synced via various services like NextCloud between your devices.
+ pkgver = 3.25.0
+ pkgrel = 1
+ url = https://opentodolist.rpdev.net/
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = qt5-base
+ depends = qt5-tools
+ depends = qt5-quickcontrols2
+ depends = syntax-highlighting
+ depends = libsecret
+ depends = ttf-roboto
+ depends = noto-fonts
+ provides = opentodolist
+ conflicts = opentodolist
+ source = opentodolist::git+https://gitlab.com/rpdev/opentodolist.git#commit=3.25.0
+ md5sums = SKIP
+
+pkgname = opentodolist
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..241e560df690
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5233f66d9ea9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Martin Hoeher <martin@rpdev.net>
+pkgname=OpenTodoList
+pkgver=3.25.0
+pkgrel=1
+pkgdesc="Maintain todo lists, notes and images in libraries, which can be synced via various services like NextCloud between your devices."
+arch=('x86_64')
+url="https://opentodolist.rpdev.net/"
+license=('GPL')
+groups=()
+depends=('qt5-base' 'qt5-tools' 'qt5-quickcontrols2' 'syntax-highlighting' 'libsecret' 'ttf-roboto' 'noto-fonts')
+makedepends=('git')
+provides=("${pkgname%}")
+conflicts=("${pkgname%}")
+replaces=()
+backup=()
+options=()
+install=
+source=("${pkgname}::git+https://gitlab.com/rpdev/opentodolist.git#commit=${pkgver}")
+noextract=()
+md5sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/${pkgname%}"
+ release_build=yes
+ if [ -n "$release_build" ]; then
+ printf "${pkgver}"
+ else
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ fi
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%}"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "$srcdir/${pkgname%}"
+ mkdir -p build
+ cd build
+ qmake CONFIG+=release INSTALL_PREFIX=/usr ..
+ make -j4
+}
+
+check() {
+ cd "$srcdir/${pkgname%}"
+ cd build
+ make check
+}
+
+package() {
+ cd "$srcdir/${pkgname%}"
+ cd build
+ make INSTALL_ROOT="$pkgdir/" install
+}