summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Wright2016-06-23 22:51:48 +0100
committerJonathan Wright2016-06-23 22:51:48 +0100
commitf603f448cc443852a2888b37640db8b362660a25 (patch)
tree2d5e2e245771dde3cc97bdd07da56b1ccbac8d53
downloadaur-f603f448cc443852a2888b37640db8b362660a25.tar.gz
First commit of first release
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD18
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50ac9b2b8699
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Jun 23 21:51:31 UTC 2016
+pkgbase = openvpn-update-systemd-resolved
+ pkgdesc = OpenVPN systemd-resolved Updater
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/jonathanio/update-systemd-resolved
+ arch = any
+ license = GPL
+ depends = openvpn
+ depends = bash
+ depends = iproute2
+ depends = systemd>229
+ source = https://github.com/jonathanio/update-systemd-resolved/archive/v1.0.0.tar.gz
+ sha256sums = ba3471acade86b257032b7ce4190af36016355a9fffd507b65e886e3aec3d115
+ sha512sums = b8d44792c1d1aa061ea574dd379088e75fb29d8b26897042c79ca6ac6d56c2324cc7467a12df0f52bfcd0599b3cb61beecb3d5fd88fb2b1d8d3384498a74ce1e
+
+pkgname = openvpn-update-systemd-resolved
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93ef5c11eb96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname=openvpn-update-systemd-resolved
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="OpenVPN systemd-resolved Updater"
+arch=("any")
+url="https://github.com/jonathanio/update-systemd-resolved"
+license=("GPL")
+depends=("openvpn" "bash" "iproute2" "systemd>229")
+source=("https://github.com/jonathanio/update-systemd-resolved/archive/v${pkgver}.tar.gz")
+sha256sums=("ba3471acade86b257032b7ce4190af36016355a9fffd507b65e886e3aec3d115")
+sha512sums=("b8d44792c1d1aa061ea574dd379088e75fb29d8b26897042c79ca6ac6d56c2324cc7467a12df0f52bfcd0599b3cb61beecb3d5fd88fb2b1d8d3384498a74ce1e")
+
+package() {
+ cd $srcdir/update-systemd-resolved-${pkgver}
+ install -D -m655 update-systemd-resolved "${pkgdir}/etc/openvpn/update-system-resolved"
+}
+
+# vim:set ts=2 sw=2 et: