summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2019-08-29 15:24:14 +0200
committerLubosz Sarnecki2019-08-29 15:29:15 +0200
commit08f8a85274dab678ae54c7325f5786af6ea26e58 (patch)
treef384695af03fb0721bce45c6db2f519ec1618b00
parent4e044fabfb273b629b71be485b9c22b26edfa651 (diff)
downloadaur-08f8a85274dab678ae54c7325f5786af6ea26e58.tar.gz
Fix version number.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c5cfa851c57..c5635ddb3030 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Aug 29 13:26:41 UTC 2019
+# Thu Aug 29 13:27:20 UTC 2019
pkgbase = openvr-git
pkgdesc = API and runtime that allows access to VR hardware from multiple vendors.
- pkgver = .1.6.10b.r0.g52065df
+ pkgver = 1.6.10b.65.52065df
pkgrel = 1
url = https://github.com/ValveSoftware/openvr
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index c8fee5ef822c..6f8949996ed7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=openvr-git
-pkgver=.1.6.10b.r0.g52065df
+pkgver=1.6.10b.65.52065df
pkgrel=1
pkgdesc="API and runtime that allows access to VR hardware from multiple vendors."
arch=('x86_64')
@@ -26,8 +26,17 @@ install_examples=false
pkgver() {
cd "$srcdir/openvr"
- #echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+
+ ver=$(git describe | sed 's/^v//')
+ hash=$(git rev-parse --short HEAD)
+ revision=$(git rev-list --count HEAD)
+
+ # remove a trailing "." if needed
+ if [[ ${ver:0:1} == "." ]] ; then
+ ver=${ver:1:${#ver}}
+ fi
+
+ echo $ver.$revision.$hash
}