summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Haag2018-11-01 00:39:25 +0100
committerChristoph Haag2018-11-01 00:39:25 +0100
commit240035b4f64db3b682ca525e93eda7da15fd8886 (patch)
tree0453e6fd3e5e11ac74f38e31f8a1ed59ebc01278
parentd8c247d74628cdeca8bd427362d25e2a409007ef (diff)
downloadaur-240035b4f64db3b682ca525e93eda7da15fd8886.tar.gz
update to 1.0.17
-rw-r--r--.SRCINFO8
-rw-r--r--0001-fix-VREvent_Data_t-union-in-c-header-and-add-pragma-.patch89
-rw-r--r--PKGBUILD8
3 files changed, 6 insertions, 99 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d3b8ee74722..b0b5f0510717 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Aug 7 23:11:59 UTC 2018
+# Wed Oct 31 23:39:21 UTC 2018
pkgbase = openvr-git
pkgdesc = API and runtime that allows access to VR hardware from multiple vendors. Contains API and samples. The runtime is under SteamVR in Tools on Steam.
- pkgver = 1.0.16.r0.g6aacebd
- pkgrel = 2
+ pkgver = 1.0.17.r0.g1fb1030
+ pkgrel = 1
url = https://github.com/ValveSoftware/openvr
arch = x86_64
license = custom
@@ -22,12 +22,10 @@ pkgbase = openvr-git
source = git+https://github.com/ValveSoftware/openvr.git
source = https://github.com/ValveSoftware/openvr/commit/0fa21ba17748efcca1816536e27bdca70141b074.patch
source = https://github.com/ValveSoftware/openvr/commit/4f9149928e29e9f92e6d8dc39f984d1a557a42b3.patch
- source = 0001-fix-VREvent_Data_t-union-in-c-header-and-add-pragma-.patch
source = 0001-also-add-pragma-pack-around-VRControllerState_t.patch
md5sums = SKIP
md5sums = 7350517830b1a0038d30c6ad33b4bb39
md5sums = dfb4306bb93633e467862cd8990e6e79
- md5sums = 97bc5ddeee3f2005afdc32b689711131
md5sums = 8a9379f8cdf9a38f21942f46378714a5
pkgname = openvr-git
diff --git a/0001-fix-VREvent_Data_t-union-in-c-header-and-add-pragma-.patch b/0001-fix-VREvent_Data_t-union-in-c-header-and-add-pragma-.patch
deleted file mode 100644
index d2d9b88244f5..000000000000
--- a/0001-fix-VREvent_Data_t-union-in-c-header-and-add-pragma-.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-From 9633359e79d5347d5667d2f2b5b46c720c559601 Mon Sep 17 00:00:00 2001
-From: Christoph Haag <christoph.haag@collabora.com>
-Date: Mon, 30 Jul 2018 17:18:44 +0200
-Subject: [PATCH] fix VREvent_Data_t union in c header and add pragma pack(
- push, 4)
-
-v2: pop pragma pack after VrEvent_t
----
- headers/openvr_capi.h | 56 ++++++++++++++++++++++++++++---------------
- 1 file changed, 37 insertions(+), 19 deletions(-)
-
-diff --git a/headers/openvr_capi.h b/headers/openvr_capi.h
-index 1ee5a36..74c0fa6 100644
---- a/headers/openvr_capi.h
-+++ b/headers/openvr_capi.h
-@@ -1966,25 +1966,41 @@ typedef struct COpenVRContext
- intptr_t m_pVRSpatialAnchors; // class vr::IVRSpatialAnchors *
- } COpenVRContext;
-
-+ typedef union
-+ {
-+ VREvent_Reserved_t reserved;
-+ VREvent_Controller_t controller;
-+ VREvent_Mouse_t mouse;
-+ VREvent_Scroll_t scroll;
-+ VREvent_Process_t process;
-+ VREvent_Notification_t notification;
-+ VREvent_Overlay_t overlay;
-+ VREvent_Status_t status;
-+ VREvent_Keyboard_t keyboard;
-+ VREvent_Ipd_t ipd;
-+ VREvent_Chaperone_t chaperone;
-+ VREvent_PerformanceTest_t performanceTest;
-+ VREvent_TouchPadMove_t touchPadMove;
-+ VREvent_SeatedZeroPoseReset_t seatedZeroPoseReset;
-+ VREvent_Screenshot_t screenshot;
-+ VREvent_ScreenshotProgress_t screenshotProgress;
-+ VREvent_ApplicationLaunch_t applicationLaunch;
-+ VREvent_EditingCameraSurface_t cameraSurface;
-+ VREvent_MessageOverlay_t messageOverlay;
-+ VREvent_Property_t property;
-+ VREvent_DualAnalog_t dualAnalog;
-+ VREvent_HapticVibration_t hapticVibration;
-+ VREvent_WebConsole_t webConsole;
-+ VREvent_InputBindingLoad_t inputBinding;
-+ VREvent_InputActionManifestLoad_t actionManifest;
-+ VREvent_SpatialAnchor_t spatialAnchor;
-+} VREvent_Data_t;
-
--typedef union
--{
-- VREvent_Reserved_t reserved;
-- VREvent_Controller_t controller;
-- VREvent_Mouse_t mouse;
-- VREvent_Scroll_t scroll;
-- VREvent_Process_t process;
-- VREvent_Notification_t notification;
-- VREvent_Overlay_t overlay;
-- VREvent_Status_t status;
-- VREvent_Keyboard_t keyboard;
-- VREvent_Ipd_t ipd;
-- VREvent_Chaperone_t chaperone;
-- VREvent_PerformanceTest_t performanceTest;
-- VREvent_TouchPadMove_t touchPadMove;
-- VREvent_SeatedZeroPoseReset_t seatedZeroPoseReset;
--} VREvent_Data_t;
--
-+#if defined(__linux__) || defined(__APPLE__)
-+// This structure was originally defined mis-packed on Linux, preserved for
-+// compatibility.
-+#pragma pack( push, 4 )
-+#endif
- /** An event posted by the server to all running applications */
- struct VREvent_t
- {
-@@ -1994,7 +2010,9 @@ struct VREvent_t
- // event data must be the end of the struct as its size is variable
- VREvent_Data_t data;
- };
--
-+#if defined(__linux__) || defined(__APPLE__)
-+#pragma pack( pop )
-+#endif
-
- typedef union
- {
---
-2.18.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 9ac6c0c2dd4b..9b00fd9195ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=openvr-git
-pkgver=1.0.16.r0.g6aacebd
-pkgrel=2
+pkgver=1.0.17.r0.g1fb1030
+pkgrel=1
pkgdesc="API and runtime that allows access to VR hardware from multiple vendors. Contains API and samples. The runtime is under SteamVR in Tools on Steam."
arch=('x86_64')
url="https://github.com/ValveSoftware/openvr"
@@ -16,12 +16,10 @@ options=('!strip' 'staticlibs')
source=("git+https://github.com/ValveSoftware/openvr.git"
'https://github.com/ValveSoftware/openvr/commit/0fa21ba17748efcca1816536e27bdca70141b074.patch'
'https://github.com/ValveSoftware/openvr/commit/4f9149928e29e9f92e6d8dc39f984d1a557a42b3.patch'
- '0001-fix-VREvent_Data_t-union-in-c-header-and-add-pragma-.patch'
'0001-also-add-pragma-pack-around-VRControllerState_t.patch')
md5sums=('SKIP'
'7350517830b1a0038d30c6ad33b4bb39'
'dfb4306bb93633e467862cd8990e6e79'
- '97bc5ddeee3f2005afdc32b689711131'
'8a9379f8cdf9a38f21942f46378714a5')
pkgver() {
@@ -35,7 +33,6 @@ prepare() {
cd "$srcdir/openvr"
git apply ../0fa21ba17748efcca1816536e27bdca70141b074.patch #https://github.com/ValveSoftware/openvr/pull/594
git apply ../4f9149928e29e9f92e6d8dc39f984d1a557a42b3.patch #https://github.com/ValveSoftware/openvr/pull/805
- git apply ../0001-fix-VREvent_Data_t-union-in-c-header-and-add-pragma-.patch # autogenerated, so no pull request
git apply ../0001-also-add-pragma-pack-around-VRControllerState_t.patch
}
@@ -76,6 +73,7 @@ package() {
done
install -m 755 "$srcdir/openvr/samples/bin/linux64/hellovr_opengl" "$pkgdir/usr/bin"
+ install -m 755 "$srcdir/openvr/samples/bin/hellovr_actions.json" "$pkgdir/usr/"
install -m 755 "$srcdir/openvr/samples/bin/cube_texture.png" "$pkgdir/usr/" #TODO: fix source code to look in proper place
install -m 755 "$srcdir/openvr/samples/bin/linux64/helloworldoverlay" "$pkgdir/usr/bin"
install -m 755 "$srcdir/openvr/samples/bin/linux64/tracked_camera_openvr_sample" "$pkgdir/usr/bin"