summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Haag2020-03-17 03:12:22 +0100
committerChristoph Haag2020-03-17 03:12:22 +0100
commit6a8fc9130ce6ba51c74b46ce0cb9b52fa2e03520 (patch)
treebac59b89cbdb807a56a3c736fd9d149cf948073f
parent4a6da685b1da56fb8933d0b778cc6faf0dd558c1 (diff)
downloadaur-6a8fc9130ce6ba51c74b46ce0cb9b52fa2e03520.tar.gz
update patch
-rw-r--r--.SRCINFO4
-rw-r--r--0001-openvr_capi-Add-pragma-pack-around-VRControllerState.patch14
-rw-r--r--PKGBUILD17
3 files changed, 20 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdc6730db97c..4ca4a14f580f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openvr-git
pkgdesc = API and runtime that allows access to VR hardware from multiple vendors.
- pkgver = 1.9.16.69.39205f6
+ pkgver = 1.10.30.70.26fa19e
pkgrel = 1
url = https://github.com/ValveSoftware/openvr
arch = x86_64
@@ -22,7 +22,7 @@ pkgbase = openvr-git
source = 0003-samples-compat-Use-correct-definition-for-vsprintf_s.patch
source = https://patch-diff.githubusercontent.com/raw/ValveSoftware/openvr/pull/1178.patch
md5sums = SKIP
- md5sums = 177ad5ec0b0714a522c3242fbe312fac
+ md5sums = 79543abcb2f86a8dcfcc942dc32c4090
md5sums = d3dc9d20967362a2e92e3fb1c7f82b57
md5sums = e68ff412ff73b1ca75f8b17ab6c7069a
md5sums = bd5a473153106325233f00b3f35c46d8
diff --git a/0001-openvr_capi-Add-pragma-pack-around-VRControllerState.patch b/0001-openvr_capi-Add-pragma-pack-around-VRControllerState.patch
index cd13f06c1e63..d56dd74bb798 100644
--- a/0001-openvr_capi-Add-pragma-pack-around-VRControllerState.patch
+++ b/0001-openvr_capi-Add-pragma-pack-around-VRControllerState.patch
@@ -1,7 +1,7 @@
-From 82e34cf8220853396a4494ab16431ab7a9d87e34 Mon Sep 17 00:00:00 2001
+From cef0756d3c26317c453132ddfad08cb814c339d5 Mon Sep 17 00:00:00 2001
From: Christoph Haag <christoph.haag@collabora.com>
Date: Wed, 8 Aug 2018 01:06:29 +0200
-Subject: [PATCH 1/3] openvr_capi: Add pragma pack around VRControllerState_t.
+Subject: [PATCH] openvr_capi: Add pragma pack around VRControllerState_t.
See https://github.com/ValveSoftware/SteamVR-for-Linux/issues/35
---
@@ -9,10 +9,10 @@ See https://github.com/ValveSoftware/SteamVR-for-Linux/issues/35
1 file changed, 8 insertions(+)
diff --git a/headers/openvr_capi.h b/headers/openvr_capi.h
-index f6743de..5893e6e 100644
+index 6feb2c6..d263914 100644
--- a/headers/openvr_capi.h
+++ b/headers/openvr_capi.h
-@@ -1995,6 +1995,11 @@ typedef struct VRControllerAxis_t
+@@ -2051,6 +2051,11 @@ typedef struct VRControllerAxis_t
float y;
} VRControllerAxis_t;
@@ -24,7 +24,7 @@ index f6743de..5893e6e 100644
typedef struct VRControllerState_t
{
uint32_t unPacketNum;
-@@ -2002,6 +2007,9 @@ typedef struct VRControllerState_t
+@@ -2058,6 +2063,9 @@ typedef struct VRControllerState_t
uint64_t ulButtonTouched;
struct VRControllerAxis_t rAxis[5]; //struct vr::VRControllerAxis_t[5]
} VRControllerState_t;
@@ -32,8 +32,8 @@ index f6743de..5893e6e 100644
+#pragma pack( pop )
+#endif
- typedef struct Compositor_OverlaySettings
+ typedef struct VRBoneTransform_t
{
--
-2.23.0
+2.25.1
diff --git a/PKGBUILD b/PKGBUILD
index 9a2f89d18488..2dcbe1e48049 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=openvr-git
-pkgver=1.9.16.69.39205f6
+pkgver=1.10.30.70.26fa19e
pkgrel=1
pkgdesc="API and runtime that allows access to VR hardware from multiple vendors."
arch=('x86_64')
@@ -18,7 +18,7 @@ source=("git+https://github.com/ValveSoftware/openvr.git"
'https://patch-diff.githubusercontent.com/raw/ValveSoftware/openvr/pull/1178.patch' # Add ability to build with system installed jsoncpp
)
md5sums=('SKIP'
- '177ad5ec0b0714a522c3242fbe312fac'
+ '79543abcb2f86a8dcfcc942dc32c4090'
'd3dc9d20967362a2e92e3fb1c7f82b57'
'e68ff412ff73b1ca75f8b17ab6c7069a'
'bd5a473153106325233f00b3f35c46d8')
@@ -43,10 +43,15 @@ pkgver() {
prepare() {
cd "$srcdir/openvr"
- git apply "../0001-openvr_capi-Add-pragma-pack-around-VRControllerState.patch"
- git apply "../0002-samples-cmake-Remove-OpenVR-paths-check.patch"
- git apply "../0003-samples-compat-Use-correct-definition-for-vsprintf_s.patch"
- git apply "../1178.patch"
+ for i in \
+ "../0001-openvr_capi-Add-pragma-pack-around-VRControllerState.patch" \
+ "../0002-samples-cmake-Remove-OpenVR-paths-check.patch" \
+ "../0003-samples-compat-Use-correct-definition-for-vsprintf_s.patch" \
+ "../1178.patch"
+ do
+ echo "Applying $i"
+ git apply "$i"
+ done
}
build() {