summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Haag2017-01-31 09:26:56 +0100
committerChristoph Haag2017-01-31 09:26:56 +0100
commit746bdb63462bc1351273d9af7dd8066f61d06e11 (patch)
tree59722ab9b6e84b7e8a72c464bd8b0cc209c4e7e4
parent4c8784e2bdfd03200d3fbeabba37474b146b2049 (diff)
downloadaur-746bdb63462bc1351273d9af7dd8066f61d06e11.tar.gz
OpenVR SDK 1.0.6
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD37
2 files changed, 23 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 716ed1abb544..076e6210cd4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openvr-git
pkgdesc = API and runtime that allows access to VR hardware from multiple vendors. Contains API and samples. The runtime is under SteamVR in Tools on Steam. Note: There's no compositor for linux, so try with hellovr -nocompositor
- pkgver = 41.b967460
+ pkgver = 43.7fa6470
pkgrel = 1
url = https://github.com/ValveSoftware/openvr
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index e1c68b39adab..5416b9adf66a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=openvr-git
-pkgver=41.b967460
+pkgver=43.7fa6470
pkgrel=1
pkgdesc="API and runtime that allows access to VR hardware from multiple vendors. Contains API and samples. The runtime is under SteamVR in Tools on Steam. Note: There's no compositor for linux, so try with hellovr -nocompositor"
arch=('x86_64')
@@ -25,37 +25,44 @@ pkgver() {
prepare() {
cd "$srcdir/openvr"
# Patch for https://github.com/ValveSoftware/openvr/issues/315
- git apply -vvv "$srcdir"/countof.patch
}
build() {
#export CXX=clang++
#export CC=clang
- cd "$srcdir/openvr"
- cd samples
- mkdir -p build
- cd build
+ cd openvr
+ cmake -DBUILD_SHARED=0 -DCMAKE_INSTALL_PREFIX=/usr/ -DCMAKE_BUILD_TYPE=Release .
+ make
+
+ cmake -DBUILD_SHARED=1 -DCMAKE_INSTALL_PREFIX=/usr/ -DCMAKE_BUILD_TYPE=Release .
+ make
- cmake .. -DCMAKE_BUILD_TYPE=Release
+ cd samples
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr/ -Wno-dev .
make
}
package() {
- cd "$srcdir/openvr"
+ #make install DESTDIR="$pkgdir"
+ #make install DESTDIR="$pkgdir"
+ install -d "$pkgdir"/usr/lib
+ install -m 555 openvr/bin/linux64/libopenvr_api.so "$pkgdir/usr/lib"
+ install -m 555 openvr/bin/linux64/libopenvr_api.a "$pkgdir/usr/lib"
- install -d "$pkgdir/usr/lib"
+ cd build-samples
+ #make install DESTDIR="$pkgdir"
install -d "$pkgdir/usr/bin"
- install -d "$pkgdir/usr/include/"
-
- cp -ra "$srcdir/openvr/headers"/* "$pkgdir/usr/include/"
- install "$srcdir/openvr/headers"/* "$pkgdir/usr/include/"
- install -m 555 "$srcdir/openvr/lib/linux64/libopenvr_api.so" "$pkgdir/usr/lib"
install -m 755 "$srcdir/openvr/samples/bin/linux64/hellovr_opengl" "$pkgdir/usr/bin"
+ install -m 755 "$srcdir/openvr/samples/bin/cube_texture.png" "$pkgdir/usr/" #TODO: fix source code to look in proper place
install -m 755 "$srcdir/openvr/samples/bin/linux64/helloworldoverlay" "$pkgdir/usr/bin"
+ install -m 755 "$srcdir/openvr/samples/bin/linux64/tracked_camera_openvr_sample" "$pkgdir/usr/bin"
#install -m 755 "$srcdir/build/samples/hellovr_opengl/run_hellovr.sh" "$pkgdir/usr/bin/run_hellovr.sh"
- install -m 755 "$srcdir/openvr/samples/bin/cube_texture.png" "$pkgdir/usr/" #TODO: fix source code to look in proper place
+
+ install -d "$pkgdir/usr/include/"
+ cp -ra "$srcdir/openvr/headers"/* "$pkgdir/usr/include/"
+ #install "$srcdir/openvr/headers"/* "$pkgdir/usr/include/"
}