summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Haag2018-07-27 18:41:14 +0200
committerChristoph Haag2018-07-27 18:41:14 +0200
commit969fc1b34a8b0baefca8de5dc5f411a16dcee377 (patch)
tree74a2af2f0b8f84f7eb38bb497ebdf4162e57cf0b
parent2213329959a3b61fc620abfd5658609cd9118403 (diff)
downloadaur-969fc1b34a8b0baefca8de5dc5f411a16dcee377.tar.gz
add patch to fix capi
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec599b5a5413..32de44174a1d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue May 15 07:27:29 UTC 2018
+# Fri Jul 27 16:41:12 UTC 2018
pkgbase = openvr-git
pkgdesc = API and runtime that allows access to VR hardware from multiple vendors. Contains API and samples. The runtime is under SteamVR in Tools on Steam.
- pkgver = 1.0.15.r2.g2e9a4de
+ pkgver = 1.0.15.r0.g60eb187
pkgrel = 1
url = https://github.com/ValveSoftware/openvr
arch = x86_64
@@ -20,9 +20,11 @@ pkgbase = openvr-git
options = !strip
options = staticlibs
source = git+https://github.com/ValveSoftware/openvr.git
- source = countof.patch
+ source = https://github.com/ValveSoftware/openvr/commit/0fa21ba17748efcca1816536e27bdca70141b074.patch
+ source = https://github.com/ValveSoftware/openvr/commit/4f9149928e29e9f92e6d8dc39f984d1a557a42b3.patch
md5sums = SKIP
- md5sums = f488b62d4a88e9295adc8762cd82f551
+ md5sums = 7350517830b1a0038d30c6ad33b4bb39
+ md5sums = dfb4306bb93633e467862cd8990e6e79
pkgname = openvr-git
diff --git a/PKGBUILD b/PKGBUILD
index ce95922fa7e7..d4f69515c2d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=openvr-git
-pkgver=1.0.15.r2.g2e9a4de
+pkgver=1.0.15.r0.g60eb187
pkgrel=1
pkgdesc="API and runtime that allows access to VR hardware from multiple vendors. Contains API and samples. The runtime is under SteamVR in Tools on Steam."
arch=('x86_64')
@@ -13,9 +13,10 @@ makedepends=('git' 'cmake' 'qt5-base') #qt5 for the overlayexample
provides=("openvr")
options=('!strip' 'staticlibs')
-source=("git+https://github.com/ValveSoftware/openvr.git" "countof.patch")
+source=("git+https://github.com/ValveSoftware/openvr.git" 'https://github.com/ValveSoftware/openvr/commit/0fa21ba17748efcca1816536e27bdca70141b074.patch' 'https://github.com/ValveSoftware/openvr/commit/4f9149928e29e9f92e6d8dc39f984d1a557a42b3.patch')
md5sums=('SKIP'
- 'f488b62d4a88e9295adc8762cd82f551')
+ '7350517830b1a0038d30c6ad33b4bb39'
+ 'dfb4306bb93633e467862cd8990e6e79')
pkgver() {
cd "$srcdir/openvr"
@@ -26,7 +27,8 @@ pkgver() {
prepare() {
cd "$srcdir/openvr"
- git pull origin pull/594/head --no-edit
+ git apply ../0fa21ba17748efcca1816536e27bdca70141b074.patch #https://github.com/ValveSoftware/openvr/pull/594
+ git apply ../4f9149928e29e9f92e6d8dc39f984d1a557a42b3.patch #https://github.com/ValveSoftware/openvr/pull/805
}
build() {