summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Haag2017-06-15 23:35:32 +0200
committerChristoph Haag2017-06-15 23:37:45 +0200
commitd36bc2029512c947f02e7756573da25696e2e8fb (patch)
treeab8cf0589db998a42398741f32d51a580733edf3
parentdfa6cdad872b64160ad807f5b05641d9eebe3bd4 (diff)
downloadaur-d36bc2029512c947f02e7756573da25696e2e8fb.tar.gz
change pkgver() to the version with tag
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5caf1be69154..ce3134053419 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openvr-git
pkgdesc = API and runtime that allows access to VR hardware from multiple vendors. Contains API and samples. The runtime is under SteamVR in Tools on Steam.
- pkgver = 46.bcac1bf
+ pkgver = 1.0.8.r0.gbcac1bf
pkgrel = 1
url = https://github.com/ValveSoftware/openvr
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 98bd3e4da9be..223a9b2b9516 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=openvr-git
-pkgver=46.bcac1bf
+pkgver=1.0.8.r0.gbcac1bf
pkgrel=1
pkgdesc="API and runtime that allows access to VR hardware from multiple vendors. Contains API and samples. The runtime is under SteamVR in Tools on Steam."
arch=('x86_64')
@@ -19,9 +19,11 @@ md5sums=('SKIP'
pkgver() {
cd "$srcdir/openvr"
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ #echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+
prepare() {
cd "$srcdir/openvr"
}