summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Haag2017-06-15 01:04:49 +0200
committerChristoph Haag2017-06-15 01:04:49 +0200
commitdfa6cdad872b64160ad807f5b05641d9eebe3bd4 (patch)
tree7df77c2e75d5b4d15f8e482c9d4b103d3ed9eefd
parent4f36d07bd9731682a671d92b00c4f5778b2d6c47 (diff)
downloadaur-dfa6cdad872b64160ad807f5b05641d9eebe3bd4.tar.gz
1.0.8 release - disable build of samples
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffb3a627a4be..5caf1be69154 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openvr-git
pkgdesc = API and runtime that allows access to VR hardware from multiple vendors. Contains API and samples. The runtime is under SteamVR in Tools on Steam.
- pkgver = 44.b653929
+ pkgver = 46.bcac1bf
pkgrel = 1
url = https://github.com/ValveSoftware/openvr
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 2e8ced6c07c7..98bd3e4da9be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=openvr-git
-pkgver=44.b653929
+pkgver=46.bcac1bf
pkgrel=1
pkgdesc="API and runtime that allows access to VR hardware from multiple vendors. Contains API and samples. The runtime is under SteamVR in Tools on Steam."
arch=('x86_64')
@@ -40,9 +40,9 @@ build() {
#make
cd samples
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr/ -Wno-dev .
-
- make
+ # samples are broken (1.0.8 release)
+ #cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr/ -Wno-dev .
+ #make
}
package() {
@@ -52,12 +52,14 @@ package() {
install -m 555 openvr/bin/linux64/libopenvr_api.so "$pkgdir/usr/lib"
install -m 555 openvr/bin/linux64/libopenvr_api.a "$pkgdir/usr/lib"
- #make install DESTDIR="$pkgdir"
+ #make install DESTDIR="$pkgdir" #There is no installer for the samples
install -d "$pkgdir/usr/bin"
- install -m 755 "$srcdir/openvr/samples/bin/linux64/hellovr_opengl" "$pkgdir/usr/bin"
- install -m 755 "$srcdir/openvr/samples/bin/cube_texture.png" "$pkgdir/usr/" #TODO: fix source code to look in proper place
- install -m 755 "$srcdir/openvr/samples/bin/linux64/helloworldoverlay" "$pkgdir/usr/bin"
- install -m 755 "$srcdir/openvr/samples/bin/linux64/tracked_camera_openvr_sample" "$pkgdir/usr/bin"
+ #samples are broken (1.0.8 release)
+ #install -m 755 "$srcdir/openvr/samples/bin/linux64/hellovr_opengl" "$pkgdir/usr/bin"
+ #install -m 755 "$srcdir/openvr/samples/bin/cube_texture.png" "$pkgdir/usr/" #TODO: fix source code to look in proper place
+ #install -m 755 "$srcdir/openvr/samples/bin/linux64/helloworldoverlay" "$pkgdir/usr/bin"
+ #install -m 755 "$srcdir/openvr/samples/bin/linux64/tracked_camera_openvr_sample" "$pkgdir/usr/bin"
+
#install -m 755 "$srcdir/build/samples/hellovr_opengl/run_hellovr.sh" "$pkgdir/usr/bin/run_hellovr.sh"
install -d "$pkgdir/usr/include/"