summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2022-11-22 11:09:13 +0100
committerLubosz Sarnecki2022-11-22 11:16:19 +0100
commitf529ecb00845c789459047b386e07a39fc441696 (patch)
treec532885edc136663465532002709366e43a7a95c
parent60ae917f1a20919e25e69f0c7e0a73a67bd4e92e (diff)
downloadaur-f529ecb00845c789459047b386e07a39fc441696.tar.gz
Update to 1.23.7.
* Update github patch hashes. * Fix build issues caused removed enum usage. * Update version.
-rw-r--r--.SRCINFO8
-rw-r--r--0008-hmderrors_public-Remove-usage-of-undefined-enum.patch28
-rw-r--r--PKGBUILD13
3 files changed, 41 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9de6c10ab52..ada654cade21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openvr-git
pkgdesc = API and runtime that allows access to VR hardware from multiple vendors.
- pkgver = 1.16.8.r0.g4c85abc
- pkgrel = 2
+ pkgver = 1.23.7.r0.g08de382
+ pkgrel = 1
url = https://github.com/ValveSoftware/openvr
arch = x86_64
license = custom
@@ -24,12 +24,14 @@ pkgbase = openvr-git
source = https://patch-diff.githubusercontent.com/raw/ValveSoftware/openvr/pull/1178.patch
source = https://patch-diff.githubusercontent.com/raw/ValveSoftware/openvr/pull/1524.patch
source = 0001-Add-include-stdarg.h-to-strtools_public.cpp.patch
+ source = 0008-hmderrors_public-Remove-usage-of-undefined-enum.patch
md5sums = SKIP
md5sums = 4aa6ee8199d86dde2a563b4495f41a53
md5sums = d3dc9d20967362a2e92e3fb1c7f82b57
md5sums = e68ff412ff73b1ca75f8b17ab6c7069a
md5sums = b9ce6c53ec78251d82460f10e07e6645
- md5sums = fb7e22a32ee2f35bd5555d13a5700ba6
+ md5sums = 30e13170804c6d6756d74fa1ee7bdcb0
md5sums = ac790ec12a558931895504f1ca92c364
+ md5sums = 9193a495096b6736d9aeb3ee2bad9808
pkgname = openvr-git
diff --git a/0008-hmderrors_public-Remove-usage-of-undefined-enum.patch b/0008-hmderrors_public-Remove-usage-of-undefined-enum.patch
new file mode 100644
index 000000000000..ce023a8d0d78
--- /dev/null
+++ b/0008-hmderrors_public-Remove-usage-of-undefined-enum.patch
@@ -0,0 +1,28 @@
+From 3d3d8eaaa1b6887e86a379d1f847c0ac2183928d Mon Sep 17 00:00:00 2001
+From: Lubosz Sarnecki <lubosz@gmail.com>
+Date: Tue, 22 Nov 2022 11:04:04 +0100
+Subject: [PATCH 8/8] hmderrors_public: Remove usage of undefined enum.
+
+VRInitError_Init_CreateDriverDirectDeviceFailed was removed in
+OpenVR SDK 1.23.7.
+
+Fixed the build.
+---
+ src/vrcommon/hmderrors_public.cpp | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/vrcommon/hmderrors_public.cpp b/src/vrcommon/hmderrors_public.cpp
+index 6f44d3a..786f249 100644
+--- a/src/vrcommon/hmderrors_public.cpp
++++ b/src/vrcommon/hmderrors_public.cpp
+@@ -180,7 +180,6 @@ const char *GetIDForVRInitError( vr::EVRInitError eError )
+ RETURN_ENUM_AS_STRING( VRInitError_Init_PrismNeedsNewDrivers );
+ RETURN_ENUM_AS_STRING( VRInitError_Init_PrismStartupTimedOut );
+ RETURN_ENUM_AS_STRING( VRInitError_Init_CouldNotStartPrism );
+- RETURN_ENUM_AS_STRING( VRInitError_Init_CreateDriverDirectDeviceFailed );
+ RETURN_ENUM_AS_STRING( VRInitError_Init_PrismExitedUnexpectedly );
+
+ RETURN_ENUM_AS_STRING( VRInitError_Driver_Failed );
+--
+2.38.1
+
diff --git a/PKGBUILD b/PKGBUILD
index d9cf2e28adbc..38002c712921 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=openvr-git
-pkgver=1.16.8.r0.g4c85abc
-pkgrel=2
+pkgver=1.23.7.r0.g08de382
+pkgrel=1
pkgdesc="API and runtime that allows access to VR hardware from multiple vendors."
arch=('x86_64')
url="https://github.com/ValveSoftware/openvr"
@@ -19,14 +19,16 @@ source=("git+https://github.com/ValveSoftware/openvr.git"
'https://patch-diff.githubusercontent.com/raw/ValveSoftware/openvr/pull/1178.patch' # Add ability to build with system installed jsoncpp
'https://patch-diff.githubusercontent.com/raw/ValveSoftware/openvr/pull/1524.patch' # fix broken 1.6.8 build https://github.com/ValveSoftware/openvr/issues/1525
'0001-Add-include-stdarg.h-to-strtools_public.cpp.patch' # missing include for va_start and va_end
+ '0008-hmderrors_public-Remove-usage-of-undefined-enum.patch' # Delete remains of removed enum
)
md5sums=('SKIP'
'4aa6ee8199d86dde2a563b4495f41a53'
'd3dc9d20967362a2e92e3fb1c7f82b57'
'e68ff412ff73b1ca75f8b17ab6c7069a'
'b9ce6c53ec78251d82460f10e07e6645'
- 'fb7e22a32ee2f35bd5555d13a5700ba6'
- 'ac790ec12a558931895504f1ca92c364')
+ '30e13170804c6d6756d74fa1ee7bdcb0'
+ 'ac790ec12a558931895504f1ca92c364'
+ '9193a495096b6736d9aeb3ee2bad9808')
install_examples=false
@@ -45,7 +47,8 @@ prepare() {
"../0003-samples-compat-Use-correct-definition-for-vsprintf_s.patch" \
"../1178.patch" \
"../1524.patch" \
- "../0001-Add-include-stdarg.h-to-strtools_public.cpp.patch"
+ "../0001-Add-include-stdarg.h-to-strtools_public.cpp.patch" \
+ "../0008-hmderrors_public-Remove-usage-of-undefined-enum.patch"
do
echo "Applying $i"
git apply "$i"