summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2016-05-09 15:07:43 +0100
committerWorMzy Tykashi2016-05-09 15:07:43 +0100
commit66bc59865bc701618dd837c91a104b66dccb2f07 (patch)
treef580925d190694659603e437034fd1d2efaad341
parent4a9750bfcd96497ac15db57420cda5970aa79e65 (diff)
downloadaur-66bc59865bc701618dd837c91a104b66dccb2f07.tar.gz
Replace own patch with upstreams
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--abs-fix.patch36
3 files changed, 34 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2dc3261d251..8ec91021329d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openxcom
pkgdesc = An open-source reimplementation of the famous X-COM game
pkgver = 1.0
- pkgrel = 5
+ pkgrel = 6
url = http://openxcom.org/
install = openxcom.install
arch = i686
@@ -23,7 +23,7 @@ pkgbase = openxcom
source = auto_ptr-fix.patch
source = openxcom.install
sha256sums = 45acb280010a01d60506b1c5f2951ae501c012cc6161aac470bd15c1e6981246
- sha256sums = e4e3f082202e47ee7f8e9448d3d8111bba9a67d72f0fea32c3d6af788e7f91fe
+ sha256sums = d80c75b8fe3b5404a10f550f66307abfabc6bec5ed88b417f36222293ccda06c
sha256sums = 40b52c623a71fa8986296e8e6c3c775fe4751fe1846722ef1442bd171ac31a8b
sha256sums = 33a412d870d8c1399738b71f772aaa5954d0028a9c42373ca4a27124c154956d
diff --git a/PKGBUILD b/PKGBUILD
index 9f74d295cdbc..2eb0ac469439 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=openxcom
pkgver=1.0
-pkgrel=5
+pkgrel=6
pkgdesc="An open-source reimplementation of the famous X-COM game"
arch=('i686' 'x86_64')
url="http://openxcom.org/"
@@ -19,7 +19,7 @@ source=("https://github.com/SupSuper/OpenXcom/archive/v1.0.tar.gz"
"auto_ptr-fix.patch"
"${pkgname}.install")
sha256sums=('45acb280010a01d60506b1c5f2951ae501c012cc6161aac470bd15c1e6981246'
- 'e4e3f082202e47ee7f8e9448d3d8111bba9a67d72f0fea32c3d6af788e7f91fe'
+ 'd80c75b8fe3b5404a10f550f66307abfabc6bec5ed88b417f36222293ccda06c'
'40b52c623a71fa8986296e8e6c3c775fe4751fe1846722ef1442bd171ac31a8b'
'33a412d870d8c1399738b71f772aaa5954d0028a9c42373ca4a27124c154956d')
diff --git a/abs-fix.patch b/abs-fix.patch
index 46e3686a490b..fbffbb7fe30e 100644
--- a/abs-fix.patch
+++ b/abs-fix.patch
@@ -1,18 +1,42 @@
-diff -aur a/src/Geoscape/Globe.cpp b/src/Geoscape/Globe.cpp
---- a/src/Geoscape/Globe.cpp 2016-05-09 14:23:24.784162800 +0100
-+++ b/src/Geoscape/Globe.cpp 2016-05-09 14:22:48.994666182 +0100
-@@ -1390,12 +1390,12 @@
+From 49bec0851fc6e5365cac0f71b2c40a80ddf95e77 Mon Sep 17 00:00:00 2001
+From: Louis Delacroix <yoursecretsaresafe@googlemail.com>
+Date: Sun, 16 Nov 2014 20:47:41 +0000
+Subject: [PATCH] Fix use of abs() for floating point arguments
+
+---
+ src/Battlescape/ProjectileFlyBState.cpp | 2 +-
+ src/Geoscape/Globe.cpp | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/Battlescape/ProjectileFlyBState.cpp b/src/Battlescape/ProjectileFlyBState.cpp
+index c890d12..2ea67ae 100644
+--- a/src/Battlescape/ProjectileFlyBState.cpp
++++ b/src/Battlescape/ProjectileFlyBState.cpp
+@@ -651,7 +651,7 @@ int ProjectileFlyBState::getMaxThrowDistance(int weight, int strength, int level
+ if (curZ < 0 && dz < 0) //roll back
+ {
+ dz = std::max(dz, -1.0);
+- if (abs(dz)>1e-10) //rollback horizontal
++ if (std::abs(dz)>1e-10) //rollback horizontal
+ dist -= curZ / dz;
+ break;
+ }
+diff --git a/src/Geoscape/Globe.cpp b/src/Geoscape/Globe.cpp
+index e5249ce..1a360dd 100755
+--- a/src/Geoscape/Globe.cpp
++++ b/src/Geoscape/Globe.cpp
+@@ -1217,12 +1217,12 @@ void Globe::drawVHLine(Surface *surface, double lon1, double lat1, double lon2,
if (fabs(sx)<0.01)
{
- seg = abs( sy/(2*M_PI)*48 );
-+ seg = std::abs( sy/(2*M_PI)*48 );
++ seg = std::abs(sy/(2*M_PI)*48);
if (seg == 0) ++seg;
}
else
{
- seg = abs( sx/(2*M_PI)*96 );
-+ seg = std::abs( sx/(2*M_PI)*96 );
++ seg = std::abs(sx/(2*M_PI)*96);
if (seg == 0) ++seg;
}