summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2018-03-14 15:52:09 +0000
committerWorMzy Tykashi2018-03-14 15:52:09 +0000
commit9df511075b0d183c90497ae733bb7016c26c977b (patch)
tree8bf52d1a4c6f3fb8300c8180831618266ebf0f23
parent0222d781b8e4a7397eb1ab651bdc2ef1f91cb17b (diff)
downloadaur-9df511075b0d183c90497ae733bb7016c26c977b.tar.gz
Fix build, rename patches, drop .install as source file
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--openxcom-abs-fix.patch (renamed from abs-fix.patch)0
-rw-r--r--openxcom-auto_ptr-fix.patch (renamed from auto_ptr-fix.patch)0
-rw-r--r--openxcom-cmath-algorithm-fixes.patch55
5 files changed, 68 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29e67dee759a..f6817af03c6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openxcom
pkgdesc = An open-source reimplementation of the famous X-COM game
pkgver = 1.0
- pkgrel = 6
+ pkgrel = 7
url = https://openxcom.org/
install = openxcom.install
arch = i686
@@ -19,13 +19,13 @@ pkgbase = openxcom
depends = mesa
optdepends = openxcom-data-steam: Original XCom data files from steam
source = openxcom-1.0.tar.gz::https://github.com/SupSuper/OpenXcom/archive/v1.0.tar.gz
- source = abs-fix.patch
- source = auto_ptr-fix.patch
- source = openxcom.install
+ source = openxcom-abs-fix.patch
+ source = openxcom-auto_ptr-fix.patch
+ source = openxcom-cmath-algorithm-fixes.patch
sha256sums = 45acb280010a01d60506b1c5f2951ae501c012cc6161aac470bd15c1e6981246
sha256sums = d80c75b8fe3b5404a10f550f66307abfabc6bec5ed88b417f36222293ccda06c
sha256sums = 40b52c623a71fa8986296e8e6c3c775fe4751fe1846722ef1442bd171ac31a8b
- sha256sums = 33a412d870d8c1399738b71f772aaa5954d0028a9c42373ca4a27124c154956d
+ sha256sums = 3b285e666fc3d37486861b3a17ff156d9b8804167403c58a267bdb69e55c8b86
pkgname = openxcom
diff --git a/PKGBUILD b/PKGBUILD
index d75b025f4064..b08508eced8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=openxcom
pkgver=1.0
-pkgrel=6
+pkgrel=7
pkgdesc="An open-source reimplementation of the famous X-COM game"
arch=('i686' 'x86_64')
url="https://openxcom.org/"
@@ -15,18 +15,19 @@ makedepends=('boost' 'glu' 'xmlto' 'docbook-xml' 'docbook-xsl')
optdepends=('openxcom-data-steam: Original XCom data files from steam')
install="${pkgname}.install"
source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/SupSuper/OpenXcom/archive/v1.0.tar.gz"
- "abs-fix.patch"
- "auto_ptr-fix.patch"
- "${pkgname}.install")
+ "openxcom-abs-fix.patch"
+ "openxcom-auto_ptr-fix.patch"
+ "openxcom-cmath-algorithm-fixes.patch")
sha256sums=('45acb280010a01d60506b1c5f2951ae501c012cc6161aac470bd15c1e6981246'
'd80c75b8fe3b5404a10f550f66307abfabc6bec5ed88b417f36222293ccda06c'
'40b52c623a71fa8986296e8e6c3c775fe4751fe1846722ef1442bd171ac31a8b'
- '33a412d870d8c1399738b71f772aaa5954d0028a9c42373ca4a27124c154956d')
+ '3b285e666fc3d37486861b3a17ff156d9b8804167403c58a267bdb69e55c8b86')
prepare() {
cd OpenXcom-${pkgver}
- patch -p1 -i "${srcdir}/abs-fix.patch"
- patch -p1 -i "${srcdir}/auto_ptr-fix.patch"
+ patch -Np1 -i "${srcdir}/openxcom-abs-fix.patch"
+ patch -Np1 -i "${srcdir}/openxcom-auto_ptr-fix.patch"
+ patch -Np1 -i "${srcdir}/openxcom-cmath-algorithm-fixes.patch"
}
build() {
diff --git a/abs-fix.patch b/openxcom-abs-fix.patch
index fbffbb7fe30e..fbffbb7fe30e 100644
--- a/abs-fix.patch
+++ b/openxcom-abs-fix.patch
diff --git a/auto_ptr-fix.patch b/openxcom-auto_ptr-fix.patch
index e8531642e801..e8531642e801 100644
--- a/auto_ptr-fix.patch
+++ b/openxcom-auto_ptr-fix.patch
diff --git a/openxcom-cmath-algorithm-fixes.patch b/openxcom-cmath-algorithm-fixes.patch
new file mode 100644
index 000000000000..e27d703e6862
--- /dev/null
+++ b/openxcom-cmath-algorithm-fixes.patch
@@ -0,0 +1,55 @@
+diff -aur a/src/Basescape/BaseInfoState.h b/src/Basescape/BaseInfoState.h
+--- a/src/Basescape/BaseInfoState.h 2018-03-14 15:06:59.665628271 +0000
++++ b/src/Basescape/BaseInfoState.h 2018-03-14 15:43:22.067605905 +0000
+@@ -19,6 +19,7 @@
+ #ifndef OPENXCOM_BASEINFOSTATE_H
+ #define OPENXCOM_BASEINFOSTATE_H
+
++#include <cmath>
+ #include "../Engine/State.h"
+
+ namespace OpenXcom
+diff -aur a/src/Basescape/CraftInfoState.h b/src/Basescape/CraftInfoState.h
+--- a/src/Basescape/CraftInfoState.h 2018-03-14 15:02:09.783729176 +0000
++++ b/src/Basescape/CraftInfoState.h 2018-03-14 15:43:16.476703036 +0000
+@@ -19,6 +19,7 @@
+ #ifndef OPENXCOM_CRAFTINFOSTATE_H
+ #define OPENXCOM_CRAFTINFOSTATE_H
+
++#include <cmath>
+ #include "../Engine/State.h"
+
+ namespace OpenXcom
+diff -aur a/src/Engine/Language.h b/src/Engine/Language.h
+--- a/src/Engine/Language.h 2018-03-14 15:11:37.236763021 +0000
++++ b/src/Engine/Language.h 2018-03-14 15:42:14.751775215 +0000
+@@ -23,6 +23,7 @@
+ #include <vector>
+ #include <string>
+ #include <yaml-cpp/yaml.h>
++#include <algorithm>
+ #include "LocalizedText.h"
+ #include "../Savegame/Soldier.h"
+
+diff -aur a/src/Engine/OptionInfo.h b/src/Engine/OptionInfo.h
+--- a/src/Engine/OptionInfo.h 2018-03-14 15:14:50.346384845 +0000
++++ b/src/Engine/OptionInfo.h 2018-03-14 15:42:14.750775233 +0000
+@@ -23,6 +23,7 @@
+ #include <string>
+ #include <map>
+ #include <SDL.h>
++#include <algorithm>
+
+ namespace OpenXcom
+ {
+diff -aur a/src/Savegame/CraftWeapon.h b/src/Savegame/CraftWeapon.h
+--- a/src/Savegame/CraftWeapon.h 2018-03-14 15:27:14.695387913 +0000
++++ b/src/Savegame/CraftWeapon.h 2018-03-14 15:42:14.748775267 +0000
+@@ -21,6 +21,7 @@
+
+ #include <string>
+ #include <yaml-cpp/yaml.h>
++#include <cmath>
+
+ namespace OpenXcom
+ {