summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Thompson2015-06-19 16:08:19 -0400
committerIan Thompson2015-06-19 16:08:19 -0400
commitc78359ef079e37585b2ca5e30ef3d40e9ba48556 (patch)
tree5aff180860139d98911b59c0e6cf2c3237b2904f
downloadaur-c78359ef079e37585b2ca5e30ef3d40e9ba48556.tar.gz
Initial import (v1.0-2)
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD31
-rw-r--r--openxcom.install5
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ba64c895a22
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = openxcom
+ pkgdesc = An open-source reimplementation of the famous X-COM game
+ pkgver = 1.0
+ pkgrel = 2
+ url = http://openxcom.org/
+ install = openxcom.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = boost
+ makedepends = glu
+ makedepends = xmlto
+ makedepends = docbook-xml
+ makedepends = docbook-xsl
+ depends = sdl_gfx
+ depends = sdl_mixer
+ depends = sdl_image
+ depends = yaml-cpp>=0.5
+ depends = mesa
+ source = https://github.com/SupSuper/OpenXcom/archive/v1.0.tar.gz
+ source = openxcom.install
+ sha256sums = 45acb280010a01d60506b1c5f2951ae501c012cc6161aac470bd15c1e6981246
+ sha256sums = 33a412d870d8c1399738b71f772aaa5954d0028a9c42373ca4a27124c154956d
+
+pkgname = openxcom
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a9993ba52b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Ian Thompson <dalrik370 at gmail dot com>
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor: TheBenj88 <thebenj88 *AT* gmail *DOT* com>
+
+pkgname=openxcom
+pkgver=1.0
+pkgrel=2
+pkgdesc="An open-source reimplementation of the famous X-COM game"
+arch=('i686' 'x86_64')
+url="http://openxcom.org/"
+license=('GPL3')
+depends=('sdl_gfx' 'sdl_mixer' 'sdl_image' 'yaml-cpp>=0.5' 'mesa')
+makedepends=('boost' 'glu' 'xmlto' 'docbook-xml' 'docbook-xsl')
+install="${pkgname}.install"
+source=("https://github.com/SupSuper/OpenXcom/archive/v1.0.tar.gz"
+ "${pkgname}.install")
+sha256sums=('45acb280010a01d60506b1c5f2951ae501c012cc6161aac470bd15c1e6981246'
+ '33a412d870d8c1399738b71f772aaa5954d0028a9c42373ca4a27124c154956d')
+
+
+build() {
+ cd "${srcdir}/OpenXcom-1.0"
+ ./autogen.sh
+ ./configure --prefix=/usr --without-docs
+ make
+}
+
+package() {
+ cd "${srcdir}/OpenXcom-1.0"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/openxcom.install b/openxcom.install
new file mode 100644
index 000000000000..5d741f548c1e
--- /dev/null
+++ b/openxcom.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo " OpenXcom requires the original X-COM resources."
+ echo " Copy these game subfolders to /usr/share/openxcom/data:"
+ echo "GEODATA, GEOGRAPH, MAPS, ROUTES, SOUND, TERRAIN, UFOGRAPH, UFOINTRO, UNITS"
+}