summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Thompson2015-10-06 18:06:50 -0400
committerIan Thompson2015-10-06 18:06:50 -0400
commitf03be1c5b65746f62d8c8854048af87e74cad2ea (patch)
treef9d2ae23ce51f20b7c048b9fb9a95d79d314959a
parentc78359ef079e37585b2ca5e30ef3d40e9ba48556 (diff)
downloadaur-f03be1c5b65746f62d8c8854048af87e74cad2ea.tar.gz
Roll back to older version of yaml-cpp
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a9993ba52b9..4900c3a68b18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
pkgname=openxcom
pkgver=1.0
-pkgrel=2
+pkgrel=3
pkgdesc="An open-source reimplementation of the famous X-COM game"
arch=('i686' 'x86_64')
url="http://openxcom.org/"
license=('GPL3')
-depends=('sdl_gfx' 'sdl_mixer' 'sdl_image' 'yaml-cpp>=0.5' 'mesa')
+depends=('sdl_gfx' 'sdl_mixer' 'sdl_image' 'yaml-cpp51' 'mesa')
makedepends=('boost' 'glu' 'xmlto' 'docbook-xml' 'docbook-xsl')
install="${pkgname}.install"
source=("https://github.com/SupSuper/OpenXcom/archive/v1.0.tar.gz"
@@ -21,7 +21,7 @@ sha256sums=('45acb280010a01d60506b1c5f2951ae501c012cc6161aac470bd15c1e6981246'
build() {
cd "${srcdir}/OpenXcom-1.0"
./autogen.sh
- ./configure --prefix=/usr --without-docs
+ YAML_CFLAGS="-I/opt/yaml-cpp51/include" YAML_LIBS="-Wl,-rpath,/opt/yaml-cpp51/lib -L/opt/yaml-cpp51/lib -lyaml-cpp" ./configure --prefix=/usr --without-docs
make
}