summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2024-03-08 23:06:49 +0000
committerWorMzy Tykashi2024-03-08 23:06:49 +0000
commitbd6b18b0b845511c0641d7b135ce82752063ccfc (patch)
treeeab005a946dcd6ef69c0889b5afcabd3d1e526eb
parent99cc084a229f392b61bd0c9cc70b36ab69b66199 (diff)
downloadaur-openxcom-git.tar.gz
Use SPDX-License-Identifier, other QoL improvements
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD32
2 files changed, 36 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69209823d78a..d9db81861b71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,45 +1,45 @@
pkgbase = openxcom-git
pkgdesc = An open-source reimplementation of the famous X-COM game (git-version)
- pkgver = 1.0_r3059_g3af9628ba
+ pkgver = 1.0_r3113_ge2c5a1b45
pkgrel = 1
url = https://openxcom.org/
arch = i686
arch = x86_64
- license = GPL3
- makedepends = git
- makedepends = xmlto
+ license = GPL-3.0-or-later
+ makedepends = boost
+ makedepends = cmake
makedepends = docbook-xml
makedepends = docbook-xsl
makedepends = doxygen
- makedepends = sdl_mixer
- makedepends = sdl_gfx
- makedepends = sdl_image
- makedepends = sdl
- makedepends = yaml-cpp
- makedepends = libgl
makedepends = gcc-libs
- makedepends = glibc
- makedepends = boost
+ makedepends = git
makedepends = glu
- makedepends = cmake
makedepends = hicolor-icon-theme
+ makedepends = libgl
+ makedepends = sdl
+ makedepends = sdl_gfx
+ makedepends = sdl_image
+ makedepends = sdl_mixer
+ makedepends = xmlto
makedepends = xorgproto
+ makedepends = yaml-cpp
source = git+https://github.com/SupSuper/OpenXcom.git
sha256sums = SKIP
pkgname = openxcom-git
pkgdesc = An open-source reimplementation of the famous X-COM game (git-version)
install = openxcom-git.install
- depends = sdl_mixer
- depends = sdl_gfx
- depends = sdl_image
- depends = sdl
- depends = yaml-cpp
- depends = libgl
depends = gcc-libs
depends = glibc
depends = hicolor-icon-theme
+ depends = libgl
+ depends = sdl
+ depends = sdl_gfx
+ depends = sdl_image
+ depends = sdl_mixer
+ depends = yaml-cpp
optdepends = openxcom-data-steam: pacman-tracked X-COM data files from Steam
+ optdepends = openxcom-tftd-data-steam: pacman-tracked Terror From The Deep data files from Steam
provides = openxcom
conflicts = openxcom
diff --git a/PKGBUILD b/PKGBUILD
index 6d999f0cc926..20527d70ccd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,15 @@
pkgbase=openxcom-git
pkgname=('openxcom-git' 'openxcom-docs-git')
_gitname=OpenXcom
-pkgver=1.0_r3059_g3af9628ba
+pkgver=1.0_r3113_ge2c5a1b45
pkgrel=1
pkgdesc="An open-source reimplementation of the famous X-COM game (git-version)"
arch=('i686' 'x86_64')
url="https://openxcom.org/"
-license=('GPL3')
-makedepends=('git' 'xmlto' 'docbook-xml' 'docbook-xsl' 'doxygen' 'sdl_mixer'
- 'sdl_gfx' 'sdl_image' 'sdl' 'yaml-cpp' 'libgl' 'gcc-libs' 'glibc'
- 'boost' 'glu' 'cmake' 'hicolor-icon-theme' 'xorgproto')
+license=('GPL-3.0-or-later')
+makedepends=('boost' 'cmake' 'docbook-xml' 'docbook-xsl' 'doxygen' 'gcc-libs' 'git'
+ 'glu' 'hicolor-icon-theme' 'libgl' 'sdl' 'sdl_gfx' 'sdl_image' 'sdl_mixer'
+ 'xmlto' 'xorgproto' 'yaml-cpp')
source=(git+"https://github.com/SupSuper/${_gitname}.git")
sha256sums=('SKIP')
@@ -21,13 +21,16 @@ pkgver() {
cd ${_gitname}
git describe --long --tags | sed -e 's:^v::;s:\([^-]*-g\):r\1:;s:-:_:g'
}
+
prepare() {
- mkdir -p ${_gitname}/build
+ # Fix manpage install location
+ sed -i 's:openxcom.6 DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man6):openxcom.6 DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/man6):' ${_gitname}/docs/CMakeLists.txt
}
build() {
- cd ${_gitname}/build
- cmake -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE="None" -DDEV_BUILD="Off" ..
+ cmake -B build -S ${_gitname} -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_BUILD_TYPE="None" -DDEV_BUILD="Off"
+ cd build
make
# Make documentation
@@ -37,24 +40,23 @@ build() {
package_openxcom-git() {
pkgdesc="An open-source reimplementation of the famous X-COM game (git-version)"
- depends=('sdl_mixer' 'sdl_gfx' 'sdl_image' 'sdl' 'yaml-cpp' 'libgl' 'gcc-libs'
- 'glibc' 'hicolor-icon-theme')
- optdepends=('openxcom-data-steam: pacman-tracked X-COM data files from Steam')
+ depends=('gcc-libs' 'glibc' 'hicolor-icon-theme' 'libgl' 'sdl' 'sdl_gfx'
+ 'sdl_image' 'sdl_mixer' 'yaml-cpp')
+ optdepends=('openxcom-data-steam: pacman-tracked X-COM data files from Steam'
+ 'openxcom-tftd-data-steam: pacman-tracked Terror From The Deep data files from Steam')
provides=('openxcom')
conflicts=('openxcom')
install="${pkgname}.install"
- cd ${_gitname}/build
+ cd build
make DESTDIR="${pkgdir}" install
- # Fix manpage location
- install -Dm644 "${srcdir}/OpenXcom/docs/openxcom.6" "${pkgdir}/usr/share/man/man6/openxcom.6"
}
package_openxcom-docs-git() {
pkgdesc="Documentation for the open-source reimplementation of the famous X-COM game (git-version)"
arch=('any')
- cd ${_gitname}/build/docs
+ cd build/docs
install -dm755 "${pkgdir}/usr/share/doc/openxcom/"
cp -a html "${pkgdir}/usr/share/doc/openxcom/"
}