summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohan Förberg2017-04-01 18:17:41 +0200
committerJohan Förberg2017-04-01 18:17:41 +0200
commit39caee2590628b60fba6a0c8d2321628a5bd8ecf (patch)
tree7b1fab8fbc1077f38978fbf8f31191c2ed351dd3
downloadaur-openxcom-music-sycraft.tar.gz
Init.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
-rw-r--r--openxcom-music-sycraft.install9
4 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cbc8ca1e5ca4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Apr 1 16:14:21 UTC 2017
+pkgbase = openxcom-music-sycraft
+ pkgdesc = Remixed soundtrack by Sycraft for use with OpenXcom
+ pkgver = 6.0
+ pkgrel = 1
+ url = http://sycraft.org/content/audio/xcom.shtml
+ install = openxcom-music-sycraft.install
+ arch = any
+ license = custom
+ depends = openxcom
+ source = http://sycraft.org/content/audio/xcom/sycraft-xcom-ogg.zip
+ sha1sums = ce71c24495c808a74ee33e00e9b80bfe496c1a97
+
+pkgname = openxcom-music-sycraft
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ad624d3ecf4d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+/*.zip
+/*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75ddd3c405d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Johan Förberg <johan@forberg.se>
+pkgname=openxcom-music-sycraft
+pkgver=6.0
+pkgrel=1
+pkgdesc='Remixed soundtrack by Sycraft for use with OpenXcom'
+arch=(any)
+url=http://sycraft.org/content/audio/xcom.shtml
+depends=(openxcom)
+install=openxcom-music-sycraft.install
+license=(custom)
+
+source=(http://sycraft.org/content/audio/xcom/sycraft-xcom-ogg.zip)
+sha1sums=('ce71c24495c808a74ee33e00e9b80bfe496c1a97')
+
+prepare() {
+ cd "$srcdir"
+
+ # Extract 'license' part of readme per Arch packaging standards.
+ sed -n '1,2p; 20,23p' Sycraft_music_readme.txt > LICENSE
+}
+
+package() {
+ cd "$srcdir"
+
+ install -Dm644 *.ogg Sycraft_music_readme.txt -t "$pkgdir/usr/share/openxcom/UFO/SOUND"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/openxcom-music-sycraft.install b/openxcom-music-sycraft.install
new file mode 100644
index 000000000000..cb3569d82ce6
--- /dev/null
+++ b/openxcom-music-sycraft.install
@@ -0,0 +1,9 @@
+ufodir=/usr/share/openxcom/UFO
+post_install() {
+ [ -f "$ufodir/GEODATA/WORLD.DAT" ] && exit
+
+ echo ">>> It seems your XCOM/UFO data files are not installed in the"
+ echo " standard directory $ufodir. The Sycraft"
+ echo " soundtrack will not be automatically detected unless it is"
+ echo " installed into the same directory as your XCOM data files."
+}