summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Lange2019-04-05 17:59:55 +1100
committerRobin Lange2019-04-05 17:59:55 +1100
commit654d4b14e7718542a6d4d5b608ebb2091e0e0e43 (patch)
tree616b218cfa639db83e21b1b820fca6d029d93456
parent3b0d2113016a73ef167a5740f346267c9c1400c4 (diff)
downloadaur-654d4b14e7718542a6d4d5b608ebb2091e0e0e43.tar.gz
Fixed pkgver() returning empty string
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c68d22b9d81..ca8b1886a5b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = optimus-manager-git
pkgdesc = Management utility to handle GPU switching for Optimus laptops (Git version)
- pkgver = r274.6d8572c
- pkgrel = 1
+ pkgver = r275.56fd2d8
+ pkgrel = 2
url = https://github.com/Askannz/optimus-manager
arch = any
license = MIT
@@ -19,7 +19,7 @@ pkgbase = optimus-manager-git
backup = etc/optimus-manager/xorg-nvidia.conf
backup = etc/optimus-manager/xsetup-intel.sh
backup = etc/optimus-manager/xsetup-nvidia.sh
- source = git+https://github.com/Askannz/optimus-manager.git
+ source = git+https://github.com/Askannz/optimus-manager.git#branch=master
sha256sums = SKIP
pkgname = optimus-manager-git
diff --git a/PKGBUILD b/PKGBUILD
index 775be05fb0a6..1d4e92345b5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Robin Lange <robin dot langenc at gmail dot com>
# Contributor: Robin Lange <robin dot langenc at gmail dot com>
pkgname=optimus-manager-git
-pkgver=r274.6d8572c
-pkgrel=1
+pkgver=r275.56fd2d8
+pkgrel=2
pkgdesc="Management utility to handle GPU switching for Optimus laptops (Git version)"
arch=('any')
url="https://github.com/Askannz/optimus-manager"
@@ -16,11 +16,11 @@ backup=('etc/optimus-manager/xorg-intel.conf'
'etc/optimus-manager/xorg-nvidia.conf'
'etc/optimus-manager/xsetup-intel.sh'
'etc/optimus-manager/xsetup-nvidia.sh')
-source=("git+https://github.com/Askannz/optimus-manager.git")
+source=("git+https://github.com/Askannz/optimus-manager.git#branch=master")
sha256sums=('SKIP')
pkgver() {
- cd $_pkgname
+ cd "${srcdir}/optimus-manager/"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}