summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmar Pakker2017-05-12 16:09:58 +0200
committerOmar Pakker2017-05-12 16:09:58 +0200
commit2f17031801a10caf5195c53dcfebeb9afc4065b4 (patch)
tree412aef0454a1dc3fe5f11265da312a77a1453c76
downloadaur-oracle-sgdc-bin.tar.gz
Initial package. User has to manually supply the SGDC source tar.
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD43
-rw-r--r--oracle-sgdc.install53
-rw-r--r--osgdc.pngbin0 -> 56290 bytes
4 files changed, 125 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39fc42c5af29
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = oracle-sgdc-bin
+ pkgdesc = The Oracle Secure Global Desktop Client allows you to connect to an Oracle Secure Global Desktop server.
+ pkgver = 5.20.921
+ pkgrel = 1
+ url = http://www.oracle.com/us/technologies/virtualization/secure-global-desktop/overview/index.html
+ install = oracle-sgdc.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = gendesk
+ depends = lib32-libxpm
+ depends = lib32-libxinerama
+ depends = lib32-libxcursor
+ depends = lib32-libxkbfile
+ depends = lib32-openmotif
+ provides = oracle-sgdc
+ conflicts = oracle-sgdc
+ source = osgdc.png
+ source = sgdcfile://sgdci3li.tar
+ sha256sums = 866e0a618b330ba28d70fbdd3ad43d25e182587f50f88dbbe28543aa28a09378
+ sha256sums = SKIP
+ depends_i686 = libxpm
+ depends_i686 = libxinerama
+ depends_i686 = libxcursor
+ depends_i686 = libxkbfile
+ depends_i686 = openmotif
+
+pkgname = oracle-sgdc-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fcb140f89d28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Omar Pakker <archlinux@opakker.nl>
+
+_pkgname=oracle-sgdc
+pkgname=${_pkgname}-bin
+pkgver="5.20.921"
+pkgrel=1
+pkgdesc="The Oracle Secure Global Desktop Client allows you to connect to an Oracle Secure Global Desktop server."
+arch=('i686' 'x86_64')
+url="http://www.oracle.com/us/technologies/virtualization/secure-global-desktop/overview/index.html"
+license=('unknown')
+depends_i686=('libxpm' 'libxinerama' 'libxcursor' 'libxkbfile' 'openmotif')
+depends_x86_64=('lib32-libxpm' 'lib32-libxinerama' 'lib32-libxcursor' 'lib32-libxkbfile' 'lib32-openmotif')
+makedepends=('gendesk')
+provides=('oracle-sgdc')
+conflicts=('oracle-sgdc')
+install=${_pkgname}.install
+source=("osgdc.png" "sgdcfile://sgdci3li.tar")
+sha256sums=('866e0a618b330ba28d70fbdd3ad43d25e182587f50f88dbbe28543aa28a09378'
+ 'SKIP')
+
+DLAGENTS+=('sgdcfile::/usr/bin/echo "Please obtain the Oracle SGD client tar (sgdci3li.tar) manually and put it next to the PKGBUILD. It can be obtained from an SGD server or from the Oracle eDelivery network SGD RPM files (opt/tarantella/var/docroot/client/sgdci3li.tar)"')
+
+pkgver() {
+ printf "%s" $(sed -n '/^PRODUCT_VERSION_FULL=/s,^PRODUCT_VERSION_FULL=,,p' "${srcdir}/sgdc/install")
+}
+
+prepare() {
+ # Create .desktop file.
+ gendesk -f -n \
+ --pkgname "${_pkgname}" \
+ --pkgdesc "${pkgdesc}" \
+ --name "Oracle Secure Global Desktop Client" \
+ --genericname "Remote Desktop" \
+ --comment "Oracle SGD client for connecting to Oracle SGD servers." \
+ --exec "/usr/bin/ttatcc -prompt" \
+ --categories "Network;RemoteAccess;"
+}
+
+package() {
+ install -Dm644 "${srcdir}/osgdc.png" "${pkgdir}/usr/share/pixmaps/oracle-sgdc.png"
+ install -Dm644 "${srcdir}/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+ install -Dm755 "${srcdir}/sgdc/ttatcc" "${pkgdir}/usr/bin/ttatcc"
+}
diff --git a/oracle-sgdc.install b/oracle-sgdc.install
new file mode 100644
index 000000000000..a283d6ed930b
--- /dev/null
+++ b/oracle-sgdc.install
@@ -0,0 +1,53 @@
+_SUNRAY_CONF_PATH="/etc/opt/SUNWut/utadmin.conf"
+_SUNRAY_LICPOOL_DIR="/var/cache/osgd"
+
+post_install() {
+ # Perform the necessary steps for enabling the sharing of Windows client licenses with the Sun Ray Windows Connector.
+
+ # Check for the presence of the SunRay conf file.
+ if [ -f "${_SUNRAY_CONF_PATH}" ]; then
+ # Share licenses with Windows connector.
+
+ # Parse Sun Ray conf file, and extract the value of admin.srwc.groupname.
+ local awk_prog='$1 == "admin.srwc.groupname" {print $3}'
+ local admin_groupname=$(awk "${awk_prog}" "${_SUNRAY_CONF_PATH}")
+
+ # Change the group ownership of the installed tcc to the group obtained above
+ chgrp "${admin_groupname}" "/usr/bin/ttatcc"
+ if [ $? -ne 0 ]; then
+ # We don't want to set GID the binary if we haven't changed the group!
+ return
+ fi
+
+ # Set the group ID bit in the tcc binary permissions
+ chmod g+s "/usr/bin/ttatcc"
+ if [ $? -ne 0 ]; then
+ echo "Error setting group permissions on ttatcc."
+ fi
+ else
+ # Create the license pool directory used for sharing Windows client licenses between users.
+ if [ ! -d "${_SUNRAY_LICPOOL_DIR}" ]; then
+ mkdir -p "${_SUNRAY_LICPOOL_DIR}"> /dev/null 2>&1
+ if [ $? -ne 0 ]; then
+ # Creation failed. Abort.
+ return
+ fi
+ fi
+
+ # Set it to be world readable, writeable and executable
+ chmod 777 "${_SUNRAY_LICPOOL_DIR}"
+ if [ $? -ne 0 ]; then
+ echo "Error setting permissions on the pool directory."
+ fi
+ fi
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ rm -rf "${_SUNRAY_LICPOOL_DIR}"
+
+ echo "Delete the folder ~/.tarantella if you want to clear your user data."
+}
diff --git a/osgdc.png b/osgdc.png
new file mode 100644
index 000000000000..72990268308a
--- /dev/null
+++ b/osgdc.png
Binary files differ