summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Enck2018-04-10 19:52:00 -0400
committerSean Enck2018-04-10 19:52:00 -0400
commit696a23b4611c0e0b164352c206dac10d298ec3da (patch)
tree8dc2a10598217dd98c577e3e3f66be10e93bd2d8
parent4f4b7ddefe50e1524166ecdd7d98e0d8d4bcc610 (diff)
downloadaur-696a23b4611c0e0b164352c206dac10d298ec3da.tar.gz
per https://github.com/oragono/oragono/issues/121 update config, service, and remove rotate
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--oragono-rotate11
-rw-r--r--oragono.service3
-rw-r--r--path.patch29
5 files changed, 26 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 321ad5de3c58..68f55cc6be71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,12 +14,10 @@ pkgbase = oragono
source = git+https://github.com/oragono/oragono-vendor
source = oragono.service
source = path.patch
- source = oragono-rotate
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 131097e2803dee6f0b00de41b80fb790a44dd6c90bf1b1004078535150ff64cc
- sha256sums = 25a1c0f764283059e95088f3b9cb66fe6a0c95df0d9dc8375856f41097c04fb0
- sha256sums = 896f394a7c62ce7961778c4664a02ffe0370ccec9a7f2569fb7d0b9119632d4b
+ sha256sums = 88cf6274839ac8d9f32f9a81068d11e762ddfc28f8fada305b693a8524e593ce
+ sha256sums = 8972e3fc24d0aca75614048f14487b6eb1e43a9edf212626f5a74b59f1051d8c
pkgname = oragono
diff --git a/PKGBUILD b/PKGBUILD
index 13d34d8c39ce..0a87ee934cdf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,13 +13,11 @@ makedepends=('go' 'git')
source=("git+$url#tag=v$pkgver"
"git+https://github.com/oragono/oragono-vendor"
"oragono.service"
- "path.patch"
- "oragono-rotate")
+ "path.patch")
sha256sums=('SKIP'
'SKIP'
- '131097e2803dee6f0b00de41b80fb790a44dd6c90bf1b1004078535150ff64cc'
- '25a1c0f764283059e95088f3b9cb66fe6a0c95df0d9dc8375856f41097c04fb0'
- '896f394a7c62ce7961778c4664a02ffe0370ccec9a7f2569fb7d0b9119632d4b')
+ '88cf6274839ac8d9f32f9a81068d11e762ddfc28f8fada305b693a8524e593ce'
+ '8972e3fc24d0aca75614048f14487b6eb1e43a9edf212626f5a74b59f1051d8c')
backup=('etc/oragono.conf')
build() {
export GOPATH=$(pwd)/..
@@ -28,7 +26,7 @@ build() {
git submodule init
git config submodule.vendor.url $srcdir/oragono-vendor
git submodule update
- patch -p0 < ../path.patch
+ patch -p1 < ../path.patch
cd vendor/github.com/$pkgname
rm -rf $pkgname
mkdir -p $pkgname
@@ -42,7 +40,6 @@ build() {
package() {
local _conf=/var/lib/oragono/
install -Dm 644 oragono.service $pkgdir/usr/lib/systemd/system/oragono.service
- install -Dm 644 oragono-rotate $pkgdir/etc/logrotate.d/oragono
cd ${srcdir}/$pkgname
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
cd build/linux
diff --git a/oragono-rotate b/oragono-rotate
deleted file mode 100644
index 95ccfbaf8f7a..000000000000
--- a/oragono-rotate
+++ /dev/null
@@ -1,11 +0,0 @@
-/var/log/oragono.log {
- copytruncate
- monthly
- compress
- missingok
- notifempty
- rotate 12
- postrotate
- pkill --signal 1 oragono
- endscript
-}
diff --git a/oragono.service b/oragono.service
index 811b631712e7..d15d68cc9850 100644
--- a/oragono.service
+++ b/oragono.service
@@ -1,9 +1,12 @@
[Unit]
Description=A modern IRC server written in Go
+After=network.target
[Service]
Type=simple
ExecStart=/usr/bin/oragono run --conf /etc/oragono.conf
+ExecReload=/bin/kill -HUP $MAINPID
+Restart=on-failure
[Install]
WantedBy=multi-user.target
diff --git a/path.patch b/path.patch
index 097ce6d67df4..139398d4a086 100644
--- a/path.patch
+++ b/path.patch
@@ -1,6 +1,8 @@
---- oragono.yaml 2017-06-26 09:52:22.638430466 -0400
-+++ ../../oragono.conf 2017-06-26 09:52:54.349010749 -0400
-@@ -24,8 +24,8 @@
+diff --git a/oragono.yaml b/oragono.yaml
+index 0d72a0b..23b80ac 100644
+--- a/oragono.yaml
++++ b/oragono.yaml
+@@ -21,8 +21,8 @@ server:
tls-listeners:
# listener on ":6697"
":6697":
@@ -11,26 +13,29 @@
# strict transport security, to get clients to automagically use TLS
sts:
-@@ -62,8 +62,7 @@
- #password: ""
+@@ -52,7 +52,7 @@ server:
# motd filename
-- # if you change the motd, you should move it to ircd.motd
+ # if you change the motd, you should move it to ircd.motd
- motd: oragono.motd
+ motd: /var/lib/oragono/ircd.motd
- # maximum length of clients' sendQ in bytes
- # this should be big enough to hold /LIST and HELP replies
-@@ -214,7 +213,7 @@
- method: file stderr
+ # motd formatting codes
+ # if this is true, the motd is escaped using formatting codes like $c, $b, and $i
+@@ -236,10 +236,10 @@ logging:
+ # file log to given target filename
+ # stdout log to stdout
+ # stderr log to stderr
+- method: file stderr
++ method: stdout stderr
# filename to log to, if file method is selected
- filename: ircd.log
-+ filename: /var/log/oragono.log
++ #filename: ircd.log
# type(s) of logs to keep here. you can use - to exclude those types
#
-@@ -256,7 +255,7 @@
+@@ -289,7 +289,7 @@ debug:
# datastore configuration
datastore:
# path to the datastore