summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Orcsik2016-09-12 14:52:13 +0200
committerMarius Orcsik2016-09-12 14:52:13 +0200
commit6089f94f2c27c6540a1e9b5d0a5636e80bfaf60e (patch)
tree20eb317df622273f6b407f08a505291d1b74cfec
downloadaur-6089f94f2c27c6540a1e9b5d0a5636e80bfaf60e.tar.gz
Initial commit for orion-git
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD43
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b954aaba579b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = orion-git
+ pkgdesc = QML/C++-written desktop client for Twitch.tv
+ pkgver = r205.3339da5
+ pkgrel = 1
+ url = https://github.com/alamminsalo/orion
+ arch = x86_64
+ arch = x86
+ license = GPL
+ makedepends = git
+ depends = libcommuni-git
+ provides = orion
+ conflicts = orion
+ source = git+https://github.com/alamminsalo/orion.git
+ md5sums = SKIP
+
+pkgname = orion-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d15c695be2db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Marius Orcsik <marius@littr.me>
+pkgname=orion-git # '-bzr', '-git', '-hg' or '-svn'
+pkgver=r205.3339da5
+pkgrel=1
+pkgdesc="QML/C++-written desktop client for Twitch.tv"
+arch=('x86_64' 'x86')
+url="https://github.com/alamminsalo/orion"
+license=('GPL')
+groups=()
+depends=('libcommuni-git')
+makedepends=('git') # 'bzr', 'git', 'mercurial' or 'subversion'
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/alamminsalo/orion.git')
+noextract=()
+md5sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+
+# Git, tags available
+ #printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ mkdir "build" && cd "./build"
+ qmake ../
+ make
+}
+
+package() {
+ cp -r "$srcdir/${pkgname%-git}" "$pkgdir"
+}