summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Orcsik2016-09-12 19:31:47 +0200
committerMarius Orcsik2016-09-12 19:31:47 +0200
commit7c5bce3b282be6d3c40f7c39c76ee895f6990e43 (patch)
treed1995fc9bd56fed1cd0086d72b52054a3f249807
parentb40993fd818385dc504ea21bdefcbee66101706d (diff)
downloadaur-7c5bce3b282be6d3c40f7c39c76ee895f6990e43.tar.gz
Fixing the packaging of the application
-rw-r--r--.SRCINFO4
-rw-r--r--Orion.desktop10
-rw-r--r--PKGBUILD19
3 files changed, 27 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b954aaba579b..63bca1bd3c0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,7 +11,9 @@ pkgbase = orion-git
provides = orion
conflicts = orion
source = git+https://github.com/alamminsalo/orion.git
- md5sums = SKIP
+ source = Orion.desktop
+ sha256sums = SKIP
+ sha256sums = a0bb773176dd7ec448ecd5702da9c32b35da27ea3070b23496fe51abb15d8d44
pkgname = orion-git
diff --git a/Orion.desktop b/Orion.desktop
new file mode 100644
index 000000000000..e16a6211f3ca
--- /dev/null
+++ b/Orion.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Orion
+Icon=/usr/share/icons/orion.svg
+Exec=/usr/bin/orion
+Comment=Seek and watch streams on Twitch
+Categories=Games;
+Terminal=false
+StartupWMClass=orion
diff --git a/PKGBUILD b/PKGBUILD
index 6a1fc9fa859c..397b5fcc07f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,9 +15,13 @@ replaces=()
backup=()
options=()
install=
-source=('git+https://github.com/alamminsalo/orion.git')
+source=('git+https://github.com/alamminsalo/orion.git'
+ 'Orion.desktop'
+)
+
noextract=()
-md5sums=('SKIP')
+sha256sums=('SKIP'
+ 'a0bb773176dd7ec448ecd5702da9c32b35da27ea3070b23496fe51abb15d8d44')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -28,11 +32,16 @@ pkgver() {
build() {
cd "$srcdir/${pkgname%-git}"
- mkdir "build" && cd "./build"
- qmake ../
+ qmake
make
}
package() {
- cp -r "$srcdir/${pkgname%-git}" "$pkgdir"
+ mkdir -p "$pkgdir/usr/share/icons"
+ mkdir -p "$pkgdir/usr/share/applications"
+ mkdir -p "$pkgdir/usr/bin"
+
+ cp "$srcdir/${pkgname%-git}/orion.svg" "$pkgdir/usr/share/icons/"
+ cp "./Orion.desktop" "$pkgdir/usr/share/applications/"
+ cp "$srcdir/${pkgname%-git}/orion" "$pkgdir/usr/bin/"
}