summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Orcsik2016-10-10 12:27:28 +0200
committerMarius Orcsik2016-10-10 12:29:20 +0200
commit9789a7fe59297fa74edc6282544e85e78f18449c (patch)
treef4d6197726f3bb54ec6b0a5fea4d1cc14bcd472d
parent90f9e3266a23dde7d82fec89ab8237aaa17ecb01 (diff)
downloadaur-9789a7fe59297fa74edc6282544e85e78f18449c.tar.gz
Fixed an issue with displaying the icon in menus
suggested by user hamzadis
-rw-r--r--.SRCINFO4
-rw-r--r--Orion.desktop2
-rw-r--r--PKGBUILD11
3 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0eba6d296bfb..f878d2cde853 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = orion-git
pkgdesc = QML/C++-written desktop client for Twitch.tv
- pkgver = r238.46ce6ae
+ pkgver = r245.98c9217
pkgrel = 1
url = https://github.com/alamminsalo/orion
arch = x86_64
@@ -24,7 +24,7 @@ pkgbase = orion-git
source = git+https://github.com/alamminsalo/orion.git
source = Orion.desktop
sha256sums = SKIP
- sha256sums = a0bb773176dd7ec448ecd5702da9c32b35da27ea3070b23496fe51abb15d8d44
+ sha256sums = 18d7d2da72a83e5228fa210961fe78d28eda65e680b5887d13ae369e3fed503c
pkgname = orion-git
diff --git a/Orion.desktop b/Orion.desktop
index e16a6211f3ca..c8e6cf11e498 100644
--- a/Orion.desktop
+++ b/Orion.desktop
@@ -2,7 +2,7 @@
Version=1.0
Type=Application
Name=Orion
-Icon=/usr/share/icons/orion.svg
+Icon=orion
Exec=/usr/bin/orion
Comment=Seek and watch streams on Twitch
Categories=Games;
diff --git a/PKGBUILD b/PKGBUILD
index ed4f620d48d0..c0618a89027e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: HabarNam <habarnam@gmail.com>
-pkgname=orion-git # '-bzr', '-git', '-hg' or '-svn'
-pkgver=r238.46ce6ae
+# Improvements by: hamzadis <adis@hamzadis.com>
+pkgname=orion-git
+pkgver=r245.98c9217
pkgrel=1
pkgdesc="QML/C++-written desktop client for Twitch.tv"
arch=('x86_64' 'x86')
@@ -22,7 +23,7 @@ source=('git+https://github.com/alamminsalo/orion.git'
noextract=()
sha256sums=('SKIP'
- 'a0bb773176dd7ec448ecd5702da9c32b35da27ea3070b23496fe51abb15d8d44')
+ '18d7d2da72a83e5228fa210961fe78d28eda65e680b5887d13ae369e3fed503c')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -38,11 +39,11 @@ build() {
}
package() {
- mkdir -p "$pkgdir/usr/share/icons"
+ mkdir -p "$pkgdir/usr/share/icons/hicolor/scalable/apps/"
mkdir -p "$pkgdir/usr/share/applications"
mkdir -p "$pkgdir/usr/bin"
- cp "$srcdir/${pkgname%-git}/orion.svg" "$pkgdir/usr/share/icons/"
+ cp "$srcdir/${pkgname%-git}/orion.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/"
cp "./Orion.desktop" "$pkgdir/usr/share/applications/"
cp "$srcdir/${pkgname%-git}/orion" "$pkgdir/usr/bin/"
}