summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrédéric Mangano-Tarumi2020-03-29 20:46:25 -0400
committerFrédéric Mangano-Tarumi2020-03-29 20:46:25 -0400
commit24b2071f993585869e981bc187f4522a9bf338fe (patch)
tree6c94e292f2bf3d1338c7a905337d7bc2f50d604c
parent5dc0aeffd48971a2154ed1a4a5403bfd2a312df7 (diff)
downloadaur-24b2071f993585869e981bc187f4522a9bf338fe.tar.gz
oshu 2.0.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a51bf586242..5ac25621f0e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Mar 21 11:29:17 UTC 2018
+# Mon Mar 30 00:20:46 UTC 2020
pkgbase = oshu
pkgdesc = Fast port of the osu! rhythm game
- pkgver = 2.0.0
+ pkgver = 2.0.1
pkgrel = 1
url = https://github.com/fmang/oshu/
arch = i686
@@ -14,7 +14,7 @@ pkgbase = oshu
depends = ffmpeg
depends = cairo
depends = pango
- source = https://www.mg0.fr/oshu/releases/oshu-2.0.0.tar.gz
+ source = https://www.mg0.fr/oshu/releases/oshu-2.0.1.tar.gz
sha256sums = 43d25bee21a4932c6e17a9a667fcd8b8459960f1da6eca63e426fb85be963ad1
pkgname = oshu
diff --git a/PKGBUILD b/PKGBUILD
index 875af163caba..8b54f82998d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Frédéric Mangano-Tarumi <fmang+aur mg0.fr>
pkgname='oshu'
-pkgver=2.0.0
+pkgver=2.0.1
pkgrel=1
pkgdesc='Fast port of the osu! rhythm game'
url='https://github.com/fmang/oshu/'
@@ -9,14 +9,14 @@ arch=('i686' 'x86_64')
license=('GPL3')
depends=('sdl2' 'sdl2_image' 'ffmpeg' 'cairo' 'pango')
makedepends=('cmake')
-source=("https://www.mg0.fr/oshu/releases/$pkgname-$pkgver.tar.gz")
-sha256sums=('43d25bee21a4932c6e17a9a667fcd8b8459960f1da6eca63e426fb85be963ad1')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/fmang/oshu/archive/$pkgver.tar.gz")
+sha256sums=('ae538aa02aa6058d0dc9db2b60feb07edda5f62c4cc6a3d8efae7d918a7c1003')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- mkdir build
+ mkdir -p build
cd build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DOSHU_DEFAULT_SKIN=osu
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DOSHU_DEFAULT_SKIN=osu
make
}